Subject: [mpls] Pipelining the inevitable adoption poll on draft-nainar-mpls-rfc8287-len-clarification

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 26 Feb 2019 11:20:26 -0000

Hi,

Since Loa is polling for IPR, I suspect an adoption poll is likely to
follow.

I know this document arises from confusion during interop, and I have some
sympathy with people who find RFCs hard to parse. I also understand that the
AD rejected fixing this through an Errata Report, and so the only option is
to publish an RFC (the motivation here appears to be that consensus is
needed for the resolution).

IMHO, 8029 is clear on how to set the length of a TLV or sub-TLV. The
sub-TLV length includes all of the fields of the sub-TLV, but not any
trailing padding. The TLV length includes all of the sub-TLV padding.

Thus, the only issue I can see here was that there was confusion about
whether fields marked as "Reserved" formed part of the sub-TLVs. The only
reason they would be, would be to allow for future extensions, otherwise
they would just be padding.

Clearly (according to this document) they were intended to be part of the
sub-TLVs (for extensions). That is inconsistent with how 8029 is written,
but since 8287 uses "Reserved" not "MBZ" it is acceptable if that is really
want people want to achieve (i.e., that is the consensus decision that is
needed).

Doesn't that mean that the *only* text needed is to say...
"Fields marked 'Reserved' in sub-TLVs defined in RFC 8287 are an integral
part of the sub-TLVs and MUST be accounted in computation of the length of
the sub-TLVs."?

The current draft seems like a lot of text to make that clarification.

Thanks,
Adrian

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Loa Andersson
Sent: 26 February 2019 07:09
To: [email-masked]
Cc: [email-masked];
[email-masked]
Subject: [mpls] IPR poll on draft-nainar-mpls-rfc8287-len-clarification

Working Group, authors,

We have started to prepare draft-nainar-mpls-rfc8287-len-clarification
for working group adoption, prior to the wgap we need to do an IPR poll.

This mail starts this IPR poll.

Are you aware of any IPR that applies to 
draft-nainar-mpls-rfc8287-len-clarification?

If so, has this IPR been disclosed in compliance with IETF IPR rules
(see RFCs 3979, 4879, 3669 and 5378 for more details).

There no IPR disclosures against draft-nainar-mpls-rfc8287-len-
clarification.

If you are listed as a document author or contributor please respond to
this email regardless of whether or not you are aware of any relevant
IPR. *The response needs to be sent to the MPLS WG mailing list.* The
document will not advance to the next stage until a response has been
received from each author and contributor.

If you are on the MPLS WG email list but are not listed as an author or
contributor, then please explicitly respond only if you are aware of any
IPR that has not yet been disclosed in conformance with IETF rules.

/Loa
  mpls wg co-chair
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 26 Feb 2019 11:55:00 +0000

Adrian,

Just to make it clear, I have filed the erratum  on RFC 8287 (which, I believe is the singular form while errata is plural) that has been rejected by Deborah because "This change requires an update to the RFC, requires consensus".

I agree that we could make the draft somewhat shorter  - but not by much: the part that looks too long to you takes roughly 2 pages out of 5.5.

The added value is that the current version means that the implementer does not have to do any length calculations (that always carry with them the risk of miscalculations): everything is spelled out in the same way as it is in RFC 8029.

I also think that when the "reserved" field is explicitly defined as following:

<quote>
   Reserved

      The Reserved field MUST be set to 0 when sent and MUST be ignored
      on receipt.

<end quote>

it is somewhat different to distinguish it from a "true" MBZ field: What's in a name?

And I do not think that this field has been intended for the future sub-TLVs since it itself is part of a sub-TLV.

The bottom line: I think that the draft is ready for adoption by the WG. If the WG, following adoption, requests to make it shorter, we can do that.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Adrian Farrel
Sent: Tuesday, February 26, 2019 1:20 PM
To: 'Loa Andersson' <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [mpls] Pipelining the inevitable adoption poll on draft-nainar-mpls-rfc8287-len-clarification

Hi,

Since Loa is polling for IPR, I suspect an adoption poll is likely to follow.

I know this document arises from confusion during interop, and I have some sympathy with people who find RFCs hard to parse. I also understand that the AD rejected fixing this through an Errata Report, and so the only option is to publish an RFC (the motivation here appears to be that consensus is needed for the resolution).

IMHO, 8029 is clear on how to set the length of a TLV or sub-TLV. The sub-TLV length includes all of the fields of the sub-TLV, but not any trailing padding. The TLV length includes all of the sub-TLV padding.

Thus, the only issue I can see here was that there was confusion about whether fields marked as "Reserved" formed part of the sub-TLVs. The only reason they would be, would be to allow for future extensions, otherwise they would just be padding.

Clearly (according to this document) they were intended to be part of the sub-TLVs (for extensions). That is inconsistent with how 8029 is written, but since 8287 uses "Reserved" not "MBZ" it is acceptable if that is really want people want to achieve (i.e., that is the consensus decision that is needed).

"Fields marked 'Reserved' in sub-TLVs defined in RFC 8287 are an integral part of the sub-TLVs and MUST be accounted in computation of the length of the sub-TLVs."?

Thanks,

Adrian

-----Original Message-----

From: mpls <[email-masked]<mailto:[email-masked]>> On Behalf Of Loa Andersson

To: [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>;

[email-masked]<mailto:[email-masked]>

Working Group, authors,

Are you aware of any IPR that applies to draft-nainar-mpls-rfc8287-len-clarification?

If so, has this IPR been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

There no IPR disclosures against draft-nainar-mpls-rfc8287-len- clarification.

If you are listed as a document author or contributor please respond to this email regardless of whether or not you are aware of any relevant IPR. *The response needs to be sent to the MPLS WG mailing list.* The document will not advance to the next stage until a response has been received from each author and contributor.

If you are on the MPLS WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

/Loa

  mpls wg co-chair

--

Loa Andersson                        email: [email-masked]<mailto:[email-masked]>

Senior MPLS Expert

mpls mailing list

[email-masked]<mailto:[email-masked]>

mpls mailing list

[email-masked]<mailto:[email-masked]>

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 26 Feb 2019 12:55:16 -0000

Hmmm,

I think I am now erring towards agreeing with you having found 8029 ss3.9.
That has three trailing MBZ bytes, but still has a length of 4.

I'm still not sure that reproducing the figures is necessary, but if you
phrase the text as "this figure replaces that figure" it'll work out OK.

A

From: Alexander Vainshtein <[email-masked]> 
Sent: 26 February 2019 11:55
To: [email-masked]
Cc: [email-masked];
[email-masked]; 'Loa Andersson'
<[email-masked]>; [email-masked]
Subject: RE: [mpls] Pipelining the inevitable adoption poll on
draft-nainar-mpls-rfc8287-len-clarification

Adrian,

Just to make it clear, I have filed the erratum  on RFC 8287 (which, I
believe is the singular form while errata is plural) that has been rejected
by Deborah because "This change requires an update to the RFC, requires
consensus". 

I agree that we could make the draft somewhat shorter  - but not by much:
the part that looks too long to you takes roughly 2 pages out of 5.5.

The added value is that the current version means that the implementer does
not have to do any length calculations (that always carry with them the risk
of miscalculations): everything is spelled out in the same way as it is in
RFC 8029.

I also think that when the "reserved" field is explicitly defined as
following:

<quote>

   Reserved

      on receipt.

<end quote>

it is somewhat different to distinguish it from a "true" MBZ field: What's
in a name?

And I do not think that this field has been intended for the future sub-TLVs
since it itself is part of a sub-TLV.

The bottom line: I think that the draft is ready for adoption by the WG. If
the WG, following adoption, requests to make it shorter, we can do that.

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]
<mailto:[email-masked]> 

-----Original Message-----
From: mpls <[email-masked] <mailto:[email-masked]> > On Behalf
Of Adrian Farrel
Sent: Tuesday, February 26, 2019 1:20 PM
To: 'Loa Andersson' <[email-masked] <mailto:[email-masked]> >; [email-masked]
<mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> ;
[email-masked]
<mailto:[email-masked]> 
Subject: [mpls] Pipelining the inevitable adoption poll on
draft-nainar-mpls-rfc8287-len-clarification

Hi,

Thanks,

Adrian

-----Original Message-----

From: mpls < <mailto:[email-masked]> [email-masked]> On Behalf
Of Loa Andersson

To:  <mailto:[email-masked]> [email-masked]

Cc:  <mailto:[email-masked]> [email-masked];

 <mailto:[email-masked]>
[email-masked]

Working Group, authors,

If so, has this IPR been disclosed in compliance with IETF IPR rules (see
RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor please respond to this
email regardless of whether or not you are aware of any relevant IPR. *The
response needs to be sent to the MPLS WG mailing list.* The document will
not advance to the next stage until a response has been received from each
author and contributor.

If you are on the MPLS WG email list but are not listed as an author or
contributor, then please explicitly respond only if you are aware of any IPR
that has not yet been disclosed in conformance with IETF rules.

/Loa

  mpls wg co-chair

-- 

Loa Andersson                        email:  <mailto:[email-masked]> [email-masked]

Senior MPLS Expert

mpls mailing list

 <mailto:[email-masked]> [email-masked]

 <https://www.ietf.org/mailman/listinfo/mpls>
https://www.ietf.org/mailman/listinfo/mpls

mpls mailing list

 <mailto:[email-masked]> [email-masked]

 <https://www.ietf.org/mailman/listinfo/mpls>
https://www.ietf.org/mailman/listinfo/mpls

This e-mail message is intended for the recipient only and contains
information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have
received this 
transmission in error, please inform us by e-mail, phone or fax, and then
delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 26 Feb 2019 14:32:38 +0000

Adrian,
I have looked up 8029 again,(that is explicitly defined and I see that in all the cases when a trailing MBZ field is defined, its length is included in the explicitly defined length of the sub-TLV.

As for adding the text that accompanies the figures: I do not see any issue with adding  that these figures replace the figures in 8029 (they are indeed different because they contain explicitly defined length). Hopefully this can be done after adoption.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: Adrian Farrel <[email-masked]>
Sent: Tuesday, February 26, 2019 2:55 PM
To: Alexander Vainshtein <[email-masked]>
Cc: [email-masked]; [email-masked]; 'Loa Andersson' <[email-masked]>; [email-masked]
Subject: RE: [mpls] Pipelining the inevitable adoption poll on draft-nainar-mpls-rfc8287-len-clarification

Hmmm,

I think I am now erring towards agreeing with you having found 8029 ss3.9. That has three trailing MBZ bytes, but still has a length of 4.

I'm still not sure that reproducing the figures is necessary, but if you phrase the text as "this figure replaces that figure" it'll work out OK.

A

From: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Sent: 26 February 2019 11:55
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'Loa Andersson' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [mpls] Pipelining the inevitable adoption poll on draft-nainar-mpls-rfc8287-len-clarification

Adrian,

<quote>
   Reserved

<end quote>

Regards,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]<mailto:[email-masked]>

-----Original Message-----
From: mpls <[email-masked]<mailto:[email-masked]>> On Behalf Of Adrian Farrel
Sent: Tuesday, February 26, 2019 1:20 PM
To: 'Loa Andersson' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [mpls] Pipelining the inevitable adoption poll on draft-nainar-mpls-rfc8287-len-clarification

Hi,

Thanks,

Adrian

-----Original Message-----

Working Group, authors,

/Loa

  mpls wg co-chair

--

Senior MPLS Expert

mpls mailing list

mpls mailing list