Subject: [mpls] Opsdir last call review of draft-ietf-mpls-egress-protection-framework-05

From: Scott Bradner via Datatracker <[email-masked]>
Date: Sun, 16 Jun 2019 18:46:06 -0700

Reviewer: Scott Bradner
Review result: Has Nits

I did an OPS-DIR review of MPLS Egress Protection Framework
(draft-ietf-mpls-egress-protection-framework) – The document describes a
protection mechanism for the egress links of an MPLS network.  The function
described looks quitter useful (at least for multi homed sites that are using
MPLS services)

I did not find any operational issues of note and consider the document ready
for publication except for one ops-related observation.  I did not see any
discussion of how a management station would be notified if a protection
circuit were to be utilized.  It seems to me that is something that a network
operation would like to know. I admit to not knowing how a network operator
knows when any of the fast reroute techniques are engaged so I may be missing
some basic fact about how MPLS networks are operated and monitored but some
words of guidance would seem to be useful or some alert function added to the
node that does the switching would be helpful

---

From: Yimin Shen <[email-masked]>
Date: Tue, 25 Jun 2019 14:11:48 +0000

Hi Scott,

Thanks very much for your OPS-DIR review for this draft!

As you already mentioned, when a local repair takes an effect on the router of PLR (point of local repair), the router should generally produce a message, event or alert, and the operator at a management station can be notified. This is generic, and also applicable to the egress protection in this draft. The mode (e.g. push vs. pull), channel, and protocol used by the PLR to communicate with the management station may vary depending on vendors, and hence it is out of the scope of this draft. We will add some text to clarify this in the next version.

Thanks,

-- Yimin Shen

On 6/16/19, 9:46 PM, "mpls on behalf of Scott Bradner via Datatracker" <[email-masked] on behalf of [email-masked]> wrote:

    Reviewer: Scott Bradner
    Review result: Has Nits

    _______________________________________________
    mpls mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mpls&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=2-nT7xvtgxYac4wpYxwo_jh5rZM2uwTLxgRhaObwYug&m=XVV33QA8GH14GrK9u4qYyBRqJIfC4hhDd1z9SkOtlUk&s=_JQ8Ij7tM0t_F4m1l8PfwScUCfoOSNN8-uVDFZF3uGk&e=