Subject: Re: [mpls] Yangdoctors early review of draft-ietf-mpls-static-yang-09

From: Tarek Saad <[email-masked]>
Date: Thu, 12 Sep 2019 15:27:36 +0000

Hi Andy,

Thanks for your review and comments. We have uploaded a new revision that addresses your comments.
https://tools.ietf.org/html/draft-ietf-mpls-static-yang-10

Inline for more details.

On 7/22/19, 12:54 PM, "Andy Bierman via Datatracker" <[email-masked]> wrote:

    Reviewer: Andy Bierman
    Review result: Ready with Nits
    
    - No pyang warnings or errors
    - No noticeable typos or omissions
    
    Nits:
     - contact info includes WG Chairs; this was removed in the new usage guidelines
[TS]: removed.

    Questions:
     - The ietf-mpls-static-extended module is used instead of a YANG feature.
       Is the generic name 'extended' appropriate? What will the next module used to
       avoid a YANG feature be called? extended2?
[TS]: there are multiple models (at IETF) that have adopted similar approach of grouping non-base data in a separate module named as 'xxx-extended'. One argument was to enforce the base model be supported without any feature check - and hence makes it simpler to understand. Not sure I have an answer for names of future extended modules, but maybe extended-<feature1>, extended-<feature2>, etc.?

Regards,
Tarek

---

From: Andy Bierman <[email-masked]>
Date: Thu, 12 Sep 2019 22:02:37 -0700

Hi,

OK thanks,

Andy

On Thu, Sep 12, 2019 at 8:27 AM Tarek Saad <[email-masked]> wrote:

> [TS]: there are multiple models (at IETF) that have adopted similar
> approach of grouping non-base data in a separate module named as
> 'xxx-extended'. One argument was to enforce the base model be supported
> without any feature check - and hence makes it simpler to understand. Not
> sure I have an answer for names of future extended modules, but maybe
> extended-<feature1>, extended-<feature2>, etc.?
>
> Regards,
> Tarek
>
>
>