Subject: [mpls] Updated rev -08 posted [Re: Éric Vyncke's No Objection on draft-ietf-mpls-ldp-yang-07: (with COMMENT)]

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Fri, 28 Feb 2020 04:44:18 +0000

Eric, 
Thanks for your review and comments.
We have posted a new rev -08 that takes care of your comments and comments from other IESG reviewers.
On behalf of authors, please see further inline [skraza]:

    ----------------------------------------------------------------------
    COMMENT:
    ----------------------------------------------------------------------
    
    Thank you for the work put into this document.
    
    I fully support Ben Kaduk's DISCUSS about IPv6 (about why IPv6 is in the
    extended section 6.1.2).  I would have balloted a DISCUSS if Ben haven't
    balloted before me.
[skraza]: Please see our response to Ben's review.
    
    Also concerned about Suresh's question about the "rw ipv4 (or ipv6)" in section
    6.2.1. and 6.2.2. and other places. Thank you, though, for the IPv6 example in
    Appendix A.

[skraza]: Fixed. Also, Added more IPv6 in examples.
    
    Answers to my COMMENTs below will be welcome,
    
    Regards,
    
    -éric
    == COMMENTS ==
    
    -- Section 4 --
    Why having the YANG subtrees for IPv4 and IPv6 different order of their
    subtrees in ietf-mpls-ldp/mpls-ldp/address-families/ipv[46] ?

[skraza]: This is due to augmentation and pyang tools puts the augmentation at the very end - this ordering is not controlled by us but the tool.
    
    -- Section 5.1.2 --
    Another difference about IPv4 and IPv6 in the tree: IPv6 has an "enable" leaf
    but IPv4 does not. Why is that ?
    
[skraza]: IPv4 was/is defacto AFI for LDP and was enabled by default in all implementations. LDPv6 was an add-on and was enabled on demand - hence "enable" is needed here.
BTW, conversely, a "disable" leaf is provided under ipv4.if someone wants to disable IPv4. 

    -- Section 5.2.1.1. --
    In the text "this document recommends an operator to pick a routable IPv4
    unicast address as an LSR Id", what is meant by "routable" ? Globally routable
    ? Domain routable ?
    
[skraza]: LDP typically works within IGP domain so I'd say IGP routing domain or perhaps just routing domain.
Added the text in the draft.

    Also, it is expected that design recommendations are done in a document about
    data model?
 
[skraza]: Fair point but this LSR-ID topic had been an important one in the context of manageability of LDP, we thought it better to highlight and recommend.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 28 Feb 2020 07:13:25 +0000

Thank you for addressing my COMMENTs

-éric

-----Original Message-----
From: "Kamran Raza (skraza)" <[email-masked]>
Date: Friday, 28 February 2020 at 05:44
To: Eric Vyncke <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Tarek Saad <[email-masked]>, Nicolai Leymann <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Updated rev -08 posted [Re: Éric Vyncke's No Objection on draft-ietf-mpls-ldp-yang-07: (with COMMENT)]

    Eric, 

        

    

        Regards,
        
        -éric
        == COMMENTS ==
        
        -- Section 4 --

        -- Section 5.1.2 --

        -- Section 5.2.1.1. --