Subject: [mpls] Updated rev -09 posted [Re: Éric Vyncke's Discuss on draft-ietf-mpls-ldp-yang-08: (with DISCUSS and COMMENT)]

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Fri, 20 Mar 2020 21:48:28 +0000

Eric,

I have posted rev -09 where we have moved I-D.ietf-rtgwg-policy-model to normative reference.
Hope this addresses last of your comment.

Rgds.
--
Kamran

On 2020-03-18, 7:03 AM, "Éric Vyncke via Datatracker" <[email-masked]> wrote:

    ----------------------------------------------------------------------
    DISCUSS:
    ----------------------------------------------------------------------
    
    Thank you for addressing my previous comments (especially around the IPv6
    support).
    
    But, I am now balloting a DISCUSS because I-D.ietf-rtgwg-policy-model  MUST be
    a normative reference as it is referenced by the YANG modules of this document.
    I.e., this document cannot be published _BEFORE_ I-D.ietf-rtgwg-policy-model
    ... Else, it will be useless.
    
    Regards
    
    -éric

    ----------------------------------------------------------------------
    COMMENT:
    ----------------------------------------------------------------------
    
    Thank you for the work put into this document.
    
    I fully support Ben Kaduk's DISCUSS about IPv6 (about why IPv6 is in the
    extended section 6.1.2).  I would have balloted a DISCUSS if Ben haven't
    balloted before me.
    
    Also concerned about Suresh's question about the "rw ipv4 (or ipv6)" in section
    6.2.1. and 6.2.2. and other places. Thank you, though, for the IPv6 example in
    Appendix A.
    
    Answers to my COMMENTs below will be welcome,
    
    Regards,
    
    -éric
    == COMMENTS ==
    
    -- Section 4 --
    Why having the YANG subtrees for IPv4 and IPv6 different order of their
    subtrees in ietf-mpls-ldp/mpls-ldp/address-families/ipv[46] ?
    
    -- Section 5.1.2 --
    Another difference about IPv4 and IPv6 in the tree: IPv6 has an "enable" leaf
    but IPv4 does not. Why is that ?
    
    -- Section 5.2.1.1. --
    In the text "this document recommends an operator to pick a routable IPv4
    unicast address as an LSR Id", what is meant by "routable" ? Globally routable
    ? Domain routable ?
    
    Also, it is expected that design recommendations are done in a document about
    data model?

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 23 Mar 2020 08:32:48 +0000

Kamran,

Thank you for the final edit, I have cleared my DISCUSS and balloted a 'no objection' to publish this document.

Regards

-éric

-----Original Message-----
From: "Kamran Raza (skraza)" <[email-masked]>
Date: Friday, 20 March 2020 at 22:48
To: Eric Vyncke <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Nicolai Leymann <[email-masked]>, Tarek Saad <[email-masked]>, "BRUNGARD, DEBORAH A" <[email-masked]>
Subject: Updated rev -09 posted [Re: Éric Vyncke's Discuss on draft-ietf-mpls-ldp-yang-08: (with DISCUSS and COMMENT)]

    Eric,

    Rgds.
    --
    Kamran

        

        
        Regards
        
        -éric

        

        
        Regards,
        
        -éric
        == COMMENTS ==
        
        -- Section 4 --
        
        -- Section 5.1.2 --
        
        -- Section 5.2.1.1. --