Subject: [mpls] Martin Duke's No Objection on draft-ietf-mpls-sfl-framework-10: (with COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Fri, 18 Sep 2020 12:36:42 -0700

Martin Duke has entered the following ballot position for
draft-ietf-mpls-sfl-framework-10: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mpls-sfl-framework/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I counted a total of three normative requirements in this document, none of
them earth-shattering, and wonder if this could be changed to Informational and
perhaps the important requirements moved into drafts that provide interoperable
specs. ISTM that asking implementers to implement both this and a draft that
describes an actual protocol is unnecessarily heavyweight.

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 18 Sep 2020 22:07:29 +0000

Hi Martin,

I'll answer quick as I'm sure other ADs may wonder also. The document was initially Informational. The Gen-ART reviewer, Pete Resnick, questioned why it was not PS and felt quite strongly it should be. After discussing among the authors and Chairs, we decided it does specify a technique which both ends need to support to provide this capability and so changed to PS. We did another IETF Last Call.

MPLS is the protocol - no other protocol documents. So it is very lightweight as it combines the framework and methodology.

MPLS has many variations in how the labels can be done. So while there are only three normative requirements, they are the keys to doing this technique.

Thanks for your early review!
Good weekends!
Deborah

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Martin Duke via Datatracker
Sent: Friday, September 18, 2020 3:37 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] Martin Duke's No Objection on draft-ietf-mpls-sfl-framework-10: (with COMMENT)

Please refer to https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=0VBYv7sShKZNYlrD1uoYT-brYS0w9on4DNmsvukVx5Y&s=8lOvWapGF2hK-ZGIf_tNHhHxSIIQRnBVUdobA8WuK1w&e= 
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dmpls-2Dsfl-2Dframework_&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=0VBYv7sShKZNYlrD1uoYT-brYS0w9on4DNmsvukVx5Y&s=XrO9xL1da8ehaZjd8irjhvx2ZBQU6vjrQC30ZGoVr2k&e= 

_______________________________________________
mpls mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mpls&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=0VBYv7sShKZNYlrD1uoYT-brYS0w9on4DNmsvukVx5Y&s=jwjYdJflTJ_X1n--ldXiVkuiv8m-7STm90o3KZGnPXE&e=

---

From: Martin Duke <[email-masked]>
Date: Fri, 18 Sep 2020 15:46:32 -0700

Very well, thanks for the explanation.

On Fri, Sep 18, 2020 at 3:07 PM BRUNGARD, DEBORAH A <[email-masked]> wrote:

> Hi Martin,
>
> I'll answer quick as I'm sure other ADs may wonder also. The document was
> initially Informational. The Gen-ART reviewer, Pete Resnick, questioned why
> it was not PS and felt quite strongly it should be. After discussing among
> the authors and Chairs, we decided it does specify a technique which both
> ends need to support to provide this capability and so changed to PS. We
> did another IETF Last Call.
>
> MPLS is the protocol - no other protocol documents. So it is very
> lightweight as it combines the framework and methodology.
>
> MPLS has many variations in how the labels can be done. So while there are
> only three normative requirements, they are the keys to doing this
> technique.
>
> Subject: [mpls] Martin Duke's No Objection on
> draft-ietf-mpls-sfl-framework-10: (with COMMENT)
>
> Please refer to
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=0VBYv7sShKZNYlrD1uoYT-brYS0w9on4DNmsvukVx5Y&s=8lOvWapGF2hK-ZGIf_tNHhHxSIIQRnBVUdobA8WuK1w&e=