Subject: [mpls] NFFRR

From: Kireeti Kompella <[email-masked]>
Date: Thu, 17 Sep 2020 07:27:28 -0700

Hi All,

We have a prototype implementation of NFFRR in Junos.  The packet
forwarding code was easier to write using a well-known SPL rather than a
configured or signaled label.  This implementation is specifically for the
EVPN multihoming case -- to prevent loops if the CE is down rather than a
link to the CE, but the principle is the same for other NFFRR cases.

Given that, and the fact that the problem is real, the solution implemented
and the draft reasonably comprehensive and stable, the authors request WG
adoption.

-- 
Kireeti

---

From: Michael Menth <[email-masked]>
Date: Thu, 17 Sep 2020 17:01:03 +0200

Hi Kireeti, all,

interesting to see this in MPLS. We've done a similar feature (Advanced
Loop Detection and Termination, ALDT) for destination-based forwarding
with LFAs and did some evaluations:

D. Merling, W. Braun, and M. Menth: Efficient Data Plane Protection for
SDN, in Proceedings of the 4th IEEE Conference on Network Softwarization
(NetSoft), June 2018, Montreal, Canada.
https://atlas.informatik.uni-tuebingen.de/~menth/papers/Menth18g.pdf

We've implemented a prototype on the P4-based Tofino from barefoot, a
paper is to come.

Regards,

Michael

Am 17.09.2020 um 16:27 schrieb Kireeti Kompella:
> configured or signaled label.  This implementation is specifically for
> the EVPN multihoming case -- to prevent loops if the CE is down rather
> than a link to the CE, but the principle is the same for other NFFRR cases.
> 
> Given that, and the fact that the problem is real, the solution
> implemented and the draft reasonably comprehensive and stable, the
> authors request WG adoption.
> 
> -- 
> Kireeti
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
> 

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 18 Sep 2020 21:57:09 +0000

Hi Kireeti,
Can you post a link to the draft? Tried searching with author criteria and still didn’t find it.
Thanks,
Acee

From: mpls <[email-masked]> on behalf of Kireeti Kompella <[email-masked]>
Date: Thursday, September 17, 2020 at 10:28 AM
To: "[email-masked]" <[email-masked]>
Subject: [mpls] NFFRR

Hi All,

We have a prototype implementation of NFFRR in Junos.  The packet forwarding code was easier to write using a well-known SPL rather than a configured or signaled label.  This implementation is specifically for the EVPN multihoming case -- to prevent loops if the CE is down rather than a link to the CE, but the principle is the same for other NFFRR cases.

Given that, and the fact that the problem is real, the solution implemented and the draft reasonably comprehensive and stable, the authors request WG adoption.

--
Kireeti

---

From: Binny Jeshan <[email-masked]>
Date: Mon, 21 Sep 2020 01:31:28 +0530

I guess it's this: https://tools.ietf.org/html/draft-kompella-mpls-nffrr-00
?

On Sat, 19 Sep 2020 at 03:27, Acee Lindem (acee) <acee=
[email-masked]> wrote:

> *From: *mpls <[email-masked]> on behalf of Kireeti Kompella <
> [email-masked]>
> *Date: *Thursday, September 17, 2020 at 10:28 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[mpls] NFFRR
>
>
>
> Hi All,
>
>
>
> implemented and the draft reasonably comprehensive and stable, the authors
> request WG adoption.
>
>
>
> --
>
> Kireeti