Subject: Re: [mpls] Barry Leiba's No Objection on draft-ietf-mpls-base-yang-15: (with COMMENT)

From: Tarek Saad <[email-masked]>
Date: Tue, 20 Oct 2020 15:00:38 +0000

Thanks Barry for your thorough review and comments. We have posted rev -16 (https://tools.ietf.org/html/draft-ietf-mpls-base-yang-16)  of the document and have addressed all your comments.
Please see inline for responses… [TS]

On 9/3/20, 11:18 PM, "Barry Leiba via Datatracker" <[email-masked]> wrote:

    [External Email. Be cautious of content]

    Barry Leiba has entered the following ballot position for
    draft-ietf-mpls-base-yang-15: No Objection

    When responding, please keep the subject line intact and reply to all
    email addresses included in the To and CC lines. (Feel free to cut this
    introductory paragraph, however.)

    Please refer to https://urldefense.com/v3/__https://www.ietf.org/iesg/statement/discuss-criteria.html__;!!NEt6yMaO-gk!VoJLrKKmaM1UHV_t0IgMn7LUqo-Bad0ISmXXYQJ3wv77doalWhBZ-vw5DGJFsQ$
    for more information about IESG DISCUSS and COMMENT positions.

    The document, along with other ballot positions, can be found here:
    https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-mpls-base-yang/__;!!NEt6yMaO-gk!VoJLrKKmaM1UHV_t0IgMn7LUqo-Bad0ISmXXYQJ3wv77doalWhBZ-vyojA8JRg$

    ----------------------------------------------------------------------
    COMMENT:
    ----------------------------------------------------------------------

    The document sometimes says “YANG model” and sometimes “YANG module”.  It
    should use the correct term and be consistent, no?
[TS]: thanks, we acted on this comment and normalized use of YANG data model and YANG module.

    I note that there is BCP 14 boilerplate here but no BCP 14 key words in the
    document.  The shepherd writeup notes that also and says that the shepherd
    wanted to discuss this with the authors... but there is no resolution to that.
    Did the shepherd discuss it with the authors?  Should some “must”s become
    “MUST”s?  Or should the boilerplate and references be removed?
[TS]: we removed BCP 14 boilerplate.

    — Section 1 —

       The MPLS base model also defines a new instance of the generic RIB
       model as defined in {!RFC8349}} to store native MPLS routes.

    What is the notation around RFC8349?  Does it mean something, or is it a markup
    artifact that needs to be fixed during editing?
[TS]: this is markup that needed fixing. Fixed now.

Regards,
Tarek

Juniper Business Use Only

---

From: Barry Leiba <[email-masked]>
Date: Wed, 21 Oct 2020 14:28:41 -0400

Thanks, Tarek.

Barry