Subject: Re: [mpls] Working Group Last Call : draft-ietf-mpls-lsp-ping-registries-update-04

From: Shraddha Hegde <[email-masked]>
Date: Mon, 9 Nov 2020 07:32:24 +0000

I have read the -05 version of the document and find it useful and clear on IANA code point
Registry usage. I have a question on the registry update.
The TLVs and sub-TLV registry "vendor private" code points has been update to " FCFS" while the
Message type/return code etc registry types have been left as "private use".
Any specific reason for not changing them to "FCFS" ?

Rgds
Shraddha

Juniper Business Use Only

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Adrian Farrel
Sent: Thursday, September 24, 2020 10:02 PM
To: 'mpls' <[email-masked]>
Cc: [email-masked]
Subject: [mpls] Working Group Last Call : draft-ietf-mpls-lsp-ping-registries-update-04

[External Email. Be cautious of content]

Hi MPLS WG,

As previously noted, I'm the shepherd for this document and I'm running the working group last call as agreed by the chairs.

This email starts a two-week last call on
draft-ietf-mpls-lsp-ping-registries-update-04
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-registries-update/__;!!NEt6yMaO-gk!VW78XGy-uR3ChuXVvRR0JKhySp_wD_Uq4kMjc1Bpc8jk-JZRx6oojaG4eBsY_Edo$

Please send your opinions to the mailing list before October 9th.

While yes/no opinions are not without value, it is far more helpful if you can indicate whether you have read the latest version of the draft, and what the reasons are for your opinions.

Of course, all of your review comments will be helpful in improving the document.

Best,
Adrian

_______________________________________________
mpls mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/mpls__;!!NEt6yMaO-gk!VW78XGy-uR3ChuXVvRR0JKhySp_wD_Uq4kMjc1Bpc8jk-JZRx6oojaG4eNVcT4XQ$

---

From: Loa Andersson <[email-masked]>
Date: Mon, 9 Nov 2020 17:08:30 +0800

Shraddha,

I have been waiting for that question. The reason I did not change to FCFS is that there are only four “private use” code points. If you make them FCFS there is a risk that they will be used up very quickly. IANA documents the allocation of FCFS code points, so as soon as the fourth code is allocated, they are gone. 

This is true for Message Types, Reply Modes and Return Codes. 

In all fairness I did not think keeping them “private use” was ideal, but it was the least harmful alternative I could find. 

T

/Loa 

Sent from my iPhone

> On 9 Nov 2020, at 15:32, Shraddha Hegde <shraddha=[email-masked]> wrote:
> 
> https://www.ietf.org/mailman/listinfo/mpls