Subject: [mpls] I-D Action: draft-ietf-mpls-sr-epe-oam-01.txt

From: [email-masked]
Date: Thu, 19 Nov 2020 10:06:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiprotocol Label Switching WG of the IETF.

        Title           : Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) Egress Peer Engineering Segment Identifiers (SIDs) with MPLS Data Planes
        Authors         : Shraddha Hegde
                          Kapil Arora
                          Mukul Srivastava
                          Samson Ninan
                          Xiaohu Xu
	Filename        : draft-ietf-mpls-sr-epe-oam-01.txt
	Pages           : 16
	Date            : 2020-11-19

Abstract:
   Egress Peer Engineering (EPE) is an application of Segment Routing to
   Solve the problem of egress peer selection.  The Segment Routing
   based BGP-EPE solution allows a centralized controller, e.g. a
   Software Defined Network (SDN) controller to program any egress peer.
   The EPE solution requires a node to program the PeerNode Segment
   Identifier(SID) describing a session between two nodes, the PeerAdj
   SID describing the link (one or more) that is used by sessions
   between peer nodes, and the PeerSet SID describing an arbitrary set
   of sessions or links between a local node and its peers.  This
   document provides new sub-TLVs for EPE Segment Identifiers (SID) that
   would be used in the MPLS Target stack TLV (Type 1), in MPLS Ping and
   Traceroute procedures.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mpls-sr-epe-oam/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-mpls-sr-epe-oam-01
https://datatracker.ietf.org/doc/html/draft-ietf-mpls-sr-epe-oam-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-sr-epe-oam-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 19 Nov 2020 18:10:19 +0000

Dear WG members,

latest version of the draft draft-ietf-mpls-sr-epe-oam posted

During WG adoption call, there were comments to exclude the
Interface address details from the PeerNode Sid and PeerSet SID
Target FEC TLV. The DDMT validation will ensure control plane
And forwarding plane synchronization between the two routers.
The validation of controller's state with actual forwarding state on the
Nodes will have to be validated externally by controller/application.

In this regard following changes have been done

1.	Removed interface address from PeerNode SID and PeerSet SID
2.	Updated validation procedures
3.	Added text to describe the validation scope 

Let me know if you have any further comment on the document.

Rgds
Shraddha

Juniper Business Use Only

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, November 19, 2020 11:37 PM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] I-D Action: draft-ietf-mpls-sr-epe-oam-01.txt

[External Email. Be cautious of content]

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-mpls-sr-epe-oam/__;!!NEt6yMaO-gk!QPh2Vo48Sr0CDWRyLzyNWGNptl23yk8Llnk29de7n1B4rqakopyA8ssT6NGIZ14B$

There are also htmlized versions available at:
https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-mpls-sr-epe-oam-01__;!!NEt6yMaO-gk!QPh2Vo48Sr0CDWRyLzyNWGNptl23yk8Llnk29de7n1B4rqakopyA8ssT6MMRhBsr$
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-mpls-sr-epe-oam-01__;!!NEt6yMaO-gk!QPh2Vo48Sr0CDWRyLzyNWGNptl23yk8Llnk29de7n1B4rqakopyA8ssT6G9-EQZB$

A diff from the previous version is available at:
https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-mpls-sr-epe-oam-01__;!!NEt6yMaO-gk!QPh2Vo48Sr0CDWRyLzyNWGNptl23yk8Llnk29de7n1B4rqakopyA8ssT6Jv8XByh$

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!QPh2Vo48Sr0CDWRyLzyNWGNptl23yk8Llnk29de7n1B4rqakopyA8ssT6GpBTBJd$

_______________________________________________
mpls mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/mpls__;!!NEt6yMaO-gk!QPh2Vo48Sr0CDWRyLzyNWGNptl23yk8Llnk29de7n1B4rqakopyA8ssT6JGPfj_2$

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 20 Nov 2020 03:21:40 +0000

Hi Shraddha,

Thanks a lot for addressing my comments and I appreciate our discussions to arrive at the solution for your use-case while being aligned with the EPE control-plane specifications.

Thanks,
Ketan

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of Shraddha Hegde
Sent: 19 November 2020 23:40
To: [email-masked]; [email-masked]
Subject: Re: [mpls] I-D Action: draft-ietf-mpls-sr-epe-oam-01.txt

Dear WG members,

During WG adoption call, there were comments to exclude the Interface address details from the PeerNode Sid and PeerSet SID Target FEC TLV. The DDMT validation will ensure control plane And forwarding plane synchronization between the two routers.
The validation of controller's state with actual forwarding state on the Nodes will have to be validated externally by controller/application.

Rgds
Shraddha

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, November 19, 2020 11:37 PM
To: [email-masked]
Cc: [email-masked]
Subject: [mpls] I-D Action: draft-ietf-mpls-sr-epe-oam-01.txt

Abstract:

_______________________________________________
mpls mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls