Subject: [mpls] MPLS Open DT meeting 20021-09-23

From: Loa Andersson <[email-masked]>
Date: Thu, 23 Sep 2021 12:33:15 +0200

DT,

We will have a meeting today asuual.

You'll find a tentative have aagenda at:

https://trac.ietf.org/trac/mpls/wiki/2021-09-23-agenda

Please note that it is very much "wsork in progress", the last updates will
probably be made just before the meeting.

/Loa

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 23 Sep 2021 15:55:02 +0000

Hi,

As asked during the call, MPLS data plane for DetNet is described here:
https://datatracker.ietf.org/doc/rfc8964/

DetNet PW has a mandatory d-CW (DetNet Control-Word).
Details on procedures are also described in the document.

Further RFC’s on DetNet:
https://datatracker.ietf.org/group/detnet/documents/

Cheers
Bala’zs

From: mpls <[email-masked]> On Behalf Of Loa Andersson
Sent: Thursday, September 23, 2021 12:33 PM
To: mpls <[email-masked]>
Cc: [email-masked]; [email-masked]; DetNet Chairs <[email-masked]>
Subject: [mpls] MPLS Open DT meeting 20021-09-23

 DT,

Please note that it is very much "wsork in progress", the last updates will probably be made just before the meeting.

/Loa

---

From: Loa Andersson <[email-masked]>
Date: Sun, 26 Sep 2021 11:36:51 +0200

Balázs,

Thanks for the clarification. One question, one futher question.

What happens if a DetNet packet is put into a tunnel, and the nodes of 
the tunnel is not aware of DetNet.

A node carrying the tunnel want to run OAM over a segment of the tunnel?
Where is the PSD put?

/Loa

On 23/09/2021 17:55, Balázs Varga A wrote:
> <https://datatracker.ietf.org/doc/rfc8964/>
> 
> <https://datatracker.ietf.org/group/detnet/documents/>
> 
> Cheers
> 
> Bala’zs
> 
> *From:* mpls <[email-masked]> *On Behalf Of * Loa Andersson
> *Sent:* Thursday, September 23, 2021 12:33 PM
> *To:* mpls <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; DetNet Chairs 
> <[email-masked]>
> *Subject:* [mpls] MPLS Open DT meeting 20021-09-23
> 
>   DT,
> 
> <https://trac.ietf.org/trac/mpls/wiki/2021-09-23-agenda>
> 
> Please note that it is very much "wsork in progress", the last updates 
> will probably be made just before the meeting.
> 
> /Loa
> 
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 30 Sep 2021 13:45:14 +0000

Hi Loa,

Simple question, not so simple answer:
- if the tunnel segment OR the end of the tunnel removes the PSD, then it is OK.
- if PSD is inserted and the packet reaches a DetNet relay node (doing DetNet service sub-layer
for that flow and processing the d-CW), then the DetNet flow will be broken.

Cheers
Bala'zs

-----Original Message-----
From: Loa Andersson <[email-masked]> 
Sent: Sunday, September 26, 2021 11:37 AM
To: Balázs Varga A <[email-masked]>; Loa Andersson <[email-masked]>; mpls <[email-masked]>
Cc: [email-masked]; [email-masked]; DetNet Chairs <[email-masked]>
Subject: Re: [mpls] MPLS Open DT meeting 20021-09-23

Balázs,

What happens if a DetNet packet is put into a tunnel, and the nodes of the tunnel is not aware of DetNet.

/Loa

--

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 30 Sep 2021 15:09:20 +0100

Hang on, we need a network scenario to answer this.

If I have a pair of DetNet nodes and I connect them with a tunnel it is fine provided the tunnel provides the required transmission characteristics.

If the tunnel bypasses a DetNet node that should be in the Detnet  overlay network, then the network configuration has broken the required DetNet service.

The tunnel endpoints can be coincident with the DetNet nodes provided the packet is processed at each “layer”.

However to provide a definitive answer we need to see the network scenario that Loa has in mind.

- Stewart

> On 26 Sep 2021, at 10:36, Loa Andersson <[email-masked]> wrote:
> 
> Balázs,
> 
>> https://datatracker.ietf.org/doc/rfc8964/ <https://datatracker.ietf.org/doc/rfc8964/>
>> https://datatracker.ietf.org/group/detnet/documents/ <https://datatracker.ietf.org/group/detnet/documents/>
>> Cheers
>> Bala’zs
>> *Cc:* [email-masked]; [email-masked]; DetNet Chairs <[email-masked]>
>> https://trac.ietf.org/trac/mpls/wiki/2021-09-23-agenda <https://trac.ietf.org/trac/mpls/wiki/2021-09-23-agenda>