Subject: [mpls] SR-MPLS Service Programming usecase for Open DT

From: <[email-masked]>
Date: Thu, 16 Sep 2021 16:39:37 +0800 (CST)

Hi DT,

Besides the requirement in NSH Based SFC usecase in the wiki to carry path ID and metadata by embedding NSH in EH.
There's also a need to carry metadata in SR service programming with SR-MPLS data plane.

The reference is draft-ietf-spring-sr-service-programming. SR service programming is a mechanism to achieve SFC in SR-MPLS and SRv6 networks without the use of NSH.

In this draft, there's a requirement to carry metadata in SR-MPLS data plane, some possible methods to carry metadata (e.g, defining an SRH-like header with only the mandatory fields required to carry metadata) and to indicate the presence of metadata(e.g, adding the indication in the semantic of the service SIDs, or introducing a protocol identifier in the MPLS packet) are proposed but not standardized.
As for the path ID, although not mentioned in this draft, I think there's a potential need for it to let the SFFs distinguish between different SFPs.

Maybe after discussion the solution for this usecase is similar to that for NSH Based SFC, but I think this usecase should be taken into consideration.

Regards,
Yao

---

From: Haoyu Song <[email-masked]>
Date: Mon, 20 Sep 2021 15:48:26 +0000

Hi Yao,

I think what you described has been covered in the "network programming" use case on the wiki page,
https://trac.ietf.org/trac/mpls/wiki/Usecases, which is more akin to SRH in SR.

Best,
Haoyu

-----Original Message-----
From: mpls <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, September 16, 2021 1:40 AM
To: [email-masked]
Subject: [mpls] SR-MPLS Service Programming usecase for Open DT

Hi DT,

Regards,
Yao

---

From: <[email-masked]>
Date: Wed, 22 Sep 2021 10:06:58 +0800 (CST)

Hi Haoyu,

I think there're some differences between the SR-MPLS SFC usecase and the network programming usecase.
The purpose and the content of the data carried after the BOS of these two usecases are not the same. 
The purpose of SR-MPLS SFC usecase is to achieve SFC by SR-MPLS instead of NSH. The data required to be carried after the BOS is metadata for SFC. A new extension header may be defined for it or maybe we reuse existing header like NSH or SRH or something else.
The purpose of network programming usecase is to support the equivalent of FUNC::ARG in SRv6.  And the content of the data carried after the BOS contains FUNC:ARGs, segment count and pointers as for my understanding.

Regards,
Yao

------------------原始邮件------------------
发件人：HaoyuSong
日 期 ：2021年09月20日 23:48
主 题 ：RE: [mpls] SR-MPLS Service Programming usecase for Open DT
Hi Yao,
I think what you described has been covered in the "network programming" use case on the wiki page,
https://trac.ietf.org/trac/mpls/wiki/Usecases, which is more akin to SRH in SR.
Best,
Haoyu
-----Original Message-----
From: mpls <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, September 16, 2021 1:40 AM
To: [email-masked]
Subject: [mpls] SR-MPLS Service Programming usecase for Open DT
Hi DT,