Subject: [mpls] Open DT - thoughts for dicussion

From: Loa Andersson <[email-masked]>
Date: Fri, 10 Dec 2021 22:08:25 +0800

Folk,

I had a long flight yesterday and had to do something.

https://trac.ietf.org/trac/mpls/wiki/ADI-fields

/Loa
-- 
Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Greg Mirsky <[email-masked]>
Date: Sat, 11 Dec 2021 17:12:17 -0800

Hi Loa,
thank you for putting it all together. Now it is all so much clearer (to me
at least).
I've got several questions and much appreciate your thoughts,
clarifications:

   - it appears that the first bSPL will always be used for i-indicators
   even when all are cleared. If we accept the proposal to separate i- and
   p-indicator spaces, perhaps the format might be like follows:

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Base Special Purpose Label  (TBD)     |t a a|S|a a a a a a a x|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

                    Label:  Label Value, 20 bits
                    a:      Ancillary Data Indicator (ADI)
                    x:      extension bit
                    t:      ADI type: 0 - ISD, 1 - PSD
                    S:      Bottom of Stack, 1 bit

   - I imagine that indicators will be assigned to particular functions
   and, at some point, 10th, then 19th, and probably more indicator will be
   allocated. With the current encoding schema to set 10th indicator will
   require two LSEs, 19th - three. Seems a bit expensive. Do you think there's
   a benefit to look how to compress the zeroes that fill the indicator space
   of the whole bSPL?

Regards,
Greg

On Fri, Dec 10, 2021 at 6:09 AM Loa Andersson <[email-masked]> wrote:

> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Loa Andersson <[email-masked]>
Date: Sun, 12 Dec 2021 09:31:34 +0800

Greg,

Thanks for reading and and commenting.

Inline please.

On 2021-12-12 09:12, Greg Mirsky wrote:
> Hi Loa,
> thank you for putting it all together. Now it is all so much clearer (to 
> me at least).
>   * it appears that the first bSPL will always be used for i-indicators
>     even when all are cleared. If we accept the proposal to separate i-
>     and p-indicator spaces, perhaps the format might be like follows:
> 
>   0                   1                   2                   3
>   * I imagine that indicators will be assigned to particular functions
>     and, at some point, 10th, then 19th, and probably more indicator
>     will be allocated. With the current encoding schema to set 10th
>     indicator will require two LSEs, 19th - three. Seems a bit
>     expensive. Do you think there's a benefit to look how to compress
>     the zeroes that fill the indicator space of the whole bSPL?
> 
This is precisely why I put the text together.

I'm perfectly willing to discuss "how to compress". as a matter of fact 
I thought a bit about it, but the ideas I had was too complicated. If 
anyone has ideas please bring them to the list.

/Loa
> 
> Regards,
> Greg
> 
> On Fri, Dec 10, 2021 at 6:09 AM Loa Andersson <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Folk,
> 
>     <https://trac.ietf.org/trac/mpls/wiki/ADI-fields>
> 
>     /Loa
>     -- 
>     Loa Andersson                        email: [email-masked] <mailto:[email-masked]>
>     Senior MPLS Expert [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/mpls>
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 13 Dec 2021 10:43:34 +0800

Greg, et.al.,

> Hi Loa,
<snip>
>     and p-indicator spaces, perhaps the format might be like follows:
I think this is a good check, I will update my text.

It solve some problems, e.g. the case where there are no ISD indicators,
but there are PSD indicators.

One thing that it does not solve is the #19 problem, i.e. bit number 19 
is the only bit set, this would still require 3 LSEs.

I just realized that the statement "it appears that the first bSPL will 
always be used for i-indicators" has a potential to be misunderstood.
I think that it should be "it appears that the first LSE will always be 
used for i-indicators", the bSPL will be the same.

/Loa

<snip>