Subject: Re: [Mtgvenue] filtering, take 33 (was 32)

From: Andrew Sullivan <[email-masked]>
Date: Fri, 1 Sep 2017 16:52:53 -0400

I think I am fine with this list.  Thanks for the good suggestion. 

How do the UK's filtering rules for ISPs and mobile providers and so on apply to the IETF network?  Does that present a possible problem?  (I ask because some mobile carrier once decided my mail server was "unsafe" somehow and I couldn't get my mail with my prepaid SIM.)

A

-- 
Andrew Sullivan 
Please excuse my clumbsy thums. 

> On Aug 31, 2017, at 12:40, Jim Martin <[email-masked]> wrote:
> 
> Gentlepeople,
>     Let me jump back to the beginning on this. I believe we’re trying to address the following text from 3.1:
> 
> The venue MUST provide unfiltered access to the Internet, to the extent permitted by governing laws and regulations.
> 
> 	And as I understand it, the concern was that the “to the extent permitted...” was felt to provide too much of an out for restrictive legislation.  Hence, the approach was to more accurately describe what we MUST have to have an effective meeting (Since this was in the Mandatory section). I believe our absolute minimum requirements are (largely taken from my earlier message):
> 
> 	- Sufficient bandwidth to the greater Internet
> 	- No middle boxes altering traffic (NAT, FW, Captive Portal, etc)
> 	- Native public v4 and v6
> 	- No filtering that would materially negatively impact the ability of IETF attendees to conduct their day-to-day Internet use.
> 	- Sufficient redundancy to handle equipment and provider failures
> 
> 	I also believe that I started going down the wrong road myself, as I was interpreting these as strictures on what we do to our own network, or what we ask the providers to do on our behalf, rather than what they enforce upon us.
> 
> 	Given that I’d like to propose an alternative text:
> 
> It MUST be possible (through donation or purchase) to provision Internet Access to the Meeting Venue that allows attendees to utilize the Internet for all their IETF, business, and day to day needs. This includes, but is not limited to, native and unmodified IPv4 and IPv6 connectivity, global reachability, and no additional limitation that would materially impact their Internet use. To ensure availability, it MUST be possible to provision redundant paths to the Internet.
> 
>        Thoughts?
> 
> - Jim
> 
>> On Aug 31, 2017, at 11:20 AM, Andrew Sullivan <[email-masked]> wrote:
>> 
>>> On Thu, Aug 31, 2017 at 08:43:25AM -0400, Jim Martin wrote:
>>> 
>>>> On Aug 31, 2017, at 4:27 AM, Eliot Lear <[email-masked]> wrote:
>>>> 
>>>> The Facility and IETF hotels MUST allow support for public IPv4 and IPv6
>>>> connectivity with sufficient bandwidth and redundancy to the Internet
>>>> for attendees to communicate without interruption or interference.  Only
>>>> BCP38 filtering and other necessary defensive filtering mechanisms as
>>>> agreed by the IASA are acceptable.  The IASA MAY make an exception to
>>>> this requirement after having consulted the community.
>>>> 
>>>> How about that?
>>> 
>>>   Hmm, by my reading of this, if we were getting DDoSed during a meeting I'd need to convene a meeting of IASA before I could ask the ISP to help us mitigate the attack.
>> 
>> Wouldn't it be enough to get a general approval from IASA for DDoS
>> protections and other such filtering (presumably, to be reviewed
>> whenever the techniques change)?  It's easy to refer to BCP38 but
>> harder to refer to a list that changes over time :)
>> 
>>> What are we winning by adding stricture above and beyond what I wrote when we started this whole process?
>>> 
>> 
>> The stricture is there to make the document an accurate portrayal of
>> the community expectations.
>> 
>> I'm not sure which text you mean by what you "wrote when we started
>> this whole process", but in general I think the document has gradually
>> been getting more concrete about the things that are and are not
>> permitted.  My own evaluation of text has always been done by
>> imaginging myself in the shoes of an IAOC member, and asking whether a
>> bit of text sets clear expectations for making a decision.  Much of
>> the early text, in my opinion, basically told the IAOC to use its
>> judgement or else to defer to the Meetings Committee, and since that
>> was the situation that obtained before this WG started I didn't think
>> it was an acceptable answer.
>> 
>> Best regards,
>> 
>> A
>> 
>> -- 
>> Andrew Sullivan
>> [email-masked]
>> 
>> _______________________________________________
>> Mtgvenue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mtgvenue
> _______________________________________________
> Mtgvenue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mtgvenue

---

From: Eliot Lear <[email-masked]>
Date: Sat, 2 Sep 2017 09:39:41 +0200

Jim:

On 8/31/17 6:40 PM, Jim Martin wrote:
> It MUST be possible (through donation or purchase) to provision
> Internet Access to the Meeting Venue that allows attendees to utilize
> the Internet for all their IETF, business, and day to day needs. This
> includes, but is not limited to, native and unmodified IPv4 and IPv6
> connectivity, global reachability, and no additional limitation that
> would materially impact their Internet use. To ensure availability, it
> MUST be possible to provision redundant paths to the Internet.
>        Thoughts?
>
I think it's fine, and I'll run with it unless others object.

Eliot