Subject: [multipathtcp] q about draft-ford-mptcp-multiaddressed-03

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 09 Mar 2010 20:08:01 +0900 (JST)

Hello, 
I'm reading draft-ford-mptcp-multiaddressed-03 and I have a couple of questions.

1: we don't need to include port number for add address option?
   I think we somehow need to propagate port number to the peer for new address.

2: "if an address index is in use, the Add Address option SHOULD be silently ignored."
   In my feeling, this might be problematic. For example, suppose if an endpoint added 
   addr A1 with Add option as ID 1. Later, the endpoint lost A1 and got A2 instead.
   In this case, the endpoint might send remove option for ID 1 and then try to
   register A2 as ID 1 again. But, if the remove option was dropped anyhow, regstering
   A2 will be ignored. 
   I feel we might need acks for add and remove operation or need to make 
   new add address request overwrite old one. 

3: The terminology "connection" might be a bit confusing? It means a mptcp session 
   which includes all subflows. But, I'm afraid it might be confused by a tcp 
   connection of a subflow. Using session or association might be better? 

Thanks,
--   
Yoshifumi Nishida
[email-masked]

---

From: Costin Raiciu <[email-masked]>
Date: Tue, 9 Mar 2010 11:47:34 +0000

Hi Yoshifumi,

1. We could add it. Note that we envision using add/remove address only when nats prevent direct connection setup. In the latter case, the endpoints must simply choose a port and put it in the syn. The spec now says this
port should be the same port as one of the other subflows.

2. In this case the endpoint should register A2 with ID 2. These add/remove address messages need not necesarily be reliable, as in the end they are just optimizations. We have been thinking about making them reliable, though.

3.Agreed. The draft is still rough in many places, and consistent terminology is one bullet on the todo list.

Thanks,
Costin

On 9 Mar 2010, at 11:08, Yoshifumi Nishida wrote:

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: Yoshifumi Nishida <[email-masked]>
Date: Wed, 10 Mar 2010 04:51:45 +0900 (JST)

Hi Costin, 

From: Costin Raiciu <[email-masked]>
Subject: Re: [multipathtcp] q about draft-ford-mptcp-multiaddressed-03
Date: Tue, 9 Mar 2010 11:47:34 +0000
Message-ID: <[email-masked]>

 > 2. In this case the endpoint should register A2 with ID 2. These add/remove address messages need not necesarily be reliable, as in the end they are just optimizations. We have been thinking about…

I see. I feel the draft might need to suggest to avoid picking the same ID if possible. 
Also, I know this might be a pathologic situation, but if an endpoint add and remove address 
over 256 times, (I guess it could happen in mobile situation.), this issue can happen.
So, I feel we need a certain reliability here, although it might not be required everytime.

Thanks,
--
Yoshifumi Nishida
[email-masked]