Subject: [multipathtcp] Flappiness

From: Bachir CHIHANI <[email-masked]>
Date: Wed, 17 Mar 2010 15:24:58 +0000 (GMT)

Hi,
I get some confusion when trying to understand the flappiness phenomenon !

In [1], it's stated (in the discussion section) that the flappiness happen when all the paths have similar loss rate
so that the cogestion controller tend to allocate randomly the whole window to a path and nulle for the others !!

While in [2], it's stated that the flappiness happen when a path (in case where we have only two path) experience some drops
so the its window will decrease letting the window of the other increase because of the higher transmission rate. 
Thus, the traffic will move from the congestioned path to the no congestioned one and this what they call flappiness.

Regards
Bachir.

[1] C. Raiciu, M. Handley, and D. Wischik. Coupled Multipath-Aware Congestion Control draft-raiciu-mptcp-congestion-01; 2010.
[2] C. Raiciu, D. Wischik, and M. Handley. Practical Congestion Control for Multipath Transport Protocols; 2009.

---

From: Costin Raiciu <[email-masked]>
Date: Wed, 17 Mar 2010 15:35:41 +0000

Hi,

Flappiness is just the congestion controller overreacting to losses. It happens in many cases, but the most obvious case is when loss rates are fixed and equal on the two paths (as phrased in [1]). 

The reason underlying this behaviour is the discrete (stochastic) nature of packet drops. In the equal loss rate case (I guess this is described in [2]), random fluctuations will make one path temporarily look more congested, and all traffic will be put on the other path. It is difficult to get out of this phase as the flow is effectively captured on the other path: it takes many more drops on this path to flip the other way. In effect the algorithm is bistable.

Cheers,
Costin

P.S. We have a more recent description of the work under submission. I can send you that off list if you want, as long as you don't redistribute it.

On 17 Mar 2010, at 15:24, Bachir CHIHANI wrote:

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp