Subject: Re: [multipathtcp] Think on MPTCP

From: Bachir CHIHANI <[email-masked]>
Date: Fri, 5 Mar 2010 13:17:58 -0800 (PST)

Hi Sun,
MPTCP has to provide a powerful API to let endoints express their preference regarding some paths,
depending for example on cost, or garateed bandwidth.
This is an intersting feature, specially for both sides.
Unfortunately, the current version of MPTCP don't allow that, 
For the drawbacks, I think that the current version has a some related security issues 
you can read "Threat Analysis for Multi-addressed/Multi-path TCP"

regards
Bachir.

---

From: Sébastien Barré <[email-masked]>
Date: Mon, 08 Mar 2010 14:47:23 +0100

Hi Bachir,

> Unfortunately, the current version of MPTCP don't allow that,
I am not sure to follow you here. In my understanding, the spec is about 
the MPTCP protocol. Being able to express preferences, whether through 
socket options 
(http://tools.ietf.org/html/draft-sarolahti-mptcp-af-multipath-01) or 
through system-wide settings is a matter of implementation.

What stops an implementer from offering tuning/preferences options for 
MPTCP ?

Or maybe you mean that the current Linux implementation of MPTCP 
(http://inl.info.ucl.ac.be/softwares/mptcp) does not allow that ? If 
this is what you mean, that's right :-) ... currently.

regards,

Sébastien.
> ------------------------------------------------------------------------
>
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>   

-- 
Sébastien Barré
Researcher,
CSE department, UCLouvain, Belgium
http://inl.info.ucl.ac.be/sbarre

---

From: Bachir CHIHANI <[email-masked]>
Date: Mon, 8 Mar 2010 14:04:32 +0000 (GMT)

Hi Sébastian,
I agree with you about the possibility of providing a such API, 
and like you said, I was thinking about the current implementation.

Regards.
Bachir

Hi Bachir,

> Unfortunately, the current version of MPTCP don't allow that,
I am not sure to follow you here. In my understanding, the spec is about the MPTCP protocol. Being able to express preferences, whether through socket options (http://tools.ietf.org/html/draft-sarolahti-mptcp-af-multipath-01) or through system-wide settings is a matter of implementation.

What stops an implementer from offering tuning/preferences options for MPTCP ?

Or maybe you mean that the current Linux implementation of MPTCP (http://inl.info.ucl.ac.be/softwares/mptcp) does not allow that ? If this is what you mean, that's right :-) ... currently.

regards,

Sébastien.
> you can read "Threat Analysis for Multi-addressed/Multi-path TCP"

-- Sébastien Barré
Researcher,

---

From: yonghao sun <[email-masked]>
Date: Tue, 9 Mar 2010 11:42:31 +0800

Hi，
I have read the draft(draft-scharf-mptcp-api-00),I thik it will be too
complex if
every application have its own configuration of MPTCP,that is right?
In my opinion the configuration from users not APP developers may be a
better way.
Glad to discuss here!
regards
Yonghao Sun
2010/3/8 Bachir CHIHANI <[email-masked]>:
> I am not sure to follow you here. In my understanding, the spec is about the
> MPTCP protocol. Being able to express preferences, whether through socket
> options (http://tools.ietf.org/html/draft-sarolahti-mptcp-af-multipath-01)
> or through system-wide settings is a matter of implementation.
>
> (http://inl.info.ucl.ac.be/softwares/mptcp) does not allow that ? If this is
> what you mean, that's right :-) ... currently.
>
> regards,
>
> Sébastien.

-- 
***************************************************
4-103 FIT  Tsinghua University Beijing China
***************************************************

---

From: "SCHARF, Michael" <[email-masked]>
Date: Tue, 9 Mar 2010 10:45:21 +0100

Dear Yonghao Sun,

> I have read the draft(draft-scharf-mptcp-api-00),I thik it 
> will be too complex if every application have its own 
> configuration of MPTCP,that is right?

true. As stated in the draft, the actual objective is that most
application won't need any specific configuration, unless they have
rather specific needs.

> In my opinion the configuration from users not APP developers 
> may be a better way.

I agree. Many current operating systems already allow users to configure
the TCP stack to some extent. One can expect that this will apply to
MPTCP, too. Still, these configuration interfaces are usually specific
to the operating system and not standardized. Therefore, this aspect is
currently not addressed by draft-scharf-mptcp-api. 

Best regards

Michael

---

From: 张文涛 <[email-masked]>
Date: Tue, 9 Mar 2010 18:48:11 +0800

> currently not addressed by draft-scharf-mptcp-api.

what I infer from the
above is that application has interfaces(API) to touch the behaviour of MPTCP
as needed by programming, users as well have access to configure the TCP
stack by adjusting the sysctl variables or something. The requirement of
them may differ and focus on different aspects. For instance, application
may prefer to use paths with the shortest delay, users may prefer to use the
network with the lowest price, such as WIFI. Am I far away from the point ?

-- 
Wentao Zhang, Undergraduate
Department of Electronic Engineering
Tsinghua University, Beijing, P.R.China
Tel: +86-138-1059-9295
Email: [email-masked]