Subject: [multipathtcp] REMINDER: Multipath TCP Implementors workshop, Saturday 24th July

From: <[email-masked]>
Date: Sat, 3 Jul 2010 13:21:28 +0100

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 18 May 2010 10:55
To: [email-masked]
Subject: [multipathtcp] Multipath TCP Implementors workshop,Saturday 24th July

The IETF's Multipath TCP (MPTCP) working group is organising a workshop with the OS and applications communities on the Saturday afternoon immediately before the IETF meeting in Maastricht (i.e. on 24th July)

(http://www.ietf.org/meeting/78/index.html)

If you would like to come, please register to [email-masked]. Due to room size, numbers are limited and registration is required.

Multipath TCP enables a single TCP connection to use multiple network interfaces and paths simultaneously for one TCP connection. From an applications perspective, this increases resilience and enables a basic form of connection mobility, whilst from an OS perspective it requires a change to the host TCP stack.

IETF working group:       http://www.ietf.org/dyn/wg/charter/mptcp-charter
Supplemental information: http://nrg.cs.ucl.ac.uk/mptcp/

The objective of the workshop is to help make MPTCP real, i.e., to get it implemented in many operating systems and to get it used by key applications. This will be an interactive workshop with application designers (who would use MPTCP), OS implementors (who would implement and ship MPTCP) and MPTCP working group people (who are designing and standardising MPTCP). Note that this is not a passive "dissemination" workshop! The aim is to have an active discussion with the OS and applications communities about their requirements and needs, in order to influence and improve the MPTCP protocol design.

The workshop will be highly interactive and focus on two topics:

* On the one hand, it is to understand the process through which
  Multipath TCP could make its way into OSes. The OS implementers
  and active community members can explain their real world
  requirements and constraints on the various platforms. What are
  the potential stumbling blocks for MPTCP's implementation and how
  could the protocol designers lower the deployment barriers?

* On the other hand, the WG would like to discuss the use cases for
  Multipath TCP with the applications community. What are the gotchas
  and how can the protocol designers increase the usefulness of
  MPTCP?

Where & when?

The workshop will be held on July 24, 2010 in Maastricht at the IETF meeting venue, "MECC", starting at 2pm (room to be confirmed). This is the Saturday afternoon before the start of the IETF week.

We hope that remote participation will also be possible, via Webex.

We would be pleased to hear feedback on the scope and purpose of the workshop.

The workshop is organised under the auspices of the MPTCP working group, but is not a formal WG meeting - for instance, WG consensus calls will not be made.

Best wishes,
Philip Eardley
Yoshifumi Nishida
[email-masked]

---

From: <[email-masked]>
Date: Thu, 15 Jul 2010 13:24:08 +0100

Hi,

we sent out an email (last night) to all those people who registered [title: "Confirmation of registration for Multipath TCP Implementors workshop, Maastricht, Saturday 24th July 2pm"]

If you didnt get this email and did register, then please let us know as we've mislaid your registration. [[email-masked]]

The room we've been given for the meeting is currently full to capacity (24 people), but if there are any last minute registrations, please let us know [in case someone drops out, or possibly we can get a larger room, or standing room!]

thanks.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 03 July 2010 13:21
To: [email-masked]
Cc: [email-masked]
Subject: [multipathtcp] REMINDER: Multipath TCP Implementors workshop, Saturday 24th July

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 18 May 2010 10:55
To: [email-masked]
Subject: [multipathtcp] Multipath TCP Implementors workshop,Saturday 24th July

Where & when?

Best wishes,
Philip Eardley
Yoshifumi Nishida

---

From: Lawrence Stewart <[email-masked]>
Date: Sun, 25 Jul 2010 13:22:57 +1000

On 05/18/10 19:54, [email-masked] wrote:
> The IETF's Multipath TCP (MPTCP) working group is organising a workshop
> with the OS and applications communities on the Saturday afternoon

[snip]

I wanted to provide a bit of constructive criticism regarding
yesterday's workshop as I felt it missed the mark on a few points. If we
plan another such workshop, it would be good to take these issues into
consideration.

My biggest concern was that there ended up being no scheduled time for
free-form discussion, questioning and interaction as was promised in the
planning leading up to the workshop. Being on site may have provided
more opportunity for this before starting, during the break and after
the event, but for those of us tuning in remotely there was a window of
about 60 seconds at the end where I had the chance to ask a more general
question or two and then it was all over.

The good information presented by Costin, Lars and Sebastien should have
been delivered succinctly and used to seed focused discussion sessions,
rather than simply being a data dump and allowing for the odd question
here and there. As it was we didn't even make it all the way through the
prescribed agenda with the minimal time taken up by questions. Perhaps a
50/50 split of structured presentation vs focused discussion would have
been a better fit here.

Whilst I appreciate that enabling remote participation is an incredibly
error prone and difficult practice to get right, I think we could have
done better here. Ideally we needed an inbound audio feed to the room so
that we could ask the questions ourselves. Some sort of "push to talk"
IP based service seems like an ideal fit for enabling this sort of
interaction. Skype running on a laptop hooked up to a set of PC speakers
might have been workable too (dial into a conf call when we want to ask
a question).

Failing the audio feed being available, there needed to be an appointed
jabber scribe at all times (thanks to those of you that helped with
this). The scribe needed to have their own mic at their seat so they
could stay put and relay questions with minimal hassle and maximal speed
to maintain context.

All of the documents people were drawing presentation information from
needed to be in webex, as a number of things were missing that
apparently could have been there. A video feed from a camera in the room
would have negated the need for webex altogether, but the phrase "tell
'im he's dreamin" [1] springs to mind (I think I heard someone say there
was only a DSL grade connection?).

I must say I really fail to see what value webex added. A web based
slide toolkit (e.g. [2,3,4]) or putting all the slides as pdfs on the
workshop wiki would have removed the need for webex. Jabber for chat,
the mp3 audio stream for audio and the slides are all online as HTML or
downloadable pdfs so we can follow along if presenters verbally state
the slide number they're on as they go.

I guess you can tell this is the first time I've tried to participate
remotely in an IETF event and was left feeling rather frustrated.
Perhaps I am dreamin, but I truly hope we can do better and that the
status quo isn't "the best we got".

Shame I couldn't be there with you all, but have a productive week and I
look forward to continuing to follow progress.

Cheers,
Lawrence

[1] http://www.youtube.com/watch?v=dik_wnOE4dk

[2] http://info.iet.unipi.it/~luigi/sttp/

[3] http://www.w3.org/Talks/Tools/Slidy/

[4] http://meyerweb.com/eric/tools/s5/

---

From: <[email-masked]>
Date: Sun, 25 Jul 2010 07:50:00 +0100

On 25 Jul 2010, at 04:22, Lawrence Stewart wrote:

> I must say I really fail to see what value webex added.

It allows presenters to turn up with minimal preparation, and
without providing slides in advance by email or other means to a
larger audience who could decide whether or not it's worth attending.
It forces attendance just to find out what will be presented, and
privileges attendees.

The value is to the presenter, not the audience.

Lloyd Wood
[email-masked]
http://sat-net.com/L.Wood

---

From: "Robert N. M. Watson" <[email-masked]>
Date: Sun, 25 Jul 2010 14:23:01 +0100

> plan another such workshop, it would be good to take these issues into

Dear all--

I'd like to echo Lawrence's comments. I appreciate the effort made to include participants who were unable to attend in person, but unfortunately felt that it didn't work out very well in practice:

(1) The event was quite frustrating to attend remotely -- simply listening to a recording later would have gotten the presentations across better, while not introducing unmet expectations for participation. My experience is that remote participation done poorly is worse than not doing it at all. When it goes badly (almost always), the local dynamic is disrupted to cater to remote participants who are out-of-sync with the conversation and have constant technical difficulties, while remote participants feel unable to engage with a conversation but waste the day trying.

On the technical front: a sub-second audio solution (such as bridging to a conference call, or even Skype), rather than lagged audio, and PDFs of the slides distributed in advance (even if only by five minutes) would have made a huge difference. The disconnect between the audio (>30 seconds?) and WebEx was particularly devastating during Sebastien's talk, especially towards the end when WebEx appeared to be several slides ahead of the audio. Perhaps it was just me who had this experience? If so, I blame BT's broadband network :-).

On the social front: an assigned representative for online participants with his/her own mic would have been very helpful -- perhaps with two Jabber channels rather than one, so that chatter is separate from comments intended to be relayed. The speaker / moderator remembering to poll for online questions and comments, especially when online participants are on significantly lagged audio, is critical. A way to call in questions live would work better, since relaying someone else's written questions is always painful for the proxy!

(2) The right people were present to have a really constructive discussion of the protocol and implementation, but (at least from the perspective of a vendor contemplating the viability of MP-TCP and trying to understand where in the research / transfer cycle it was) it was more of a fire hose than a conversation.

Sebastien, Costin, and others fleetingly raised many critical design and implementation trade-offs, each of which could have benefited from further discussion. Specifically scheduling discussion time and having structured Q&A would have helped a lot -- inevitably, this means less talking to slides. I'll follow up via another e-mail with a list of comments/questions I had prepared by the end of Sebastien's talk, but that were cut off due to there being no Q&A period after his talk.

Thanks,

Robert Watson
University of Cambridge
Computer Laboratory