Subject: [multipathtcp] MPTCP vs SCTP

From: Rashmi <[email-masked]>
Date: Fri, 26 Nov 2010 13:23:38 +0100

Hi,

Is there any good documentation with the major differences between SCTP and MPTCP? Or a document which lists the advantages of MPTCP over SCTP?

Thank you.
Rashmi

---

From: jouaber <[email-masked]>
Date: Fri, 26 Nov 2010 13:36:38 +0100

Hi,

I have been and still working on SCTP and mSCTP for a while.

There are many difficulties with mSCTP

1/ the management of non routable adresses mainly whan they are sent in 
an Add message. In this case, these are not translated by the NAT and 
are useless at the peer side.
2/ most of firewalls and probably NATs are not letting the SCTP protocol 
getting through
3/ unlike MTCP that should be transparent for applications (it is also a 
TCP), very few applications are aware about the SCTP protocol

4/ SCTP allow to send multiple streams on the same connection. I do not 
know abot TCP

Regards,

Badii JOUABER

Le 26/11/2010 13:23, Rashmi a écrit :
> Hi,
>
> Is there any good documentation with the major differences between 
> SCTP and MPTCP? Or a document which lists the advantages of MPTCP over 
> SCTP?
>
> Thank you.
> Rashmi
>
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

-- 
Badii Jouaber
__________________________________________________________
Département RS2M "Réseaux et Services Multimédia Mobiles"
_________________________________________
Badii JOUABER, Associate Professor
Wireless Networks and Multimedia Services Department

TELECOM SudParis
9 rue Charles Fourier,91011 EVRY,France
Office Phone : +331 60 76 42 08
Fax : +331 60 76 45 78

e-mail : [email-masked]
web: http://www-public.int-evry.fr/~jouaber

_____________________