Subject: [multipathtcp] draft-ietf-mptcp-architecture, proposed extra text on congestion control

From: <[email-masked]>
Date: Thu, 9 Dec 2010 10:25:22 +0000

Hi,
I've just been doing a review on the architecture draft before submission to IESG.

I think it doesn't quite fully capture what (I believe) is the WG consensus about the high-level design for congestion control. My suggestion is to add the following:-

MPTCP uses an algorithm that links the increase phases of the congestion avoidance state (specifying how the window inflates upon receiving acknowledgements over the various paths). The multiplicative decrease of the congestion avoidance state is the same as in TCP, as are the slow start, fast retransmit, and fast recovery algorithms.

Please shout whether you think it's ok to add this text, or whether you think there isn't yet consensus.

http://tools.ietf.org/html/draft-ietf-mptcp-architecture-03#section-5.7

Thanks
Phil/

---

From: "SCHARF, Michael" <[email-masked]>
Date: Thu, 9 Dec 2010 19:02:07 +0100

I am not sure whether the architecture document should really outline a
specific congestion window manipulation algorithm, which may still be
subject to change.

A comment on not changing slow-start and error recovery phases could
IMHO be possible. But, in that case the question is what "is the same as
in TCP". Probably, RFC 5681? But we all know that this is not exactly
what TCP in the wild happens to use...

Michael

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Thursday, December 09, 2010 11:25 AM
> To: [email-masked]
> Subject: [multipathtcp] draft-ietf-mptcp-architecture, 
> proposed extra text on congestion control
> 
> Hi,
> 
> I think it doesn't quite fully capture what (I believe) is 
> the WG consensus about the high-level design for congestion 
> control. My suggestion is to add the following:-
> 
>  
> 
> MPTCP uses an algorithm that links the increase phases of the 
> congestion avoidance state (specifying how the window 
> inflates upon receiving acknowledgements over the various 
> paths). The multiplicative decrease of the congestion 
> avoidance state is the same as in TCP, as are the slow start, 
> fast retransmit, and fast recovery algorithms.
> 
>  
> 
> Please shout whether you think it's ok to add this text, or 
> whether you think there isn't yet consensus.
> 
>  
>

---

From: <[email-masked]>
Date: Fri, 10 Dec 2010 09:59:39 +0000

Ok, we won't add this level of detail, in order to get it into the iesg without delay.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of SCHARF, Michael
Sent: 09 December 2010 18:02
To: [email-masked]
Subject: Re: [multipathtcp] draft-ietf-mptcp-architecture, proposed extra text on congestion control

Michael

> http://tools.ietf.org/html/draft-ietf-mptcp-architecture-03#se
_______________________________________________
multipathtcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multipathtcp