Subject: [multipathtcp] multipath congestion control and RFC 2861

From: <[email-masked]>
Date: Thu, 20 Jan 2011 14:43:01 +0200

Hi,

In the context of multipath TCP and coupled congestion control, I am wondering what the thoughts are in respect to
the limitation put on growth of not fully utilized congestion windows by RFC 2861 - as exemplified by the following text from RFC 2861.

  "For the separate issue of the increase of the congestion window in
   response to an acknowledgement, we believe the correct behavior is
   for the sender to increase the congestion window only if the window
   was full when the acknowledgment arrived."

The question seems relevant in connection with multipath TCP as it impacts to willingness (and possibility)
of TCP to "instantly" redistribute traffic from one failed path to other paths - or perhaps more strictly speaking: to have n-1 paths absorb
the traffic previously distributed on n paths.

Also the issue becomes very relevant when discussing the applicability of the multipath congestion control to SCTP (CMT-SCTP)
as SCTP (RFC 4960)  in text at least (not sure about all implementations) incorporates the RFC 2861 constrains on growth of not utilized CWNDs.

Thanks.

BR, Karen

*****************************************************************************************
Karen Egede Nielsen
Software Architect, Ph.D.

Tieto Denmark A/S
IP Solutions, Telecom & Media
Skanderborgvej 232, 8260 Viby J, DK-Denmark
Direct Phone / Mobile +45 25134336
E-mail: [email-masked]
*****************************************************************************************
www.tieto.com

Please note: The information contained in this message may be legally privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, you are hereby notified that any unauthorised use, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer. Thank You.

---

From: Thomas Dreibholz <[email-masked]>
Date: Thu, 20 Jan 2011 20:59:15 +0100

On Donnerstag 20 Januar 2011, [email-masked] wrote:
> Hi,
> 
> In the context of multipath TCP and coupled congestion control, I am
> wondering what the thoughts are in respect to the limitation put on growth
> of not fully utilized congestion windows by RFC 2861 - as exemplified by
> the following text from RFC 2861.
> 
> The question seems relevant in connection with multipath TCP as it impacts
> to willingness (and possibility) of TCP to "instantly" redistribute
> traffic from one failed path to other paths - or perhaps more strictly
> speaking: to have n-1 paths absorb the traffic previously distributed on n
> paths.
> 
> Also the issue becomes very relevant when discussing the applicability of
> the multipath congestion control to SCTP (CMT-SCTP) as SCTP (RFC 4960)  in
> text at least (not sure about all implementations) incorporates the RFC
> 2861 constrains on growth of not utilized CWNDs.

Dear Karen,

on reception of an acknowledgement, CMT-SCTP (and CMT/RP-SCTP as well) only 
increases the CWND of a path if its window had been fully utilised before.

Best regards
-- 
=======================================================================
 Dr. Thomas Dreibholz

 University of Duisburg-Essen,                   Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.iem.uni-due.de/~dreibh
=======================================================================

---

From: <[email-masked]>
Date: Fri, 21 Jan 2011 09:39:50 +0200

Thanks! Yes - but - I am wondering 
if there are any thoughts in respect to multipath tcp on this subject ?

BR, Karen

-----Original Message-----
From: Thomas Dreibholz [mailto:[email-masked]] 
Sent: 20. januar 2011 20:59
To: [email-masked]
Cc: Nielsen Karen
Subject: Re: [multipathtcp] multipath congestion control and RFC 2861

On Donnerstag 20 Januar 2011, [email-masked] wrote:
> wondering what the thoughts are in respect to the limitation put on 
> growth of not fully utilized congestion windows by RFC 2861 - as 
> exemplified by the following text from RFC 2861.
> 
> The question seems relevant in connection with multipath TCP as it 
> impacts to willingness (and possibility) of TCP to "instantly" 
> redistribute traffic from one failed path to other paths - or perhaps 
> more strictly
> speaking: to have n-1 paths absorb the traffic previously distributed 
> on n paths.
> 
> Also the issue becomes very relevant when discussing the applicability 
> of the multipath congestion control to SCTP (CMT-SCTP) as SCTP (RFC 
> 4960)  in text at least (not sure about all implementations) 
> incorporates the RFC

Dear Karen,

on reception of an acknowledgement, CMT-SCTP (and CMT/RP-SCTP as well) only increases the CWND of a path if its window had been fully utilised before.

Best regards

---

From: Costin Raiciu <[email-masked]>
Date: Fri, 21 Jan 2011 11:54:14 +0200

Hi Karen,

Our draft does not currently discuss the issues arising to app-limited flows, where the cwnd is not always full. The answer, however, is straightforward. 

If MPTCP is app limited, some or all the subflows will be app-limited (i.e. there will not be enough data to fill their cwnd). MPTCP should apply RFC 2861 to the subflows in this situation.

When app limited, MPTCP will probably use its best path (for instance the lowest RTT one) as much as possible.  This means that we will either have a single subflow with data on it (here RFC 2861 should appliy directly),
or one subflow that is using all its cwnd and a few others that are app limited (RFC 2861 will only apply to the latter).  

One remaning question is: how should MPTCP update alpha when some subflows are app limited? The current draft covers this by demanding that min(flighsize,cwnd) should be used when computing alpha.
When all flows are app limited, the formula still applies but the resulting alpha does not really matter, as cwnds are not increased anyways.

Cheers,
Costin

On 21 Jan 2011, at 09:39, Karen.Nielsen wrote:

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: <[email-masked]>
Date: Fri, 21 Jan 2011 12:25:55 +0200

Thanks a lot for the clear answer.
Also agree with the technical approach.

Thanks !

BR, Karen

-----Original Message-----
From: Costin Raiciu [mailto:[email-masked]] 
Sent: 21. januar 2011 10:54
To: Nielsen Karen
Cc: dreibh; multipathtcp
Subject: Re: [multipathtcp] multipath congestion control and RFC 2861

Hi Karen,

Cheers,
Costin