Subject: [multipathtcp] Single-homed end-host MPTCP - autoconfiguration

From: Rolf Winter <[email-masked]>
Date: Mon, 7 Mar 2011 15:49:45 +0000

Hi,

we have played with a single-homed end-system in a multi-homed site using MPTCP and it works like a charm. Therefore, we have implemented an auto-configuration mechanism for it using DHCP and tested that one too. If the WG feels that this is something useful we can present it. The work will ultimately need move to DHC but we first would like to know from the MPTCP group whether they feel it is useful. The draft can be found here:

http://tools.ietf.org/html/draft-wr-mptcp-single-homed-00

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Mark Handley <[email-masked]>
Date: Mon, 7 Mar 2011 23:47:05 +0000

Definitely seems worthwhile to me.

On terminology - I don't think this is really an MP proxy.  We've
talked privately about MPTCP proxies (so an MP client with multiple
paths can connect to a single-path TCP server), and such beasts would
be full transport-level proxies.  What's talked about in your draft is
really a multi-address capability for DHCP rather than a proxy.

To get this functionality without multiple addresses we've talked
about setting up multiple subflows even with single-addressed hosts,
and relying on ECMP hashing different source ports differently.  But
if you can deterministically choose different outgoing paths, that's
better.

 - Mark

On 7 March 2011 15:49, Rolf Winter <[email-masked]> wrote:
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Fri, 25 Mar 2011 00:43:44 -0700

Hello Rolf,

I've read the draft and I like the idea and believe it'll be useful.

However, I don't fully understand the purpose for new DHCP options yet.
If the server can send dhcp offers from different addresses
(correspond to ISPs) and
if the client can send dhcp request to each dhcp offer, I think it's
possible for the clients
to get multiple addresses from the server. Could you elaborate the
reason to not use this method?

Also, I'm wondering whether we always need to create virtual interface
since some OSs
allow us to assign multiple IP addresses on single interface.

Thanks,
--
Yoshifumi Nishida
[email-masked]

---

From: Rolf Winter <[email-masked]>
Date: Fri, 25 Mar 2011 09:27:43 +0000

Hi Yoshifumi,

if I understand you correctly, you suggest to simply send two DHCP offers for a single request (like having two DHCP servers in the network) and the client, instead of discarding one, will accept both and use them for multipath TCP. Is that correct?

That is possible but we had reasons to go with new options:

Say you already have a network with two DHCP servers, then the two offers (without any specific options) will not necessarily mean that you will get multipath out of them. That is not fatal from the MPTCP perspective, but not nice either and it is certainly not a behaviour that was anticipated when the two servers where deployed.

The new options give you the following benefit:

1) a DHCP server can tell that the client can do multi-path and give it the right information to ask for more addresses
2) a client can tell, even if multiple offers arrive which ones can be used for multi-path and can be certain that the different addresses will be routed over different networks. 
3) The general DHCP behaviour does not change, i.e. in case of multiple offers simply pick one etc.

I hope this makes sense to you.

Best,

Rolf

> -----Original Message-----
> From: [email-masked] [mailto:multipathtcp-
> [email-masked]] On Behalf Of Yoshifumi Nishida
> Sent: Freitag, 25. März 2011 08:44
> To: Rolf Winter
> Cc: [email-masked]
> Subject: Re: [multipathtcp] Single-homed end-host MPTCP -
> autoconfiguration
> 
> Hello Rolf,
> 
> > we have played with a single-homed end-system in a multi-homed site
> using MPTCP and it works like a charm. Therefore, we have implemented
> an auto-configuration mechanism for it using DHCP and tested that one
> too. If the WG feels that this is something useful we can present it.
> The work will ultimately need move to DHC but we first would like to
> know from the MPTCP group whether they feel it is useful. The draft can
> be found here:
> >
> > NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> >
> >

---

From: Yoshifumi Nishida <[email-masked]>
Date: Fri, 25 Mar 2011 12:12:29 -0700

Hi Rolf,
Thanks for the response.

> if I understand you correctly, you suggest to simply send two DHCP offers for a single request (like having two DHCP servers in the network) and the client, instead of discarding one, will accept b…

Yes. That's what I meant. (Although I'm just asking and not suggesting. )

> Say you already have a network with two DHCP servers, then the two offers (without any specific options) will not necessarily mean that you will get multipath out of them. That is not fatal from th…

Please correct me if I'm wrong. I think there are several reasons for
having multiple DHCP servers.
I'm guessing it will be something like
   1) redundancy
   2) load balancing/multi-home
   3) misconfiguration
In case of 1), it won't be very nice as you said. But, I think we
might be able to exclude this case by checking
the offered IP address. I mean, if client gets the same range of IP
addresses, it will send only one DHCP request to one server.
For 2), I think it's OK to use multipath.
For 3), clients can be messed up with or without multipath function.
so I think we don't have to think about this much..
Considering these cases, I think sending multiple DHCP requests might
be acceptable..

> 3) The general DHCP behaviour does not change, i.e. in case of multiple offers simply pick one etc.

I think I understand the benefit. But, my concern is some ISP might
provide to users settop boxes which
integrate NAT and DHCP servers. In such case, if you subscribe two
ISPs, you'll get two boxes, which
might be difficult to apply the idea of this draft.

Thanks,
--
Yoshifumi Nishida