Subject: Re: [multipathtcp] Fw:New Version Notification fordraft-deng-mptcp-mobile-network-proxy-00.txt

From: lingli deng <[email-masked]>
Date: Tue, 4 Mar 2014 19:38:27 +0800

Hi all,

Thanks for the comments and feedback yesterday regarding MPTCP proxy.

I recall a question from the floor regarding to applicability of MPTCP
proxy to TCPcrypt flows, but I didn’t catch the exact question or his name.

Would anyone help in clarifying the question or any other questions that
one feel needs to be addressed/discussed by posting to the list, before we
can start working on it.

Thanks a lot!

BR

Lingli

2014-02-16 9:26 GMT+08:00 lingli deng <[email-masked]>:

> Hi all,
>
> We uploaded a new I.D., which discusses the usecases of network deployed
> MPTCP proxy.
> URL: http://www.ietf.org/internet-drafts/draft-deng-
> mptcp-mobile-network-proxy-00.txt
> Your review and comments would be highly appreciated.
>
> Best Regards,
>
> Lingli
>
> ---------- Forwarded message ----------
> From: 邓灵莉 <[email-masked]>
> Date: 2014-02-14 23:59 GMT+08:00
> Subject: Fw:New Version Notification
> fordraft-deng-mptcp-mobile-network-proxy-00.txt
> To: denglingli <[email-masked]>
>
>
>
>
> ----邮件原文----
> 发件人：internet-drafts<[email-masked]>
> 收件人：Tao Sun <[email-masked]>,Dapeng Liu<[email-masked]
> >,Deng Lingli<[email-masked]>,Tao Sun<[email-masked]
> >,Lingli Deng <[email-masked]>,Dapeng Liu <
> [email-masked]>
> 抄 送: (无)
> 发送时间：2014-02-15 00:00:43
> 主题：New Version Notification fordraft-deng-mptcp-mobile-network-proxy-00.txt
>
>
> A new version of I-D, draft-deng-mptcp-mobile-network-proxy-00.txt
> has been successfully submitted by Lingli Deng and posted to the
> IETF repository.
>
> Name: draft-deng-mptcp-mobile-network-proxy
> Revision: 00
> Title: MPTCP Proxy for Mobile Networks
> Document date: 2014-02-14
> Group: Individual Submission
> Pages: 8
> URL:
> http://www.ietf.org/internet-drafts/draft-deng-mptcp-mobile-network-proxy-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-deng-mptcp-mobile-network-proxy/
> Htmlized:
> http://tools.ietf.org/html/draft-deng-mptcp-mobile-network-proxy-00
>
>
> Abstract:
>  This document discusses the motivation and usecases for ISP deployed
>  MPTCP proxies in mobile networks.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of submission
>
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
> Subject：New Version Notification fordraft-deng-mptcp-mobile-network-proxy-00.txt
>
>
> A new version of I-D, draft-deng-mptcp-mobile-network-proxy-00.txt
> has been successfully submitted by Lingli Deng and posted to the
> IETF repository.
>
> Name: draft-deng-mptcp-mobile-network-proxy
> Revision: 00
> Title: MPTCP Proxy for Mobile Networks
> Document date: 2014-02-14
> Group: Individual Submission
> Pages: 8
> URL:
> http://www.ietf.org/internet-drafts/draft-deng-mptcp-mobile-network-proxy-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-deng-mptcp-mobile-network-proxy/
> Htmlized:
> http://tools.ietf.org/html/draft-deng-mptcp-mobile-network-proxy-00
>
>
> Abstract:
>  This document discusses the motivation and usecases for ISP deployed
>  MPTCP proxies in mobile networks.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of submission
>
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
>
>
>
>
> --
> 邓灵莉/Lingli Deng
> 中国移动通信研究院/China Mobile Research Institute
> e-mail: [email-masked]
> tel: 15801696688-3367
> mobile: 13810597148
>

-- 
邓灵莉/Lingli Deng
中国移动通信研究院/China Mobile Research Institute
e-mail: [email-masked]
tel: 15801696688-3367
mobile: 13810597148

---

From: Olivier Bonaventure <[email-masked]>
Date: Tue, 04 Mar 2014 13:56:32 +0100

Lingli,

> one feel needs to be addressed/discussed by posting to the list,
> before we can start working on it.

If I recall correctly, this was a comment from Steve Kent who noted :

"If I were using TLS, this would be completely compatible, but tcpcrypt 
would not be"

The reason for the incompatibility with tcpcrypt is that tcpcrypt uses a 
MAC to protect the end-to-end TCP header while TLS only protects the 
datastream

Olivier

-- 
INL, ICTEAM, UCLouvain, Belgium, http://inl.info.ucl.ac.be