Subject: [multipathtcp] FW: [tcpinc] Protect or not the TCP header fields

From: Yoshifumi Nishida <[email-masked]>
Date: Tue, 7 Oct 2014 10:57:03 -0700

I guess many folks in the WG already know this, but just in case..

In tcpinc WG, they start making a design choice on which parts of tcp
segment should be protected.

http://www.ietf.org/mail-archive/web/tcpinc/current/msg00359.html

I'm personally wondering if this design decision can have some impacts on
securing mptcp.
According to the previous discussions, it seems to me that we might want to
utilize outcomes from the tcpinc WG for this.
If tcpinc focuses on only protecting payload, I'm wondering if we can still
utilize their outcomes for mptcp.
It would be great if someone could provide some thoughts on this.

Thanks,
--
Yoshi

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Tue, 7 Oct 2014 18:20:21 +0000

A more specific question related to this - sorry, I’ve not followed the past MPTCP discussion in detail:  Would MPTCP want to use a tcpinc TCP header protection (if that was part of tcpinc), but avoid a tcpinc payload encryption?

Would there be a use case for this?

Michael

From: multipathtcp [mailto:[email-masked]] On Behalf Of Yoshifumi Nishida
Sent: Tuesday, October 07, 2014 7:57 PM
To: multipathtcp
Subject: [multipathtcp] FW: [tcpinc] Protect or not the TCP header fields

In tcpinc WG, they start making a design choice on which parts of tcp segment should be protected.

I'm personally wondering if this design decision can have some impacts on securing mptcp.
According to the previous discussions, it seems to me that we might want to utilize outcomes from the tcpinc WG for this.
If tcpinc focuses on only protecting payload, I'm wondering if we can still utilize their outcomes for mptcp.
It would be great if someone could provide some thoughts on this.

Thanks,
--
Yoshi