Subject: [multipathtcp] Update to the draft agenda for MPTCP WG meeting

From: <[email-masked]>
Date: Sat, 18 Jul 2015 16:23:51 +0000

We've been working on a new version of the agenda (draft - updates still possible). https://www.ietf.org/proceedings/93/agenda/agenda-93-mptcp

Volunteers for note taking and jabber scribing would be much appreciated.

Please could presenters send slides by lunchtime Monday.

We've broken the agenda into several sections.

First we hear briefly about the status of the various implementations.

If anyone with another implementation wants to be added, please let us know.

We also need to discuss what goes in the WG doc - the suggestion was to start with "Guidelines for implementers" https://tools.ietf.org/html/draft-barre-mptcp-impl-00 (and perhaps include some info from https://tools.ietf.org/html/draft-eardley-mptcp-implementations-survey)

The second section is about Operational Experiences of using MPTCP http://datatracker.ietf.org/doc/draft-ietf-mptcp-experience/ .

The doc has gone through WG last call. We should discuss how to complete this doc, if anything is missing (perhaps to motivate proposed changes to RFC6824bis?)

Thomas: Please highlight anything from your work that should be included in the WG doc, which isn't already. Sorry the time constraints mean that your timeslot is shorter than you hoped.

Olivier: Do you want 5-10 minutes to highlight work from your recent submitted papers?

The third major topic is to discuss changes to RFC6824bis. The primary goal of the WG is to publish this on the Standards track. Our suggestion is to use our face-to-face time to discuss those proposals that have generated discussion /interest, and hopefully resolve each of them (resolution to be confirmed on the mailing list). I think the list is:-
* http://datatracker.ietf.org/doc/draft-bonaventure-mptcp-exp-option/
* Do we need both 4 & 8 byte Data ack & DSS?
* http://datatracker.ietf.org/doc/draft-barre-mptcp-tfo/
* http://datatracker.ietf.org/doc/draft-paasch-mptcp-syncookies/
* http://datatracker.ietf.org/doc/draft-boucadair-mptcp-symmetric/
* http://datatracker.ietf.org/doc/draft-bonaventure-mptcp-addr/

Please let us know if there are any other proposed mods to RFC6824bis that you think would particularly benefit from face-to-face discussion.

Unfortunately this is likely to use all our agenda time up, and there are a couple of presentations that we may therefore not get to. Hopefully we'll get another session for MPTCP, but if not we'll organise an interim (audio) meeting.

Also to highlight that Costin Raiciu's talk, rough title "Three ways to (ab)use Multipath TCP Congestion Control" is now part of the ICCRG meeting  (Wednesday, 3.50pm - 5.10pm, Congress Hall I).

thanks,

best wishes,

Phil & Yoshi.

---

From: <[email-masked]>
Date: Mon, 20 Jul 2015 18:57:00 +0000

Hi,

I uploaded all the presentations that I received so far. also tweaked the agenda slightly.

https://datatracker.ietf.org/meeting/93/materials.html [& search for mptcp]

I'm expecting several more.

Please send to me as soon as possible - early tomorrow.

This is important so that

[1] remote participants have access to the slides

[2] I've had some network problems, so last minute uploads are likely not to be possible

thanks!

phil

________________________________
From: multipathtcp <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: 18 July 2015 17:23
To: [email-masked]
Subject: [multipathtcp] Update to the draft agenda for MPTCP WG meeting

thanks,

best wishes,

Phil & Yoshi.