Subject: [multipathtcp] Implementation draft

From: Olivier Bonaventure <[email-masked]>
Date: Tue, 21 Jul 2015 13:02:24 +0200

Hello,

Our charter recommends that we write a draft on the guidelines for 
implementors. There are now several interoperable implementations, which 
shows that the protocol specification is understable.

The two existing drafts on this topic are :

https://tools.ietf.org/html/draft-eardley-mptcp-implementations-survey-02

https://tools.ietf.org/html/draft-barre-mptcp-impl-00

I would suggest to gather the known implementors and write a short draft 
to meet this remaining milestone. A possible table of contents could be :

1. Introduction

2. Known implementations

brief description of the known MPTCP implementations

3. Implementation choices

Some discussion of the choices made by implementors, such as :
  - support for add_addr/add_addr2 and remove_addr
  - support for 32bits/64 bits dsn
  - support for congestion control
  - support for other features of the protocol

4. Interoperability

a matrix with the known interopebility among the implementations

5. Conclusion

Olivier

---

From: <[email-masked]>
Date: Tue, 28 Jul 2015 16:22:37 +0000

Thanks Olivier.
Assuming this isn't too much work, I think it's worth doing. If it is a lot of work, we should discuss Lars's suggestion of not doing this doc.
Yes, it would be interesting to record what features aren't implemented by (some of) the implementations. Deployment status and plans (to the extent public) could also be interesting.

The charter says
<<The working group will document implementation advice. The current
documents have several points where an implementer may benefit from
guidance, for example about heuristics such as buffer sizing, or from
advice about alternative implementations such as bump-in-the-stack.

I think some of this material is already in the protocol RFC or bis doc. Is it worth moving?

Phil

> -----Original Message-----
> From: multipathtcp [mailto:[email-masked]] On Behalf Of
> Olivier Bonaventure
> Sent: 21 July 2015 12:02
> To: multipathtcp
> Subject: [multipathtcp] Implementation draft
> 
> Hello,
> 
> implementors. There are now several interoperable implementations,
> which shows that the protocol specification is understable.
> 
> I would suggest to gather the known implementors and write a short
> draft to meet this remaining milestone. A possible table of contents
> could be :
> 
> 1. Introduction
> 
> 2. Known implementations
> 
> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp