Subject: [multipathtcp] TR: I-D Action: draft-boucadair-mptcp-dhc-00.txt

From: <[email-masked]>
Date: Fri, 3 Jul 2015 05:53:55 +0000

Dear all,

Comments and suggestions are more than welcome. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : jeudi 2 juillet 2015 15:46
> À : [email-masked]
> Objet : I-D Action: draft-boucadair-mptcp-dhc-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : DHCP Options for Network-Assisted Multipath TCP
> (MPTCP)
>         Authors         : Mohamed Boucadair
>                           Christian Jacquenet
> 	Filename        : draft-boucadair-mptcp-dhc-00.txt
> 	Pages           : 10
> 	Date            : 2015-07-02
> 
> Abstract:
>    One of the promising deployment scenarios for Multipath TCP (MPTCP)
>    is to enable a Customer Premises Equipment (CPE) that is connected to
>    multiple networks (e.g., DSL, LTE, WLAN) to optimize the usage of its
>    network attachments.  Because of the lack of MPTCP support at the
>    server side, some service providers now consider a "network-assisted
>    mode" that relies upon the activation of a dedicated function called:
>    MPTCP Concentrator.  This document focuses on the explicit deployment
>    scheme where the identity of the MPTCP Concentrator(s) is explicitly
>    configured on connected hosts.
> 
>    This document specifies DHCP (IPv4 and IPv6) options to configure
>    hosts with Multipath TCP (MPTCP) parameters.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-boucadair-mptcp-dhc/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-boucadair-mptcp-dhc-00
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Fri, 3 Jul 2015 06:27:29 +0000

Hi Med,

My comments 
1) How will this work if endpoint is MPTCP-aware but CPE is not capable of acting as MPTCP proxy ?
2)You may want to discuss how the proposed mechanism can be used with https://tools.ietf.org/html/draft-ietf-mif-mpvd-dhcp-support-01 

Cheers,
-Tiru

> -----Original Message-----
> From: multipathtcp [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, July 03, 2015 11:24 AM
> To: multipathtcp
> Subject: [multipathtcp] TR: I-D Action: draft-boucadair-mptcp-dhc-00.txt
> 
> Dear all,
> 
> > [email-masked] Envoyé : jeudi 2 juillet 2015 15:46 À :
> > [email-masked] Objet : I-D Action:
> > draft-boucadair-mptcp-dhc-00.txt
> >
> >
> > submission until the htmlized version and diff are available at
> > tools.ietf.org.
> >
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp

---

From: <[email-masked]>
Date: Fri, 3 Jul 2015 07:15:52 +0000

Hi Tiru,

Thank you for the comments. 

Please see inline.

Cheers,
Med

> De : Tirumaleswar Reddy (tireddy) [mailto:[email-masked]]
> Envoyé : vendredi 3 juillet 2015 08:27
> À : BOUCADAIR Mohamed IMT/OLN; multipathtcp
> Objet : RE: I-D Action: draft-boucadair-mptcp-dhc-00.txt
> 
> Hi Med,
> 
> My comments

[Med] The draft assumes the following:

"This deployment scenario relies on MPTCP Proxy on both
   the CPE and the network sides (Figure 1). "

which means that the option is requested only when the CPE embeds an MPTCP proxy. 

As for an MPTCP-enabled host serviced by a CPE that does not embed an MPTCP proxy, the behavior is left unspecified because we considered it is out of scope.

> 2)You may want to discuss how the proposed mechanism can be used with
> https://tools.ietf.org/html/draft-ietf-mif-mpvd-dhcp-support-01

[Med] This is a good point...but the draft adopts a simple scheme where available access networks belong to the same administrative entity. We may clarify this point in the next revision.