Subject: [multipathtcp] MPTCP proxy work - call for ideas

From: <[email-masked]>
Date: Thu, 9 Mar 2017 15:27:48 +0000

Hi,

We have two (adjacent) sessions in Chicago - so we have some time to dedicate to MPTCP proxy related discussions.

We'd like to offer time for people to present their proposals. These could be new ideas, or relate to what has already been proposed.
In order to try and make this discussion more fruitful, please read the words below - which frame the scope of the discussion, and suggest how to present your idea.
Please let us know if you want time - we'll divide the available time, and leave plenty of time for discussion.
PS This is MPTCP proxy discussion - there may be some side meeting about banana.
PS This discussion proceeds without changing the charter. Depending on the idea(s) that get consensus, then we work out if it needs a re-charter or not, and about coordinating with other WGs.

Thanks,
Best wishes,
Phil & Yoshi

----
MPTCP is now seeing widespread deployment in networks to bond together two accesses, such as fixed and mobile broadband, by using an MPTCP-specific proxy or proxies. There are two scenarios. The first involves two proxies, one in the home gateway or Customer Premises Equipment and one in the network, both under the control of the operator. The other scenario involves an MPTCP-enabled smartphone, with LTE and WiFi, plus a proxy in the operator's network.
The WG will analyse proposed solutions for both the single and dual proxy scenarios. The solution(s) may require changes to RFC6824bis, and may require a means of configuring set-up information in the proxy, which would be done in coordination with other IETF WGs such as DHC.

Note:
- Single & two ended proxy in scope
- Proxy(s) are under control of operator
- Only TCP traffic considered
- Open for solution proposals. First step is to analyse proposals and reach consensus on one we go ahead with, or perhaps a solution for each scenario
- Hopefully just one solution, but possibly need a different solution for 1 & 2 ended scenarios. Not multiple solutions for each scenario.
- May (but may not) require changes to rfc6284 (for instance, is it an extension to the protocol, or using the existing protocol)
- If it does require a change to 6824, then prefer to include the change in the bis, in order have one version of the protocol.
- "appropriate IETF WGs" includes any WG arising from the banana BoF
- if the solution(s) require a non-MPTCP protocol to exchange information between the two proxies, this presumably wouldn't be in the remit of MPTCP WG

We now have a 'call for solution proposals'. First step is to analyse proposals and reach consensus on one we go ahead with

*                    proposal should be in the form of a "protocol model". See RFC4101, Writing protocol models: <<to present an architectural model for how the protocol operates ...  1. What problem is the protocol trying to achieve? 2.What messages are being transmitted and what do they mean? 3. What are the important, but unobvious, features of the protocol? >>

*                    if your ideas involve multiple possibilities, please either select your favourite, or report them as separate solutions

*                    The WG will consider single and dual proxy separately. But we favour solutions with a lot of "re-use" between the single and dual proxy. This is in terms of effort by the WG, implementers and deployers. We also favour solutions where the single and dual proxied solutions can co-exist

*                    Whilst you may not be ready to present your analysis of your proposal against the (proposed) Criteria (See separate email), it may be worth bearing them in mind.
----

---

From: <[email-masked]>
Date: Mon, 13 Mar 2017 17:26:10 +0000

We should also point out explicitly that the text below makes some assumptions about the scenarios of interest, the nature of the solutions and the way they're presented. Discussion is welcome, if people disagree.
To be explicit, for instance:  in the single-ended proxy case, the proxy is (most likely) not on both default paths; whilst the single-ended proxy & dual-ended proxy may need different solutions, we're not developing multiple solutions for each case; etc.
Thanks
Phil & Yoshi
From: multipathtcp [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 09 March 2017 15:28
To: [email-masked]
Subject: [multipathtcp] MPTCP proxy work - call for ideas

Hi,

Thanks,
Best wishes,
Phil & Yoshi

----

Note:

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 23 Mar 2017 16:44:12 +0000

Hi Phil, Yoshi

I could cover for the session a new scenario related with the application of MPTCP proxy to mobile backhaul / aggregation scenarios. Unfortunately there is not a supporting document for this yet, but I could through a descriptive scenario during the session by now, looking for a way for documenting it (if it is interesting for the people) afterwards.

>From the solution space perspective I foresee this scenario being solved by network-assisted MPTCP.

My only constraint would be that I most probably should leave the session at 18:00 (or even a bit before).

Bets regards

Luis

__________________________________
Luis M. Contreras

Technology and Planning
Transport, IP and Interconnection Networks
Telefónica I+D / Global CTO unit / Telefónica

Distrito Telefónica, Edificio Sur 3, Planta 3
28050 Madrid
España / Spain

Skype (Lync): +34 91 312 9084
Mobile: +34 680 947 650
[email-masked]<mailto:[email-masked]>

De: multipathtcp [mailto:[email-masked]] En nombre de [email-masked]
Enviado el: jueves, 9 de marzo de 2017 16:28
Para: [email-masked]
Asunto: [multipathtcp] MPTCP proxy work - call for ideas

Hi,

Thanks,
Best wishes,
Phil & Yoshi

----

Note:

---

From: <[email-masked]>
Date: Fri, 24 Mar 2017 12:39:40 +0000

Luis,
Good to hear you're in Chicago.
So far we proposed solving two proxy scenarios:
<< MPTCP is now seeing widespread deployment in networks to bond together two accesses, such as fixed and mobile broadband, by using an MPTCP-specific proxy or proxies. There are two scenarios. The first involves two proxies, one in the home gateway or Customer Premises Equipment and one in the network, both under the control of the operator. The other scenario involves an MPTCP-enabled smartphone, with LTE and WiFi, plus a proxy in the operator's network.
The WG will analyse proposed solutions for both the single and dual proxy scenarios. The solution(s) may require changes to RFC6824bis, and may require a means of configuring set-up information in the proxy, which would be done in coordination with other IETF WGs such as DHC.
If you've an additional scenario it would be good to hear about it. It would be good if you could tell us on the list, so we can discuss it before the meeting. We'll allow a bit of time during the meeting for discussion about the scenarios we're trying to solve, but I think this will be at the mike rather than presentations.
Also, there'll be some time for solution discussions (in turn for each of the two scenarios - or maybe three scenarios if another one is needed!). Not sure if you have a solution to propose? If you do, 1 or 2 slides is perfect - please present it in the form of a "protocol model".
Thanks
phil

From: LUIS MIGUEL CONTRERAS MURILLO [mailto:[email-masked]]
Sent: 23 March 2017 11:44
To: Eardley,PL,Philip,TUB8 R <[email-masked]>; [email-masked]
Subject: RE: MPTCP proxy work - call for ideas

Hi Phil, Yoshi

Bets regards

Luis

Technology and Planning

De: multipathtcp [mailto:[email-masked]] En nombre de [email-masked]<mailto:[email-masked]>
Enviado el: jueves, 9 de marzo de 2017 16:28
Para: [email-masked]<mailto:[email-masked]>
Asunto: [multipathtcp] MPTCP proxy work - call for ideas

Hi,

Thanks,
Best wishes,
Phil & Yoshi

----

Note: