Subject: [multipathtcp] Questions on explicit proxy

From: "Nandini Ganesh (nanv)" <[email-masked]>
Date: Wed, 2 Aug 2017 18:28:35 +0000

Hi,

I have been reviewing both the current drafts for explicit proxy/converters for MPTCP.

I have the following questions regarding plain mode draft

1.       Please can you give an example of a use-case where the D-bit is set MP_CONVERT_IE and how this “source address” will be used?

2.       The downstream explicit proxy will always intercept the traffic and convert it to TCP.  If the server is upgraded to support MPTCP, is there a method to dynamically learn this?

Also, are there any sample implementations of explicit MPTCP proxy as suggested in the drafts?

Thanks,
Nandini

---

From: <[email-masked]>
Date: Thu, 3 Aug 2017 06:15:17 +0000

Hi Nandini,

Please see inline.

Cheers,
Med

De : multipathtcp [mailto:[email-masked]] De la part de Nandini Ganesh (nanv)
Envoyé : mercredi 2 août 2017 20:29
À : [email-masked]
Cc : Sri Gundavelli (sgundave)
Objet : [multipathtcp] Questions on explicit proxy

Hi,

[Med] The main use case is for IPv6 source address preservation to avoid NPTv6 (RFC6296). An example is shown in slide 18 of https://datatracker.ietf.org/meeting/98/materials/slides-98-mptcp-sessa-network-assisted-mptcp. The packet that will be relayed by the proxy will be sourced with the IPv6 address indicated in the proxy supplied data. Doing so avoids breaking applications with referrals and many other things that would break with NPTv6 (https://tools.ietf.org/html/rfc6296#section-5)

[Med] The proxy does not systematically convert an MPTCP connection into TCP; it needs to wait for the SYN-ACK from the remote server to determine whether the remote server is MPTCP compliant. We clarified this in the new converter design; you can refer for instance to slide 8 of https://datatracker.ietf.org/meeting/99/materials/slides-99-mptcp-sessa-0-rtt-tcp-converters

Also, are there any sample implementations of explicit MPTCP proxy as suggested in the drafts?
[Med] I’m aware of some non-public implementations. Those implementations need to be adapted anyway to follow the new spec as sketched in the converter draft. Please use the converter draft as the reference document. Thank you.

Thanks,
Nandini