Subject: Re: name server without root cache

From: [email-masked]
Date: Fri, 05 Apr 2002 12:43:17 +1000

> >> Further - why invent new logic (lines of code to execute) to provide
> an
> >> error code for this situation ?
> >
> > Because it makes life much easier if we get predictable responses that
> we
> > can interpret in some meaningful way. If we just get SERVFAIL or
> NOTIMP
> > we cannot draw the conclusion that the server does not have the zon.
> 
> I agree - SERVFAIL / NOTIMP are not the solutions for this.
> We already have a well defined way to determine if a server has a zone -
> the AA-flag in the response.
> 
> 
> > Yes, a different status code would be simpler, but we are not there,
> so
> > let's keep thing transparent until a new status model is in place (the
> > status codes of DNS are unfortunately too overloaded).
> > Some people like me like to be able to analyse broken delegations and
> come
> > to some reasonable conclusion what is wrong. Knowing that the server
> is
> > not configured with the zone is a good start for communcating with
> > sometimes "broken" DNS administrators.
> 
> DNS could certainly use more specific status codes.
> However, for this particular scenario I think it's already pretty well
> defined (AA-flag / missing closer referral) and unnecessary to invent
> more...

	No.  You either return a valid answer or a error indication.
	
	rcode=noerror, nscount=0 is not a valid answer

> 
> 
> Jesper G. Hoy
> 
> 
> 
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 5 Apr 2002 12:07:41 +0859 ()

Mark;

> 	No.  You either return a valid answer or a error indication.

The other option is to silently igrore a query and return nothing.

							Masataka Ohta

---

From: Rob Austein <[email-masked]>
Date: Thu, 04 Apr 2002 23:25:06 -0500

> rcode=noerror, nscount=0 is not a valid answer

I'm pretty sure that RFC 1035 permits

  QR=1 RCODE=0 AA=0 ANCOUNT=0 NSCOUNT=0 ADCOUNT=0

To the best of my limited ability to remember the contents of 15 year
old packet dumps, this is exactly how the JEEVES nameserver program
responded when its resolver program was disabled and it received a
query for a QNAME that wasn't in any of the zones for which it had
authoritative data loaded.

Whether such a response would be -advisable- given what current
software might think it means is a separate question.