Subject: Re: name server without root cache

From: Masataka Ohta <[email-masked]>
Date: Thu, 4 Apr 2002 08:59:15 +0859 ()

Rob Austin;

> It's clear that the resolution process will never complete in the
> general case unless -somebody- in the query path knows where the root
> is, but the core protocol doesn't assume either that every name server
> knows or that every resolver knows.

RFC 1034:

: 5.3.1. Stub resolvers
: 
: One option for implementing a resolver is to move the resolution
: function out of the local machine and into a name server which supports
: recursive queries.

RFC 1035:

: In either case,
: resolvers are replaced with stub resolvers which act as front ends to
: resolvers located in a recursive server in one or more name servers
: known to perform that service:
: 
:                    Local Hosts                     |  Foreign
:                                                    |
:     +---------+                                    |
:     |         | responses                          |
:     | Stub    |<--------------------+              |
:     | Resolver|                     |              |
:     |         |----------------+    |              |
:     +---------+ recursive      |    |              |
:                 queries        |    |              |
:                                V    |              |
:     +---------+ recursive     +----------+         |  +--------+
:     |         | queries       |          |queries  |  |        |
:     | Stub    |-------------->| Recursive|---------|->|Foreign |
:     | Resolver|               | Server   |         |  |  Name  |
:     |         |<--------------|          |<--------|--| Server |
:     +---------+ responses     |          |responses|  |        |
:                               +----------+         |  +--------+
:                               |  Central |         |
:                               |   cache  |         |
:                               +----------+         |

It's just a malconfiguration at the resolver side that it is not
surprising that there can be no proper behaviour at the server side.

							Masataka Ohta

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Alexis Yushin <[email-masked]>
Date: Thu, 4 Apr 2002 04:35:45 +0200 (CEST)

>Keep in mind that the "safety belt" information that's sometimes
>incorrectly referred to as "root hints" is really just a list of IP
>addresses of name servers for an iterative resolver to ask when it has
>no better idea of where to send a query.  This is most commonly used

Worst case scenario is when RA=0 server has outdated .hints file.

Alexis