Subject: A6/DNAME - game over

From: Paul Vixie <[email-masked]>
Date: Thu, 30 May 2002 23:27:48 -0700

just fyi.  itojun and marka have done the deed.  as of 8.3.2 and 9.2.1,
the bitstring approach to gethostbyaddr() for IPv6 will be dead.  i'm
personally still quite convinced that this will make IPv6 less approachable
for networks who want to multihome.  but professionally speaking, the
ietf consensus on this matter is obvious.  ISC's mission is in two parts:
(1) try to make the standards sensible; (2) implement whatever standards
result.  i consider that we have failed at (1), and at considerable cost
in BIND9's original time/money budgets as well as its performance.  but
we are nevertheless continuing with (2).

re:

------- Forwarded Message

Subject: CVS commit: bind8
Message-Id: <[email-masked]>
Date: Thu, 30 May 2002 23:05:34 -0700 (PDT)

Module Name:	bind8
Committed By:	marka
Date:		Fri May 31 06:05:34 UTC 2002

Modified Files:
	bind8/src: CHANGES
	bind8/src/include: resolv.h
	bind8/src/lib/irs: dns_ho.c
	bind8/src/lib/resolv: res_init.c res_private.h

Log Message:
1286.   [func]          libbind: no longer attempts bit string labels for
                        IPv6 reverse resolution.  Try IPV6.ARPA then IPV6.INT
                        for nibble style resolution.

To generate a diff of this commit:
cvs rdiff -r8.1022 -r8.1023 bind8/src/CHANGES
cvs rdiff -r8.47 -r8.48 bind8/src/include/resolv.h
cvs rdiff -r1.35 -r1.36 bind8/src/lib/irs/dns_ho.c
cvs rdiff -r8.28 -r8.29 bind8/src/lib/resolv/res_init.c
cvs rdiff -r8.2 -r8.3 bind8/src/lib/resolv/res_private.h

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

------- End of Forwarded Message

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Bill Manning <[email-masked]>
Date: Fri, 31 May 2002 08:03:35 -0700 (PDT)

Humph.  A6/DNAME are being moved to -EXPERIMENTAL- not
	being depricated to -HISTORIC- so I don't see that killing
	off these two RR types in the reference implementation 
	makes sense, ...yet.  Looks like a reason to stay with 9.2.0
	to me.

% just fyi.  itojun and marka have done the deed.  as of 8.3.2 and 9.2.1,
% the bitstring approach to gethostbyaddr() for IPv6 will be dead.  i'm
% personally still quite convinced that this will make IPv6 less approachable
% for networks who want to multihome.  but professionally speaking, the
% ietf consensus on this matter is obvious.  ISC's mission is in two parts:
% (1) try to make the standards sensible; (2) implement whatever standards
% result.  i consider that we have failed at (1), and at considerable cost
% in BIND9's original time/money budgets as well as its performance.  but
% we are nevertheless continuing with (2).
% 
% re:
% 
% ------- Forwarded Message
% 
% Subject: CVS commit: bind8
% Message-Id: <[email-masked]>
% Date: Thu, 30 May 2002 23:05:34 -0700 (PDT)
% 
% Module Name:	bind8
% Committed By:	marka
% Date:		Fri May 31 06:05:34 UTC 2002
% 
% Modified Files:
% 	bind8/src: CHANGES
% 	bind8/src/include: resolv.h
% 	bind8/src/lib/irs: dns_ho.c
% 	bind8/src/lib/resolv: res_init.c res_private.h
% 
% Log Message:
% 1286.   [func]          libbind: no longer attempts bit string labels for
%                         IPv6 reverse resolution.  Try IPV6.ARPA then IPV6.INT
%                         for nibble style resolution.
% 
% 
% To generate a diff of this commit:
% cvs rdiff -r8.1022 -r8.1023 bind8/src/CHANGES
% cvs rdiff -r8.47 -r8.48 bind8/src/include/resolv.h
% cvs rdiff -r1.35 -r1.36 bind8/src/lib/irs/dns_ho.c
% cvs rdiff -r8.28 -r8.29 bind8/src/lib/resolv/res_init.c
% cvs rdiff -r8.2 -r8.3 bind8/src/lib/resolv/res_private.h
% 
% Please note that diffs are not public domain; they are subject to the
% copyright notices on the relevant files.
% 
% 
% 
% ------- End of Forwarded Message
% 
% 
% --
% to unsubscribe send a message to [email-masked] with
% the word 'unsubscribe' in a single line as the message text body.
% archive: <http://ops.ietf.org/lists/namedroppers/>
% 

-- 
--bill

---

From: Paul Vixie <[email-masked]>
Date: Fri, 31 May 2002 11:02:47 -0700

> 	makes sense, ...yet.  Looks like a reason to stay with 9.2.0

it's dead, bill.

---

From: Paul Vixie <[email-masked]>
Date: 31 May 2002 12:57:01 -0700

Mats Dufberg <[email-masked]> writes:

> On May 31, 2002, 08:03 (-0700) Bill Manning <[email-masked]> wrote:
> 
> Only A6 is being moved to experimental, not DNAME. There is no change of
> DNAME as such, only the recommended solution for the reverse tree is
> changed.

DNAME deployment (in terms of both zones which use it, gethostbyaddr()
implementations which will follow it, authority server implementations
who handle it, and recursive server implementations who glue it) has
been stalled for some time.  Getting rid of bitstrings gets rid of the
major reason for having DNAME.  Moving A6 to experimental gets rid of
the remaining incentive for having DNAME.

It's dead.  It's all dead.  We're doing AAAA and PTR.  I'm not happy
about it -- not about what we're doing and not about how we went about
failing to decide to do anything else -- but it's time to move on.

BIND9.next will remove support for all of this performance-draining goo
unless the IETF somehow reverses itself yet again, which seems unlikely.
--
Paul Vixie

---

From: Mats Dufberg <[email-masked]>
Date: Fri, 31 May 2002 22:58:16 +0200 (CEST)

> unless the IETF somehow reverses itself yet again, which seems unlikely.

Will that mean that DNAME will be moved out of bind (bind9) even though it
is still defined in an RFC in standards track?

Mats

----------------------------------------------------------------------
Mats Dufberg				             Registry TeliaNet
[email-masked]                                  Skanova/AO Networks
+46 8 456 7274                                               Box 10707
+46 70 258 2588                                    SE-121 29 Stockholm
----------------------------------------------------------------------

---

From: Paul Vixie <[email-masked]>
Date: Fri, 31 May 2002 14:06:21 -0700

> is still defined in an RFC in standards track?

no, our charter doesn't permit that.  but if it isn't used, it'll be #ifdef'd
and will begin to rot, and ultimately it will get axed like IQUERY was.