Subject: Re: Q2: crypto algorithm requirements for DNSSEC

From: Derek Atkins <[email-masked]>
Date: 11 Feb 2003 23:41:08 -0500

[email-masked] writes:

> 	No you can't forsee all eventualities.  You can however plan
> 	to recover from single points of failure.

Fine, then let's define 10 different algorithms, call them all MUST,
and require everyone to sign their zone 10 times...

Where does it end?

Seriously, you're over-engineering a solution to something I consider
a non-problem.  And honestly I think that Mr. Bellovin or Mr. Schiller
would agree with me that this is a non-problem.  The problem we want
to solve here is that DNS Resolvers, Caching Services, and Primary
Servers are slow to deploy/upgrade.  Changing the software is HARD.

However, the DATA in the DNS is _EASY_ to change...

Let's not lose sight of the forest for the trees....

> 	Mark

-derek

-- 
       Derek Atkins
       Computer and Internet Security Consultant
       [email-masked]             www.ihtfp.com

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: [email-masked]
Date: Wed, 12 Feb 2003 16:05:24 +1100

> and require everyone to sign their zone 10 times...

	Well you only need two at any point in time to deal with a
	single failure.

> However, the DATA in the DNS is _EASY_ to change...

	No.  It's not easy.  It's easier but it's still hard.

	When it happens it is going to be hard enough just to get
	the word out to say "don't use this algorithm anymore".
	It will be MUCH harder to get the new data deployed if it
	is not deployed as part of standard procedures.

	MUCH HARDER still will be the job to roll out the new
	manditory it implement algorithm to replace the corrupted
	one.
 
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: David Blacka <[email-masked]>
Date: Wed, 12 Feb 2003 00:35:23 -0500

> and require everyone to sign their zone 10 times...

I'd like to point out that because of the way DNSSEC verifiers are defined to 
work, when you sign your zone with more than one algorithm, you become open 
to attack when *any one* of those algorithms is found weak.  Verifiers just 
ignore non-validating SIGs.

To my thinking, signing with more than one algorithm is less secure than 
signing with just one.  Or, at best, no more secure.

Honestly, I understand where Mark is coming from.  He is optimizing for the 
resolver perspective.  From the resolvers point of view, being able to just 
"turn off" the broken algorithm and then have the entire DNSSEC tree suddenly 
be secure again must be pretty attractive.  

But from the zone owner's perspective, his zone will be vulnerable until 
either he re-signs the zone or all resolvers are reconfigured to not use the 
bad algorithm.  From the zone owner's perspective the fastest way back to 
security is to resign the zone.  Who knows how long it will take for all the 
security aware resolvers to change their configurations?

-- 
David Blacka    <[email-masked]> 
Sr. Engineer    Verisign Applied Research

---

From: Greg Hudson <[email-masked]>
Date: 12 Feb 2003 01:41:29 -0500

On Wed, 2003-02-12 at 00:35, David Blacka wrote:
> bad algorithm.

I don't see how re-signing the zone helps.  If I can forge, say, RSA
signatures, then I can forge a signature chain all the way from the
client's pre-configured RSA public key to the domain I'm trying to
attack, whether or not the real zone data has been re-signed with a DSA
key.

---

From: "Olaf M. Kolkman" <[email-masked]>
Date: Wed, 12 Feb 2003 09:37:31 +0100

> 	is not deployed as part of standard procedures.

My over-engineering-flag is raised as well; If RSA get's compromised
the DNS is the least of my worries... If RSA get's compromised I can
live with an unsecured DNS tree... just as I can live with it today.

In other words: "You do not have to outrun the bear as long as you
outrun the other guy" and if RSA is compromised there are other guys
than DNS that are a much tastier game.

--Olaf

--------------------------------------------| Olaf M. Kolkman
                                            | www.ripe.net/disi

---

From: Kare Presttun <[email-masked]>
Date: Wed, 12 Feb 2003 12:42:02 +0100

>than DNS that are a much tastier game.
Sooo true!!

Med vennlig hilsen | Best regards,
Kåre Presttun
Tel.: +47 4100 4908
mailto:[email-masked]
http://www.presttun.org/kare/