Subject: Re: Q1 followup - arguements against "MUST NOT" language

From: [email-masked]
Date: Thu, 06 Mar 2003 08:00:00 +1100

> That seems to be the prevailing winds - MUST NOT compress DNS names in the
> RDATA (paraphrase).  Basically, change the DNSSEC specs to keep in line with
> the unknown-rrs draft and namedroppers discussion.

	The MUST NOT is to prevent the case of the letters in the label
	being changed and thereby causing signature comparision to fail.

	Potentially it could be compressed if you added additional
	restrictions to the current compression algorithim to also
	check the case of labels when looking for compression pointer
	targets.

	The actual requirement is that the case of the labels be
	preserved.  Not compressing domain names in the rdata is a
	way to achieve that.
 
> Scott
> ----- Original Message -----
> From: "Edward Lewis" <[email-masked]>
> To: "Scott Rose" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, March 05, 2003 9:43 AM
> Subject: Re: Q1 followup - arguements against "MUST NOT" language
> 
> 
> > Also, what do you mean by "use" ;)
> >
> > I'm leaning towards "MUST NOT compress domain names in the RDATA
> > sections when assembling and transmitting a message."  (Includes
> > dynamic update request messages when using this wording.)
> >
> > 1) Bytes compressed away in a SIG message are miniscule compared to
> > the signature.
> >
> > 2) A response won't have many NXT's anyway (unlike NS records which
> > may be numerous in a referral).
> >
> > 3) Assuming EDNS0 is going to enlarge the minimum maximum message
> > size from 512, what's a few extra bytes.
> >
> >
> > At 13:40 -0500 2/12/03, Scott Rose wrote:
> > >The general consensus is that name compression in RDATA is A Bad Thing
> (tm),
> > >but there are some differences on the wording for the spec:
> > >
> > >Sub-Question:  What are the arguments against using the terms (1)"MUST
> NOT
> > >use name compression on DNS names in the RDATA on sending over the wire"
> > >(paraphrasing here) over (2)"SHOULD NOT use name compression on DNS names
> in
> > >the RDATA..."?
> > >
> > >Notes:
> > >     A.  (1) is the strength of the wording used in the unknown-rrs
> draft.
> > >There would be consistency.
> > >
> > >
> > >
> > >Scott
> > >
> > >
> > >
> > >
> > >--
> > >to unsubscribe send a message to [email-masked] with
> > >the word 'unsubscribe' in a single line as the message text body.
> > >archive: <http://ops.ietf.org/lists/namedroppers/>
> >
> > --
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> > Edward Lewis                                          +1-703-227-9854
> > ARIN Research Engineer
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: [email-masked] (Andreas Gustafsson)
Date: Wed, 5 Mar 2003 13:47:14 -0800 (PST)

> 	being changed and thereby causing signature comparision to fail.

No, the canonicalization specified in RFC2535 section 8.1 (and revised
in unknown-rrs section 7) will keep that from happening.

The real problem is that the record would be corrupted by servers that
attempt to treat it transparently, as I just explained in my message
to Edward Lewis.
-- 
Andreas Gustafsson, [email-masked]