Subject: Re: wcard-clarify breaking RFC 2308 NXDOMAIN

From: Paul Vixie <[email-masked]>
Date: Wed, 27 Aug 2003 15:22:51 +0000

> > Vixie responded:
> >
> >    RFC 2308 implicitly outlawed BIND's behaviour, which is to return
> >    NOERROR/ANCOUNT=0 for empty nonterminals. After RFC 2308, empty
> >    nonterminals are signalled with NXDOMAIN.
> >
> > There wasn't even a whisper of disagreement.
> 
> If Paul Vixie said that, he was wrong.  His mistake does not amount to a
> change of the protocol.

i did say it and i was wrong.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Paul Vixie <[email-masked]>
Date: Thu, 28 Aug 2003 15:17:36 +0000

> >    (3) publishes BIND 9, which uses NXDOMAIN in this situation, and

> (3) is a bug in bind 9.

which version/versions, specifically?  see below.

---

;; ANSWER SECTION:
version.bind.           0       CH      TXT     "9.3.0a0"

---

;; QUESTION SECTION:
;this.example.vix.com.          IN      A

;; AUTHORITY SECTION:
example.vix.com.        3600    IN      SOA     example.vix.com. root.vix.com. 2003082602 1800 900 604800 86400

---

#fh:i386# grep this example.vix.com 
test.a.is.this  A       127.0.0.5

---

i don't know why any of you is bothering to refute bernstein's assertions,
or even respond to him, or even read his tripe.  however, do consider the
likelihood of him defending my prior comments had he DISAGREED with them,
and also consider that whilest i did in fact misunderstand/misread RFC2308,
several other members of what bernstein laughably calls "the bind company",
notably the author of rfc2308 and a coauthor of the current wildcard draft,
have views remarkably different than the one bernstein quotes me as having.

can we have some serious discourse now?