Subject: Re: Prupose of draft-ietf-dnsext-dnssec-trans-00.txt

From: Paul Vixie <[email-masked]>
Date: 11 Jun 2004 18:06:56 +0000

"Olaf M. Kolkman" <[email-masked]> writes:

> ...
> The question is if with this set of ways forward we can ship
> DNSSEC-bis without closing the doors on ourselves.
> 
> We do not want to select the actual solution now, we want to make sure
> if we do not close the door on ourselves. 
> 
> If you think we are closing the door on ourselves by shipping
> DNSSEC-bis as is than please speak up (as Simon Josefsson did in the
> "DNSKEY flags field" thread). 

and did you want those of us who consider the current -trans and -ter drafts
to be evidence of the possibility of moving from -bis to -ter later, and who
therefore think that -bis should be sent to IESG with only editorial changes
as required to answer recent document quality questions, to just stay silent?

in other words, is this a positive-pressure or negative-pressure gate?
-- 
Paul Vixie

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Ólafur Gudmundsson/DNSEXT co-chair <[email-masked]>
Date: Fri, 11 Jun 2004 14:32:20 -0400

>as required to answer recent document quality questions, to just stay silent?

The -trans and -ter drafts document there are ways forward even if
we deploy -bis. We plan on publishing one or both as Informational RFC
for future reference.

We chairs encourage you to either submit the -ter document as a Internet draft
or take relevant text out of the -ter document and fold it into the
-trans document.

What we the chairs would like is to move some of this discussion to
[email-masked] (the WG alternate mailing list for half baked ideas).

>in other words, is this a positive-pressure or negative-pressure gate?

The chairs only apply gentle positive-pressure ;-)

Discussion we encourage on namedroppers:
         - current set of DNSSEC-bis documents
         - making NSEC, DNSKEY, DS, RRSIG more robust for future use
         - draft-ietf-dnsext-dnssec-trans-00.txt related to
                 errors, missing cases, clarifications of text.
         - Wild card clarify issues
         - LLMNR draft.
         - Interoperabilty of DNS protocol documents that are in Proposed
                 Standard state.
         - Any DNS other protocol issues

Discussion we preferred to take place on [email-masked]
         - alternatives to NSEC or the need for NSEC functionality.
         - unpublished draft vixie-...-ter
         - costs of different alternatives
         - Crypto issues
         - alternative in dnssec-trans-0x.txt to recommend.
         - ideas for in-protocol DNSKEY revocations
         - alternate validation of Trust anchors.
         - DNSSEC issues that are somewhere between protocol and operations.

We are planning to have a two meeting slots at the next IETF in San Diego,
to provide high bandwidth forum to discuss many of these ideas.
We requested these slots be spaced out as much as possible to
facilitate smaller groups working on ideas/analysis/testing during
the meeting.

         Ólafur (on behalf of Olaf)

---

From: Alex Bligh <[email-masked]>
Date: Fri, 11 Jun 2004 19:55:41 +0100

Olafur,

> Discussion we encourage on namedroppers:

I am now confused. The first message said radio silence on (nearly)
everything. Your co-chair's second said radio silence on NSEC2 but "feel
free to discuss any other item that is within the scope of DNSEXT." And
this message seems to suggest the latter are out of scope.

So namedroppers is the dnsext mailing list, and -trans is a dnsext w/g
draft. So is discussion on
 draft-ietf-dnsext-dnssec-trans-00.txt
acceptable here (provided it does not touch on NSEC2) or not?

Alex

---

From: Ólafur Gudmundsson/DNSEXT co-chair <[email-masked]>
Date: Fri, 11 Jun 2004 15:27:50 -0400

>this message seems to suggest the latter are out of scope.

DNSEXT WG has 2 official mailing lists, see: www.dnsext.org [1]
NSEC2 and other Negative alternatives discussion should
move to [email-masked], where the subgroup of DNSEXT people
interested playing with new ideas for DNSSEC is concentrated.

>acceptable here (provided it does not touch on NSEC2) or not?

As long as the discussion is about document quality or
  "signalling" mechanisms not the "Negative answer" mechanisms.

         Olafur
[1] Thanks Stewart Cheshire for providing this redirect service.