Subject: Re: [dnsop] Re: getaddrinfo/TTL and resolver application-interface

From: Paul Vixie <[email-masked]>
Date: Sun, 01 Aug 2004 00:37:10 +0000

i don't think expansing getaddrinfo/getnameinfo to return ttl is the
right approach.  we need a "getrrsetbyname" for dns-aware applications
that returns ttl, security status, and so on.  it should be in an rfc,
like the advanced ipv6 api document.  it should be pushed toward posix.

isc had proposed this to some of our funding agencies but i believe it
was "too much too soon" at the time.  perhaps MODA will pick it up now.

re:

> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked],
> 	[email-masked]
> Subject: Re: [dnsop] Re: getaddrinfo/TTL and resolver application-interface
> X-Mailer: Cue version 0.8 (040717-1035/itojun)
> Date: Sun,  1 Aug 2004 09:14:19 +0900 (JST)
> From: [email-masked] (Jun-ichiro itojun Hagino)
> Sender: [email-masked]
> 
> > On the other hand, introducing an new ai_ttl field at the end of struct
> > addrinfo can be done without any effect on binaries (since the field offsets of
> > the other fields do not change, and freeaddrinfo() will free the correct size
> > structure). Applications which want to use ai_ttl would then do
> > 
> > 	call getaddrinfo...
> > #ifdef _GETADDRINFO_AI_TTL
> > 	ttl = ai->ai_tll;
> > #else
> > 	ttl = 30;	/* Or some other constant */
> > #endif
> > 
> > While this is more painful than if we'd included ai_ttl from the start,
> > it seems to be less painful than standardizing getrrsetbyname() to
> > ensure portability of that interface across platforms.
> 
> 	getaddrinfo() is not a DNS-only function; it can lookup hostname-to
> 	address using /etc/hosts, NIS, LDAP, whatever you have.  what value
> 	would you put in to ai_ttl when the lookup is done by non-DNS method?
> 
> itojun
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/namedroppers/>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Pekka Savola <[email-masked]>
Date: Sun, 1 Aug 2004 06:15:29 +0300 (EEST)

> 	would you put in to ai_ttl when the lookup is done by non-DNS method?

-1, unless something else is provided?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html