Subject: Re: Caching SOA records (was Re: SPF I-D for review: draft-schlitt-spf-classic-00.txt)

From: Paul Vixie <[email-masked]>
Date: Wed, 12 Jan 2005 21:03:46 +0000

> FWIW, my BIND 9.2.4 recursive name server clearly caches SOA records,
> as do a few other BIND recursive servers of random or unknown version
> numbers that I queried.

i stand corrected.  i usually don't think of RFC 2182 when i think of dns,
and the "throw away line" in RFC 1035 has governed both my thinking, and
various early coding efforts.  (matt has corrected me on this point before.)

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: wayne <[email-masked]>
Date: Wed, 12 Jan 2005 15:29:02 -0600

> various early coding efforts.  (matt has corrected me on this point before.)

minor nit:  That's RFC2181, not 2182.

It happens to be the same RFC that I reference in the spf-classic
draft for the definition of a zone cut.  I found it quite educational,
and if there is misinformation in it, I would be quite interested in
learning about the errors.

-wayne

---

From: Mark Andrews <[email-masked]>
Date: Thu, 13 Jan 2005 08:52:54 +1100

> various early coding efforts.  (matt has corrected me on this point before.)

	named negative responses to SOA queries as if they had a
	zero TTL.  This is done to allow a client to query for the
	SOA record to find the zone cut and if the query domain
	didn't exist to not leave a negative cache entry that would
	slow the visibility of changes made by subsequent UPDATE
	requests.

	This is not in any RFC though perhaps it should be.
	This only applies to releases of named that support UPDATE.

	Mark
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Paul Vixie <[email-masked]>
Date: Wed, 12 Jan 2005 22:45:24 +0000

one more thing, because i'm feeling a sheepish need to explain my confusion.

> FWIW, my BIND 9.2.4 recursive name server clearly caches SOA records, ...

BIND 8.4.5, which is the last nameserver i personally worked on, does not.