Subject: Re: What is a type? I-D ACTION:draft-iab-dns-choices-00.txt

From: Edward Lewis <[email-masked]>
Date: Wed, 19 Jan 2005 10:59:32 -0500

At 11:48 AM +0100 1/19/05, Anders Rundgren wrote:
>The following may be of some interest to existing and future creators of
>DNS-based "kitchen sinks" [I-D: draft-iab-dns-choices-00.txt]
>
>What is a type?
>===============

(History soapbox comment)

This is defined in RFC 1034, section 3.6 (Resource Records) starting 
on page 11.  In particular, this is taken from page 12:

# When we talk about a specific RR, we assume it has the following:
#
# owner           which is the domain name where the RR is found.
#
# type            which is an encoded 16 bit value that specifies the type
#                 of the resource in this resource record.  Types refer to
#                 abstract resources.
# ...

*Redefining* terms has proven to cause more confusion than progress.

 From someone who's travelled down the wrong road to extensions 
(DNSSEC leading to RFC 2065), you have to work within the system to 
make progress.  The security experts involved then were more 
concerned about cryptography and chains of trust than figuring out 
how the DNS worked and shoring up the protocols real vulnerabilities. 
E.g., instead of deriving a DS RR as a manifestation of the 
delegation, they held fast to the notion that keys ought to be kept 
off-line.  (Then along came dynamic update and registries that update 
DNS many times an hour.)

Redefining terms and questioning the basic philosophy will only lead 
to a torpedoing of the entire effort, maybe even the base.

>A single remaining issue
>========================

Optimism. ;)
Couldn't resist.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                                +1-571-434-5468
NeuStar

"A noble spirit embiggens the smallest man." - Jebediah Springfield

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 19 Jan 2005 18:03:41 +0100

>"Edward Lewis" <[email-masked]> wrote:

>to a torpedoing of the entire effort, maybe even the base.

"Redefining terms".  Rather documenting how things actually work.

"Questioning the basic philosophy".
Well, I cannot recall any other Internet-scale system which requires that
app-specific data types are defined by centrally maintained 16-bit integers.

I don't seriously believe that any consensus on this will ever occurr.  I'm
fully satisfied if the various communities creating applications, can agree on
some kind of "interpretation" of what they are doing, because then progress
can hopefully be made.

Anders Rundgren

---

From: Alex Bligh <[email-masked]>
Date: Wed, 19 Jan 2005 18:14:33 +0000

> app-specific data types are defined by centrally maintained 16-bit

Go look at the list of IANA registries. You will find rather
a lot of 16-bit (and indeed 8-bit) registries. Protocol numbers,
and well known ports off the top of my head.

Alex