Subject: Re: SPF I-D for review: draft-schlitt-spf-classic-00.txt

From: Florian Weimer <[email-masked]>
Date: Wed, 12 Jan 2005 21:23:18 +0100

* william elan net:

> On Wed, 12 Jan 2005, Paul Vixie wrote:
>
>> > > ... how would you propose to discover the "zone cut" you're speaking of?
>> > 
>> > By checking the authority section:
>> 
>> did you know that the authority section is optional in positive responses?
>> (have you read RFC 2308?)
>
> Positive responses are not a problem - if somebody queries for SPF
> RR and gets it, there is no need to do anything else.

SPF lookup for domains used in Internet mail *always* result in
positive responses because there exists an MX or A record for that
domain.  Conforming resolvers do not return an error code in this
case, but an empty data section.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Robert Elz <[email-masked]>
Date: Fri, 14 Jan 2005 18:39:04 +0700

Date:        Tue, 11 Jan 2005 22:11:30 -0800 (PST)
    From:        "william(at)elan.net" <[email-masked]>
    Message-ID:  <[email-masked]>

  | If there is no authority 
  | section for negative response, then client can directly query for SOA.

That's impossible.   You cannot find a zone but by making an
SOA query, that would beg the question - that is, you have to
know what name to query, that's the name at the zone cut, which
is what you were seeking in the first place.

kre