Subject: Re: semantic overload

From: Roy Arends <[email-masked]>
Date: Wed, 9 Mar 2005 17:56:42 +0100 (CET)

On Wed, 9 Mar 2005 [email-masked] wrote:

> ok,
> 	Ed is btwn a rock and a hard place.  He has done great work
> 	with wild cards, working out most of the kinks.  I'm still
> 	in favor of allowing all labels to exist, the tough call is
> 	trying to properly represent a "wildcard" in a zone file.
>
> 	e.g.  having the character "*" represent both a valid label
> 	as well as a trigger for other processing.   perhaps we could
> 	use something else to indicate "wildcard" functions should be
> 	involked.... like /null :)

So I can't delegate /null anymore  :)

Roy

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Thu, 10 Mar 2005 04:03:00 +1100

> --bill

	Wildcard label type?  '\*' it indicate.

--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Alex Bligh <[email-masked]>
Date: Wed, 09 Mar 2005 17:01:06 +0000

> 	involked.... like /null :)

Why is this a qualitatively different problem from other characters
(e.g. CR, LF) which can (for the masochistic) be valid constituent
components of labels?

Can't we just say that in some circumstance (presumably "on disk"
format at a minimum, but also presumably AXFR) some characters need
to be escaped if you don't want them to assume their special meaning?
IE I'm pretty sure that having
	$ORIGIN	example.com
	\052		IN	MX	notawildcardmx.example.com.
	*		IN	MX	wildcardmx.example.com.
isn't going to break very much, is it?

Not sure how this affects AXFR though...

Alex