Subject: Re: Advancing AAAA to Full standard ?

From: Edward Lewis <[email-masked]>
Date: Tue, 15 Nov 2005 09:04:29 -0500

At 16:56 +1100 11/15/05, Mark Andrews wrote:

>
>	http://www.root-servers.org/ will give you the IPv6 addresses
>	of the root servers.  It's easy enough to create zones for
>	each of the root servers that has a IPv6 address to test
>	IPv6 support.
>
>zone "f.root-servers.net" {
...

I appreciate the work around and the engineering coolness associated 
with it but when it comes to an operational environment configured 
data is to be avoided.  Why, if message size isn't the issue, are 
there no AAAA resource records for the roots in DNS?  I thought the 
issue was message size.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                                +1-571-434-5468
NeuStar

3 months to the next trip.  I guess it's finally time to settle down and
find a grocery store.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: [email-masked]
Date: Tue, 15 Nov 2005 14:50:17 +0000

> there no AAAA resource records for the roots in DNS?  I thought the 

	message size is only one consideration. given the number of
	"legacy" IMRs running a variety of older software, consideration
	should be made for code that fails to comprend unknown RR types.
	or, we can just declare that such code is broken and we don't care
	if they stop working. (try that on for size ICANN!!!)

---

From: Edward Lewis <[email-masked]>
Date: Tue, 15 Nov 2005 10:51:04 -0500

>	if they stop working. (try that on for size ICANN!!!)

What's an IMR?  I learned of IMP's in my History of the Internet 
course, but not IMR. ;)

What is the problem if the AAAA is not understood?  Is the 
implication that this software just stops working?  The old software 
will likely also be unable to make use of an IPv6 address even if it 
recognized it.

As someone said in the hallway last month, some bad ideas will cause 
"broken things to stop working."

---

From: [email-masked]
Date: Tue, 15 Nov 2005 16:35:01 +0000

> What's an IMR?  I learned of IMP's in my History of the Internet 

	read the list archives... :)
	Iterative Mode Resolver ... or in depricated parlance, caching server

> will likely also be unable to make use of an IPv6 address even if it 

	perhaps the best examples are documented in an upcoming SAINT paper.
	the failures range from failure to continue processing to returning
	A data instead of the AAAA data.

> "broken things to stop working."

	yup, but there is something to be said for stability.

---

From: Mark Andrews <[email-masked]>
Date: Wed, 16 Nov 2005 07:38:51 +1100

> 	if they stop working. (try that on for size ICANN!!!)
	
	You mean all those nameservers which will break when they recieve
	AAAA record in response to a ./NS query but also do not break when
	handed a referral to the COM/NET/SE/FR servers and whatever other TLD
	with nameservers answering on IPv6.

	AAAA has been it the wild for many years now.  The only place
	in the DNS heirachy that it is not returned is with non-delegation
	answers from the root.

; <<>> DiG 8.3 <<>> soa com @a.root-servers.net 
; (1 server found)
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15018
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 13, ADDITIONAL: 15
;; QUERY SECTION:
;;	com, type = SOA, class = IN

;; AUTHORITY SECTION:
com.			2D IN NS	A.GTLD-SERVERS.NET.
com.			2D IN NS	G.GTLD-SERVERS.NET.
com.			2D IN NS	H.GTLD-SERVERS.NET.
com.			2D IN NS	C.GTLD-SERVERS.NET.
com.			2D IN NS	I.GTLD-SERVERS.NET.
com.			2D IN NS	B.GTLD-SERVERS.NET.
com.			2D IN NS	D.GTLD-SERVERS.NET.
com.			2D IN NS	L.GTLD-SERVERS.NET.
com.			2D IN NS	F.GTLD-SERVERS.NET.
com.			2D IN NS	J.GTLD-SERVERS.NET.
com.			2D IN NS	K.GTLD-SERVERS.NET.
com.			2D IN NS	E.GTLD-SERVERS.NET.
com.			2D IN NS	M.GTLD-SERVERS.NET.

;; ADDITIONAL SECTION:
A.GTLD-SERVERS.NET.	2D IN AAAA	2001:503:a83e::2:30
A.GTLD-SERVERS.NET.	2D IN A		192.5.6.30
G.GTLD-SERVERS.NET.	2D IN A		192.42.93.30
H.GTLD-SERVERS.NET.	2D IN A		192.54.112.30
C.GTLD-SERVERS.NET.	2D IN A		192.26.92.30
I.GTLD-SERVERS.NET.	2D IN A		192.43.172.30
B.GTLD-SERVERS.NET.	2D IN AAAA	2001:503:231d::2:30
B.GTLD-SERVERS.NET.	2D IN A		192.33.14.30
D.GTLD-SERVERS.NET.	2D IN A		192.31.80.30
L.GTLD-SERVERS.NET.	2D IN A		192.41.162.30
F.GTLD-SERVERS.NET.	2D IN A		192.35.51.30
J.GTLD-SERVERS.NET.	2D IN A		192.48.79.30
K.GTLD-SERVERS.NET.	2D IN A		192.52.178.30
E.GTLD-SERVERS.NET.	2D IN A		192.12.94.30
M.GTLD-SERVERS.NET.	2D IN A		192.55.83.30

;; Total query time: 232 msec
;; FROM: drugs.dv.isc.org to SERVER: 198.41.0.4
;; WHEN: Wed Nov 16 07:26:04 2005
;; MSG SIZE  sent: 21  rcvd: 509
 
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: David Conrad <[email-masked]>
Date: Tue, 15 Nov 2005 10:13:21 -0800

Bill,

> 	yup, but there is something to be said for stability.

Seems to me there is a fairly binary choice:

0) Add <new technology> to the root zone and risk breaking things.
1) Don't add <new technology> to the root zone and get stuck in the  
eighties.

I didn't particularly like the 80's myself, but I'm sure that's just me.

It is too bad that the politics of the DNS world don't allow the  
existence of multiple DNS infrastructures implementing the same DNS  
content (e.g., a different set of root hints that reflected servers  
that supported <new technology>, leaving the "classic" root hints  
pointing to servers that don't support <new technology>).  Ah well,  
I'm sure the ISPs around the world will be happy when their customers  
call them asking why DNS answers are ... different.

Rgds,
-drc

---

From: [email-masked]
Date: Tue, 15 Nov 2005 23:55:22 +0000

> I didn't particularly like the 80's myself, but I'm sure that's just me.

	had to give up polyester and chest hair... the mores the pity.

> call them asking why DNS answers are ... different.

	change invites disaster, to some anyway. the concerns, as i
	understand them are:  how much damage and can any of it be 
	pre-empted by education and upgrades?  so the question becomes
	not so much binary by analog...  yes, we add new technology, but
	at what cost?

> -drc

-- bill (who recommends you get a hair cut and a real job)