Subject: Re: base32 alphabet rant - rhaaaaa rfc3548

From: Simon Josefsson <[email-masked]>
Date: Tue, 15 Nov 2005 14:55:05 +0100

Roy Arends <[email-masked]> writes:

> On Sat, 22 Oct 2005, Simon Josefsson wrote:
>
>> Roy Arends <[email-masked]> writes:
>>
>>> There exist multiple base32 alphabets. The two mostly used are
>>> "A-Z2-7" (examples in rfc3548) and "0-9A-V" (examples in rfc2938).
>>
>> We could update RFC 3548 to add an alternative base32 alphabet, to
>> handle this problem.  I have some other pending nits to that document,
>> available from <http://josefsson.org/base-encoding/>.
>
> That would be a good thing.

I have submitted the draft, and it has been published (see below).

Are there any base-* considerations that you need for NSEC3 that isn't
in the document?  Any other suggestions?  If not, I'll ask the RFC
Editor to publish it.

Thanks,
Simon

> 	Title		: The Base16, Base32, and Base64 Data Encodings
> 	
>    This document describes the commonly used base 64, base 32, and base
>    16 encoding schemes.  It also discusses the use of line-feeds in
>    encoded data, use of padding in encoded data, use of non-alphabet
>    characters in encoded data, and use of different encoding alphabets.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-josefsson-rfc3548bis-00.txt

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Roy Arends <[email-masked]>
Date: Tue, 15 Nov 2005 15:10:42 +0100 (CET)

> in the document?  Any other suggestions?  If not, I'll ask the RFC

Not that I can think of, though I suggest to rewrite the ambiguous "zero 
bits are added" into "bits with value zero are added" (which appears twice 
in the document).

Thanks,

Roy

---

From: Simon Josefsson <[email-masked]>
Date: Tue, 15 Nov 2005 15:22:32 +0100

Roy Arends <[email-masked]> writes:

> Not that I can think of, though I suggest to rewrite the ambiguous
> "zero bits are added" into "bits with value zero are added" (which
> appears twice in the document).

Fixed in my local copy, thanks.

Btw, the live version can be tracked through:

http://josefsson.org/base-encoding/

Regards,
Simon

---

From: Ben Laurie <[email-masked]>
Date: Tue, 15 Nov 2005 15:12:11 +0000

> in the document?  Any other suggestions?  If not, I'll ask the RFC

Yes, it should be case-blind. I was going to say that in the NSEC3 I-D, 
but far better if its in RFC3548bis.

-- 
http://www.apache-ssl.org/ben.html       http://www.thebunker.net/
**  ApacheCon - Dec 10-14th - San Diego - http://apachecon.com/ **
"There is no limit to what a man can do or how far he can go if he
doesn't mind who gets the credit." - Robert Woodruff

---

From: Ben Laurie <[email-masked]>
Date: Tue, 15 Nov 2005 15:15:02 +0000

Roy Arends wrote:
> bits are added" into "bits with value zero are added" (which appears 
> twice in the document).

Hmm. Can I be lazy and ask if it supports unpadded modes? If not, can it?

---

From: Simon Josefsson <[email-masked]>
Date: Tue, 15 Nov 2005 16:41:52 +0100

> Hmm. Can I be lazy and ask if it supports unpadded modes? If not, can it?

They aren't discussed.  I need them in the SASL GS2-* mechanism as
well (seems I ended up as co-author on that..), so adding a section on
that seem appropriate.  I have added it to the todo list.

Thanks,
Simon