Subject: Re: Non-terminal-wildcards Re: SRV records considered dubious

From: Tony Finch <[email-masked]>
Date: Mon, 4 Dec 2006 14:25:44 +0000

On Fri, 24 Nov 2006, Olaf M. Kolkman wrote:
>
> I think that most folk seem to agree that the "**" (terminal) super-wildcard
> could be implemented using a preprocessor [3], personally I think that such
> mechanism does not need a protocol action. I also think that there are still
> folk that would like to see a solution for the not-so-terminal wildcard
> (_foo.*.example.com) although we have not seen any concrete solutions and
> there is doubt that deployment of such (protocol) extension would ever happen.

CSA specifies that clients can perform a limited walk up the DNS to search
for CSA SRV records, as an alternative to wildcarding.
http://mipassoc.org/csv/draft-ietf-marid-csv-csa-02.html

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
BISCAY FITZROY: SOUTHWEST 6 TO GALE 8, INCREASING SEVERE GALE 9 IN NORTHWEST.
ROUGH OR VERY ROUGH. RAIN LATER. GOOD.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 4 Dec 2006 06:48:17 -0800

> From: Tony Finch [mailto:[email-masked]] On Behalf Of 
> 
> > I think that most folk seem to agree that the "**" (terminal) 
> > super-wildcard could be implemented using a preprocessor [3], 
> > personally I think that such mechanism does not need a protocol 
> > action. I also think that there are still folk that would 
> like to see 
> > a solution for the not-so-terminal wildcard
> > (_foo.*.example.com) although we have not seen any concrete 
> solutions 
> > and there is doubt that deployment of such (protocol) 
> extension would ever happen.
> 
> CSA specifies that clients can perform a limited walk up the 
> DNS to search for CSA SRV records, as an alternative to wildcarding.

This is the problem though.

Heuristic walks up and down the DNS hierarchy are the quick and easy fix. The problem is that they are inefficient and they change the semantics of DNS administrative boundaries.