Subject: Re: draft-ietf-dnsext-rfc2672bis-dname-09.txt: CNAME synthesis

From: Mark Andrews <[email-masked]>
Date: Fri, 08 Feb 2008 11:36:36 +1100

I suggest we leave the last paragraph of 3.2.  CNAME synthesis
	out. 

   Servers MUST be able to answer a query for a synthesized CNAME.  An
   answer containing the synthesized CNAME cannot contain an error
   (since a CNAME has been followed), as per RFC 1034 CNAME rules.

	The part of RFC 1034 that says this make authoritative and
	recursive servers inconsistant.  I prevents a recursive
	server have a local copy of a zone which has a CNAME that
	points to a non-existant name, directly or indirectly.  I
	believe this part of RFC 1034 need to be cleaned up.

	If we leave the last paragraph out we don't need to revisit
	this document when we clean up RFC 1034.

	Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Mark Andrews <[email-masked]>
Date: Fri, 08 Feb 2008 11:54:23 +1100

> 	this document when we clean up RFC 1034.

	Given the offending text from RFC 1034 is repeated in this
	document we need to address this issue now rather than
	wait.

	Mark