Subject: I-D Action:draft-ietf-dnsext-forgery-resilience-02.txt

From: [email-masked]
Date: Mon, 18 Feb 2008 13:00:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DNS Extensions Working Group of the IETF.

	Title           : Measures for making DNS more resilient against forged answers
	Author(s)       : B. Hubert, R. van Mook
	Filename        : draft-ietf-dnsext-forgery-resilience-02.txt
	Pages           : 21
	Date            : 2008-02-18

The current Internet climate poses serious threats to the Domain Name
System.  In the interim period before the DNS protocol can be secured
more fully, measures can already be taken to harden the DNS to make
'spoofing' a recursing nameserver many orders of magnitude harder.

Even a cryptographically secured DNS benefits from having the ability
to discard bogus answers quickly, as this potentially saves large
amounts of computation.

By describing certain behaviour that has previously not been
standardised, this document sets out how to make the DNS more
resilient against accepting incorrect answers.  This document updates
RFC 1034.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dnsext-forgery-resilience-02.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of 
the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then
	"get draft-ietf-dnsext-forgery-resilience-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-dnsext-forgery-resilience-02.txt".

NOTE:   The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Mark Andrews <[email-masked]>
Date: Tue, 19 Feb 2008 10:22:23 +1100

This is the second time in recent weeks that a draft that
	should have been there was not.  Instead of draft I'm 
	getting the expired boiler plate for the previous revision
	of the draft.  Something is systematically going wrong.

	Mark

% fetch http://www.ietf.org/internet-drafts/draft-ietf-dnsext-forgery-resilience-02.txt
draft-ietf-dnsext-forgery-resilience-02.txt   100% of  973  B 2399 kBps
farside.isc.org:marka {2} % fetch ftp://ftp.ietf.org/internet-drafts/draft-ietf-dnsext-forgery-resilience-02.txt
draft-ietf-dnsext-forgery-resilience-02.txt   100% of  973  B  476 kBps
% cat draft-ietf-dnsext-forgery-resilience-02.txt

This Internet-Draft, draft-ietf-dnsext-forgery-resilience-01.txt, has expired, and has been deleted 
from the Internet-Drafts directory.  An Internet-Draft expires 185 days from 
the date that it is posted unless it is replaced by an updated version, or the
Secretariat has been notified that the document is under official review by the
IESG or has been passed to the RFC Editor for review and/or publication as an 
RFC.  This Internet-Draft was not published as an RFC.

Internet-Drafts are not archival documents, and copies of Internet-Drafts that have 
been deleted from the directory are not available.  The Secretariat does not have 
any information regarding the future plans of the author(s) or working group, if 
applicable, with respect to this deleted Internet-Draft.  For more information, or 
to request a copy of the document, please contact the author(s) directly.

Draft Author(s):
Remco van Mook <[email-masked]>,
Bert Hubert <[email-masked]>
% date
Mon Feb 18 23:21:37 UTC 2008
% 

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/namedroppers/>

---

From: Chris Thompson <[email-masked]>
Date: Tue, 19 Feb 2008 12:22:57 +0000 (GMT)

> 	of the draft.  Something is systematically going wrong.

Certainly looks like it:

$ ftp ftp.ietf.org
Connected to ftp.ietf.org.
[...]
ftp> dir /internet-drafts/draft-ietf-dnsext-forgery-resilience-*
-rw-r--r--    1 0        0             973 Feb 16 05:01 draft-ietf-dnsext-forgery-resilience-02.txt
-rw-r--r--    1 30       8           30427 Feb 18 20:50 draft-ietf-dnsext-forgery-resilience-02.xml

The XML version seems to be correct.

-- 
Chris Thompson
Email: [email-masked]

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 28 Feb 2008 09:29:14 +0100

On Tue, Feb 19, 2008 at 10:22:23AM +1100,
 Mark Andrews <[email-masked]> wrote 
 a message of 43 lines which said:

> 	should have been there was not.  Instead of draft I'm getting
> 	the expired boiler plate for the previous revision of the
> 	draft.  Something is systematically going wrong.

This has been reported to AMS ([rt.amsl.com #2282]) and they replied
the problem is now fixed (but the draft disappeared, it has to be
re-submitted).