Subject: [dnsext] comments on draft-ietf-dnsext-dnssec-alg-allocation-00

From: Jim Reid <[email-masked]>
Date: Mon, 11 Jan 2010 12:22:13 +0000

I've reviewed the above draft and support it going forward. Some of  
the language though is clunky and could be improved:

In Section 2:

"For example, an algorithm might be sponsored by a government and use  
cryptography that has not been evaluated thoroughly enough to be able  
to be put on Standards Track.  Another example is that the algorithm  
might have an unclear intellectual property rights situation, and that  
prevents the algorithm from being put on Standards Track."

could be replaced by:

"For instance an algorithm may have IPR or other complications  
preventing it receiving the thorough evaluation needes for a Standards  
Track RFC.

"relatively rarely" (relative to what?) should be changed to  
"infrequently"

The sentence "Because.... half full." is very awkward. I suggest the  
replacement text below:

"To address concerns about the registry eventually filling up, the  
IETF SHOULD re-evaluate the requirements for entry into this registry  
no later than whenever 50% of the registry entries have been assigned."

---

From: Joe Abley <[email-masked]>
Date: Tue, 12 Jan 2010 11:57:15 -0500

On 2010-01-11, at 07:22, Jim Reid wrote:

> I've reviewed the above draft and support it going forward. Some of the language though is clunky and could be improved:
> 
> In Section 2:
> 
> "For example, an algorithm might be sponsored by a government and use cryptography that has not been evaluated thoroughly enough to be able to be put on Standards Track.  Another example is that the algorithm might have an unclear intellectual property rights situation, and that prevents the algorithm from being put on Standards Track."
> 
> could be replaced by:
> 
> "For instance an algorithm may have IPR or other complications preventing it receiving the thorough evaluation needes for a Standards Track RFC.

Perhaps s/needes for a Standards Track RFC/required by the Standards Track/ with an informational xref to 2026.

> "relatively rarely" (relative to what?) should be changed to "infrequently"
> 
> The sentence "Because.... half full." is very awkward. I suggest the replacement text below:
> 
> "To address concerns about the registry eventually filling up, the IETF SHOULD re-evaluate the requirements for entry into this registry no later than whenever 50% of the registry entries have been assigned."

s/no later than whenever/as soon as/ also seems like it might enhance clarity.

Joe