Subject: Re: TCP details Re: [dnsext] Draft: WGLC draft-ietf-dnsext-dns-tcp-requirements

From: Alfred Hönes <[email-masked]>
Date: Tue, 23 Feb 2010 12:24:30 +0100 (MEZ)

On Mon, 22 Feb 2010 23:53:46 +0000, Paul Vixie wrote:

>> On Mon, Feb 22, 2010 at 1:09 PM, Olafur Gudmundsson <[email-masked]> wrote:
>>>    Do the members of the working group think this document,
>>>    that specifies that TCP transport must be supported by all DNS
>>>    implementation is beneficial?
>
> +1.

+1

>> Date: Mon, 22 Feb 2010 13:25:22 -0800
>> From: Matthew Dempsky <[email-masked]>
>>
>> "all DNS implementations", no; "all *general purpose* DNS
>> implementations", yes.
>
> i think this horse is dead.  rbldnsd and other non-general-purpose subset
> implementations already leave out so many required elements of the protocol,
> that adding one more required element that these don't implement, is no big
> deal.  can we please move on.

+1.

The only sensical text addition I can imagine to address concerns,
might be (because this document aims at being a clarification of
STD13 and STD3) :

  "all DNS implementations that claim conformance to STD 13 [RFC1035]"

Is that a compromise wording approachable to general consensus?

Best regards,
  Alfred.

---

From: William Allen Simpson <[email-masked]>
Date: Wed, 24 Feb 2010 14:25:26 -0500

+1

+1

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 24 Feb 2010 12:55:48 -0800

At 2:25 PM -0500 2/24/10, William Allen Simpson wrote:
>Alfred ? wrote:

+1

+1

---

From: Basil Dolmatov <[email-masked]>
Date: Thu, 25 Feb 2010 11:21:48 +0300

+1