Subject: [dnsext] V4-V6 DNS Proxying

From: Sabahattin Gucukoglu <[email-masked]>
Date: Fri, 12 Mar 2010 13:24:43 +0000

Hi all,

Can anybody think of a particularly good reason why a DNS proxy, say running on a home LAN gateway, couldn't receive DNS traffic on either of v4 or v6 interfaces and then pass it to the "WAN" side, untouched, using the other?  This should ideally work without breaking stuff, which includes a completely transparent packet forwarder with knowledge of fragmentation.  Especially for v4, the attractive aspect of a DNS proxy is of course that the LAN's DHCP server need not know anything about the exterior interface or its configuration before offering addresses to internal clients.  So, unless I'm missing anything, the packet payloads themselves should be easily forwarded.  An ideal gateway would of course provide the option to switch this off.

Cheers,
Sabahattin

---

From: [email-masked]
Date: Fri, 12 Mar 2010 13:50:36 +0000

> Can anybody think of a particularly good reason why a DNS proxy, say
> running on a home LAN gateway, couldn't receive DNS traffic on 
> either of v4 or v6 interfaces and then pass it to the "WAN" side, 
> untouched, using the other?

No specific reasons I can think of except for fragmentation.

However many vendors of such proxies can't even do the 4-to-4 case 
properly :(

See RFC 5625.

Ray