Subject: [dnsext] ECC-Gost DNSKEY and DS values assigned

From: Olafur Gudmundsson <[email-masked]>
Date: Mon, 05 Apr 2010 16:36:47 -0400

I want to point out to implementors that IANA has assigned the
values requested in dnssec-gost document.

For DNSKEY
ECC-GOST == 11

http://www.iana.org/assignments/dns-sec-alg-numbers/dns-sec-alg-numbers.xhtml

for DS
GOST R 34.11-94 == 3

http://www.iana.org/assignments/ds-rr-types/ds-rr-types.xhtml

I expect the RFC to show up in before the end of May.

	Olafur

---

From: Chris Thompson <[email-masked]>
Date: 06 Apr 2010 14:54:48 +0100

>http://www.iana.org/assignments/dns-sec-alg-numbers/dns-sec-alg-numbers.xhtml

I note that this is incompatible with

https://datatracker.ietf.org/doc/draft-ietf-dnsext-dnssec-registry-fixes/

which wants 11 to be "Reserved until 2020".

-- 
Chris Thompson               University of Cambridge Computing Service,
Email: [email-masked]    New Museums Site, Cambridge CB2 3QH,
Phone: +44 1223 334715       United Kingdom.

---

From: "Rose, Scott W." <[email-masked]>
Date: Tue, 6 Apr 2010 10:58:57 -0400

Obviously draft-registry-fixes will need to change with the updated IANA assigned values.

Scott

On 4/6/10 9:54 AM, "Chris Thompson" <[email-masked]> wrote:

===================================
Scott Rose
NIST
[email-masked]
ph: +1 301-975-8439
Google Voice: +1-571-249-3671

http://www.dnsops.gov/
===================================

---

From: Chris Thompson <[email-masked]>
Date: 07 Apr 2010 14:29:42 +0100

>Obviously draft-registry-fixes will need to change with the updated

Yes, but wasn't the idea of marking 9 & 11 as reserved that they had
been used surreptitiously for NSEC3-ised versions of RSASHA256 and
RSASHA512 (before the NSEC3-support-is-implied-anyway decision was
taken)? If that's actually thought to be a non-issue after all, then
reserving 9 doesn't make sense either.

I think the real point I was trying to make is that apparently the IANA
weren't being kept informed of the thinking behind (or maybe even the
existence of) the registry-fixes draft.

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 7 Apr 2010 11:34:49 -0400

> reserving 9 doesn't make sense either.

Yes, that's right.

> existence of) the registry-fixes draft.

No, unfortunately they were, but they seem not to have caught this.
Neither did your Chairs, unfortunately.  I'm not sure what we're going
to be able to do about it.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Olafur Gudmundsson <[email-masked]>
Date: Wed, 07 Apr 2010 13:32:25 -0400

Thanks Chris,
I should have engaged my brain last week on vacation
when IANA asked for confirmation of the allocation :-)

I just had a discussion with IANA about this issue.
IANA will change the allocation from 11.

Once the new allocation is complete I will notify the
mailing list.

	Sorry about the confusion
	Olafur

---

From: Olafur Gudmundsson <[email-masked]>
Date: Mon, 12 Apr 2010 22:33:50 -0400

IANA updated the DNSKEY algorithm registry
http://www.iana.org/assignments/dns-sec-alg-numbers/
	12 ECC-GOST

The DS digest allocation is the same as before.

	Olafur