Subject: [dnsext] [Technical Errata Reported] RFC4398 (2460)

From: RFC Errata System <[email-masked]>
Date: Sat, 7 Aug 2010 13:44:24 -0700 (PDT)

The following errata report has been submitted for RFC4398,
"Storing Certificates in the Domain Name System (DNS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4398&eid=2460

--------------------------------------
Type: Technical
Reported by: Paul Freeman <[email-masked]>

Section: 2

Original Text
-------------
2.  The CERT Resource Record

   The CERT resource record (RR) has the structure given below.  Its RR

   type code is 37.

                       1 1 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 2 2 3 3

   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |             type              |             key tag           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |   algorithm   |                                               /

   +---------------+            certificate or CRL                 /

   /                                                               /

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-|

Corrected Text
--------------
2.  The CERT Resource Record

   The CERT resource record (RR) has the structure given below.  Its RR

   type code is 37.

                        1 1 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 2 2 3 3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |             type              |             key tag           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |   algorithm   |                                               /

   +---------------+            certificate or CRL                 /

   /                                                               /

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-|

Notes
-----
In Section 2 (The CERT Resource Record) the table describing the wire format of the CERT RR is misaligned in such a way that it could lead to technical ambiguity of field positions within the packet structure.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4398 (draft-ietf-dnsext-rfc2538bis-09)
--------------------------------------
Title               : Storing Certificates in the Domain Name System (DNS)
Publication Date    : March 2006
Author(s)           : S. Josefsson
Category            : PROPOSED STANDARD
Source              : DNS Extensions
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 9 Aug 2010 11:36:03 -0400

Thanks for checking this.  The erratum is fine.

On Sun, Aug 08, 2010 at 11:20:03AM +0200, Simon Josefsson wrote:
> Thanks for the report.  It appears correct to me.
> 
> /Simon
> 
> RFC Errata System <[email-masked]> writes:
> 

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Simon Josefsson <[email-masked]>
Date: Sun, 08 Aug 2010 11:20:03 +0200

[ Moderators note: Post was moderated, either because it was posted by
   a non-subscriber, or because it was over 20K.  
   With the massive amount of spam, it is easy to miss and therefore 
   delete relevant posts by non-subscribers. 
   Please fix your subscription addresses. ]

/Simon