Subject: [dnsext] WG Action: RECHARTER: DNS Extensions (dnsext)

From: IESG Secretary <[email-masked]>
Date: Tue, 7 Dec 2010 09:43:52 -0800 (PST)

The DNS Extensions (dnsext) working group in the Internet Area of the IETF
has been rechartered.  For additional information, please contact the Area
Directors or the working group Chairs.

DNS Extensions (dnsext)
---------------------------------------------------
Current Status: Active Working Group

Chairs:
  Olafur Gudmundsson <[email-masked]>
  Andrew Sullivan <[email-masked]>

Internet Area Directors:
  Ralph Droms <[email-masked]>
  Jari Arkko <[email-masked]>

Internet Area Advisor:
  Ralph Droms <[email-masked]>

Mailing Lists:
  Address:	[email-masked]
  To Subscribe:	https://www.ietf.org/mailman/listinfo/dnsext
  Archive:	http://www.ietf.org/mail-archive/web/dnsext/

Description of Working Group:

The DNS has a large installed base and repertoire of protocol
specifications. The DNSEXT working group will actively advance DNS
protocol-related RFCs on the standards track while thoroughly
reviewing further proposed extensions. The scope of the DNSEXT WG is
confined to the DNS protocol, particularly changes that affect DNS
protocols "on the wire" or the internal processing of DNS data. DNS
operations are out of scope for the WG.

The WG will consider work in the following areas:

* DNSSEC and TSIG/TKEY algorithm maintenance
* Mechanisms that complement, or are alternatives to, TSIG and SIG(0)
* Hardening DNS protocol and providing guidance to implementers
* Advancing existing DNS-related Proposed Standard RFCs to Draft/Full
  Standard
* Obsoleting DNS-related RFCs
* Maintaining a Wiki containing a guide to DNS protocol RFCs
* Improving DNS zone synchronization mechanisms 
* Examining transport protocols, possibly adding new ones.
* Mechanisms to alias DNS trees or parts thereof

While the DNS offers two mechanisms for aliasing DNS labels -- CNAME
and DNAME -- neither of these provides the support necessary to alias
completely one part of the DNS tree as another part.  There are claims
that the restriction has proven to be too great in practice,
particularly with burgeoning deployment of IDNA and the need to
provide domain name variants.  The issue is made more complex by
DNSSEC

The DNSEXT WG will evaluate ways to provide such aliasing, to add
metadata to zones to allow easier operation of zones when such
aliasing is needed, or both.  The WG will also provide an
informational document outlining the various strategies available,
what they might be used for, and what their limitations are.  It is
possible that the WG will conclude no aliasing or metadata support is
possible, or that none of the proposals so far made are adequate.

Before formal adoption of any work item at least 5 working group
participants must publicly state that the item is within charter and
is a worthwhile item for further study.

The DNSEXT WG will conduct the specified RFC5395 review of RR
templates as they are posted, and EDNS0 Option templates if EDNS0-bis
updates registration requirements.

The WG will review DNS protocol related work which may originate
elsewhere in the IETF, including AD-sponsored submissions or drafts
in other working group.

Goals and Milestones:

Done           AXFR Clarify to IESG
Done           DNS existing transport protocol
                    recommendations/clarifications to IESG
Dec 2010       RFC3597-bis Unknown RR advanced to IESG for PS 
Dec 2010       DNSKEY Registry fixes and allocation procedure
                    advanced to IESG
Dec 2010       EDNS0-bis update advanced to IESG
Dec 2010       TSIG/MD5 Obsoleting to IESG
Dec 2010       IXFR-only to IESG
Jan 2011       DNSSEC Errata document to IESG 
Jul 2011       WG consensus on new or revised RRTYPEs for aliasing
                    work
Jul 2011       Interoperation testing on new or revised RRTYPEs
                    (particularly with existing deployed code)
Nov 2011       Document on new RRTYPE or revised RRTYPE handling for
                    alias to IESG
Nov 2011       Document on in-zone metadata for aliases to IESG
Nov 2011       Document on uses and limitations of different alias
                    techniques to IESG

_______________________________________________
dnsext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsext

---

From: Alex Nicoll <[email-masked]>
Date: Tue, 7 Dec 2010 14:21:08 -0500

As a relative newbie to this group, and a long time lurker, can anyone tell me where the DNS RFC Wiki that is mentioned in the charter is located?  I have recently become aware of a similar effort by others outside the IETF, and I would like to be able to compare the two.  It was also the focus of an "Ask Slashdot" question I posted some while back, and I think that there may be others who are interested as well.

Thank you,

Alex

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of IESG Secretary
Sent: Tuesday, December 07, 2010 12:44 PM
To: IETF Announcement list
Cc: [email-masked]
Subject: [dnsext] WG Action: RECHARTER: DNS Extensions (dnsext)

DNS Extensions (dnsext)

Chairs:

Internet Area Directors:

Internet Area Advisor:

Mailing Lists:
  Address:	[email-masked]

Goals and Milestones:

---

From: Olafur Gudmundsson <[email-masked]>
Date: Tue, 07 Dec 2010 14:40:59 -0500

http://trac.tools.ietf.org/wg/dnsext/trac/wiki

---

From: Alex Nicoll <[email-masked]>
Date: Tue, 7 Dec 2010 16:07:14 -0500

The other effort is a start up by Dave Crocker of BBIW, with some help by Ray Bellis (and others), located at http://bbiw.net/clusters/#clusterdnsrole.  Ray had put together a very cool perl script that helped people figure out how to traverse RFC chains, and reported the results graphically.  The idea behind Dave's effort is to get all of the information about a specific topic in one place and grouped together so that idiots like me don't have to go play "hunt and peck" in an RFC repository to try to find everything relevant to a topic.  I tried to do that using the RFC chaining information, but when I was done, I really wasn't sure if I was DONE, or if I had missed something - there was no way to know.

I am very interested in the idea of codifying the documentation of the DNS protocol (maybe as a template for other protocols) in a way such that idiots like me can have a chance to really get a complete picture of how it all works, without buying implementation specific books (like BIND).

-Alex

-----Original Message-----
From: Andrew Sullivan [mailto:[email-masked]] 
Sent: Tuesday, December 07, 2010 2:42 PM
To: Alex Nicoll
Subject: Re: [dnsext] WG Action: RECHARTER: DNS Extensions (dnsext)

> As a relative newbie to this group, and a long time lurker, can anyone tell me where the DNS RFC Wiki that is mentioned in the charter is located?  I have recently become aware of a similar effort…

I guess to "maintain" it we are supposed to "create" it too.  But I'm slightly alarmed, because this post seems to have a previous version of the charter.  I'll follow up and report to the WG.

In the meantime, where is the other effort?  Maybe we can help with it.

A

--
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 7 Dec 2010 16:14:56 -0500

On Tue, Dec 07, 2010 at 04:07:14PM -0500, Alex Nicoll wrote:

> The other effort is a start up by Dave Crocker of BBIW, with some
> help by Ray Bellis (and others), located at
> http://bbiw.net/clusters/#clusterdnsrole.

Right, I saw that.  It's a little shy on many of the details, but it's
not wrong, I think.

>  Ray had put together a
> very cool perl script that helped people figure out how to traverse
> RFC chains, and reported the results graphically. 

That tool is indeed cool.  And it is something we talked about using
in the past.  Glad it'd been useful in Dave's effort.

> I am very interested in the idea of codifying the documentation of
> the DNS protocol (maybe as a template for other protocols) in a way
> such that idiots like me can have a chance to really get a complete
> picture of how it all works, without buying implementation specific
> books (like BIND).

The WG actually undertook an effort of this sort a few years ago, and
it was a massive failure.  It's where the idea for the wiki came from,
but I think we have concluded that such a wiki isn't really a proper
job of the WG (and the version of the charter that should have been
published -- I attach it below for posterity -- doesn't include it).

A

---

From: Alex Nicoll <[email-masked]>
Date: Wed, 8 Dec 2010 10:35:26 -0500

I agree that it is shy on some details, and I hope to help them flesh things out quite a bit over time.  Are you folks using other tools like that to consolidate the current RFC list?  From reading the list for a while, the bulk of you seem to have an encyclopedic knowledge of the protocol and associated RFCs.  If there are methods you have for correlating all of the RFCs into a cohesive whole, I think it would be very valuable to the internet community at large.

-Alex

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew Sullivan
Sent: Tuesday, December 07, 2010 4:15 PM
To: [email-masked]
Subject: Re: [dnsext] WG Action: RECHARTER: DNS Extensions (dnsext)

On Tue, Dec 07, 2010 at 04:07:14PM -0500, Alex Nicoll wrote:

> The other effort is a start up by Dave Crocker of BBIW, with some help 
> by Ray Bellis (and others), located at 

Right, I saw that.  It's a little shy on many of the details, but it's not wrong, I think.

> RFC chains, and reported the results graphically.

That tool is indeed cool.  And it is something we talked about using in the past.  Glad it'd been useful in Dave's effort.

> I am very interested in the idea of codifying the documentation of the 
> DNS protocol (maybe as a template for other protocols) in a way such 
> that idiots like me can have a chance to really get a complete picture 
> of how it all works, without buying implementation specific books 
> (like BIND).

The WG actually undertook an effort of this sort a few years ago, and it was a massive failure.  It's where the idea for the wiki came from, but I think we have concluded that such a wiki isn't really a proper job of the WG (and the version of the charter that should have been published -- I attach it below for posterity -- doesn't include it).

A

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 8 Dec 2010 13:50:02 -0500

On Wed, Dec 08, 2010 at 10:35:26AM -0500, Alex Nicoll wrote:
> flesh things out quite a bit over time.  Are you folks using other
> tools like that to consolidate the current RFC list? 

If anyone is doing serious work on such consolidation, it's news to
me.  Are you volunteering?  I think this is important work, but nobody
seems to have the time for it (as measured by the previous output on the task).

A

---

From: Alex Nicoll <[email-masked]>
Date: Wed, 8 Dec 2010 13:58:05 -0500

I may gnaw my tongue off later for saying this, but sure, I'll volunteer.  I've been given some time per week to devote to outside projects by my boss here at CERT, so I'd be happy to help.  I can't think of a better way to learn everything about DNS and DNSSEC than to try to make the documentation make sense to someone else.  

Ultimately, it's not nearly as sexy as fixing issues with the DNS protocol itself, but it's a good way to make sure I don't say too many stupid things when talking about the protocol with you folks.

I didn't see anything on the wiki link that Olafur sent out that looked like a start at this, so do you (or anyone else on the list) have anything that was created during the initial effort?

-Alex

-----Original Message-----
From: Andrew Sullivan [mailto:[email-masked]] 
Sent: Wednesday, December 08, 2010 1:50 PM
To: Alex Nicoll
Cc: [email-masked]
Subject: Re: [dnsext] WG Action: RECHARTER: DNS Extensions (dnsext)

> tools like that to consolidate the current RFC list?

If anyone is doing serious work on such consolidation, it's news to me.  Are you volunteering?  I think this is important work, but nobody seems to have the time for it (as measured by the previous output on the task).

A

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Dec 2010 11:16:33 -0800

>Ultimately, it's not nearly as sexy as fixing issues with the DNS protocol itself, but it's a good way to make sure I don't say too many stupid things when talking about the protocol with you folks.

Further, I would be a fair amount that when you document a list of "anomalous things in DNS", you will (or at least should) cause issues to be fixed in the DNS protocol. This is a valuable first step to that.

--Paul Hoffman, Director
--VPN Consortium