Subject: (NAT) Another Question

From: "Tang, Tom J" <[email-masked]>
Date: Mon, 4 Oct 1999 11:00:53 -0700

Mike :

    I have another question which you might have an 
  answer for.  It is based on the diagram below :

     -----------               -------------
     | Client  |               |  Gateway  | <---> IP1
     |   One   | <-----------> |  /Server  | <---> IP2
     -----------               -------------

    Say I am using an application (i.e. ftp) which 
  has a control channel and a separate data channel.
  Say the following occurs :

  * Client requests resources
  * Server assigns resources based on IP1
  * Client establishes control channel
  * Client tries to establish data channel, runs
    out of ports
  * Client requests more resources
  * Server assigns resources based on IP2
  * Client tries to establish data channel using
    IP2 resources.
  * Ftp would see two separate IP addresses.
    Not acceptable ?

    This is a potential problem for any application
  which tries to establish multiple flows.  Is there 
  a solution for this ?

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: Gabriel Montenegro <[email-masked]>
Date: Mon, 4 Oct 1999 13:45:34 -0700 (PDT)

again, if the client is allowed to suggest values at the same time it
requests them, this problem should go away, i think. this is a simple
change to the protocol. actually, i suggested it a few months back
but the idea was to postpone such things for later. perhaps now
is the time?

>   * Client requests more resources

...and suggests IP1 as the ip address assigned along with the new
	resources

    * Server heeds client's hint and assigns resources
	based on IP1.
    * all is cool, 

>   * Server assigns resources based on IP2

    * Client goes back to step above requesting new
      resources based on IP1 (see above)...

-