Subject: RE: (NAT) RSIP Port Usage Question

From: "Tang, Tom J" <[email-masked]>
Date: Fri, 1 Oct 1999 15:56:15 -0700

gabriel :

    This is exactly what I am suggesting.  But it would
  require the differentiation of messages sent 
  between the server and client when using different protocols.
  I believe one of the goals of RSIP was to be protocol 
  agnostic and was thus hoping there might be a better solution.

-----Original Message-----
From: Gabriel Montenegro [mailto:[email-masked]]
Sent: Friday, October 01, 1999 3:15 PM
To: Tang, Tom J
Cc: [email-masked]'
Subject: Re: (NAT) RSIP Port Usage Question

tom,

would this problem be helped by perhaps *allowing* the 
client to suggest hints as to the assignments it would like to get?

basically, the client asks:

	"hi, i'd like to eventually reach <ultimate_destination>
	and in order to do so i need port(s) and here are some
	hints as to those values"

benefit of allowing the client to suggest port number hints:

	the server would know which port numbers/ranges are likely
	to be usable by the client (the example you brought up)

benefit of allowing the client to specify who the ultimate destination is:

	besides the network interface closest to the client, the server may
'
	have several interfaces on the "other" side(s). this hint may be, in
	fact, a requirement in order to know which outgoing interface
	must be used. if each interface is connected to a separate address
	space, the rsip server needs to lend the rsip client an address on
	the right address space. [this is not nearly as urgent a need as
	the previous item on port assignment, though].

-gabriel

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.
-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 1 Oct 1999 18:56:55 -0700 (PDT)

>   between the server and client when using different protocols.

why? if the client wants a port in the 500-1000 range, and
if the rsip server grants him one, what else is needed?
i can see adding a new type of rsip message if a new type
of demultiplexing tuple needs to be negotiated, but in your
case, that does not seem to be the case as the demultiplexing
fields are still

	port number
	ip address

right? or is there any additional field that needs to be negotiated?

-gabriel

-