Subject: RE: (NAT) RSIP over TCP stream

From: "Saint-Hilaire, Ylian" <[email-masked]>
Date: Wed, 3 Nov 1999 12:52:16 -0800

Unless we find consenses on the transport, as it stands RSIP servers will
most likely be implemented to allow  both TCP and UDP (but not required to).
This way clients have a choice, home and corporate products will be ok with
the standard and we don't risk getting into a "doing IKE over TCP" like
discussion. It may be a drag on developpers, but will keep everyone happy.

Ylian Saint-Hilaire
Intel - Communication Architecture Labs

-----Original Message-----
From: Mike Borella [mailto:[email-masked]]
Sent: Wednesday, November 03, 1999 10:56 AM
To: Saint-Hilaire, Ylian
Cc: [email-masked]; Saint-Hilaire, Ylian; [email-masked]
Subject: RE: (NAT) RSIP over TCP stream

Is there any particular reason that you feel this way?

-Mike

"Saint-Hilaire, Ylian" <[email-masked]> on 11/03/99 10:57:45
AM
Please respond to "Saint-Hilaire, Ylian" <[email-masked]>
Sent by:  "Saint-Hilaire, Ylian" <[email-masked]>

To:   Mike Borella/MW/US/3Com, [email-masked]
cc:   "Saint-Hilaire, Ylian" <[email-masked]>,
[email-masked]
Subject:  RE: (NAT) RSIP over TCP stream

The message size in the header simply solves the problem of identifying the
end of a the message in a stream based protocol (like TCP). The message size
is sufficient to solve this. As to using TCP or UDP, I would favor keeping
the document as-is.

Ylian Saint-Hilaire

-----Original Message-----
From: Mike Borella [mailto:[email-masked]]
Sent: Wednesday, November 03, 1999 8:25 AM
To: [email-masked]
Cc: 'Saint-Hilaire, Ylian'; [email-masked]
Subject: RE: (NAT) RSIP over TCP stream

This is more or less what we have, though we don't have enough
practical experience with the protocol to say for sure that it is
sufficient.
The advantage of TCP is not necessarily flow control or congestion control,
just
reliability.  That simplifies the protocol greatly by reducing the number of
failure
states.    On the other hand, UDP is more conducive for light clients.

-Mike

"Bernard Aboba" <[email-masked]> on 11/02/99 11:29:58 PM

Please respond to [email-masked]

Sent by:  "Bernard Aboba" <[email-masked]>

To:   Mike Borella/MW/US/3Com, "'Saint-Hilaire, Ylian'"
      <[email-masked]>
cc:   [email-masked]
Subject:  RE: (NAT) RSIP over TCP stream

>This speaks to an even larger issue: should RSIP recommend TCP or UDP?

Yes. Making a choice will simplify interoperability testing.

One of the things to consider in making the choice is whether you
will need things like RTT estimation, congestion control, or
windowing in your control channel transport. These things tend
to matter if you believe that the RSIP client and gateway could
be separated by a WAN (e.g. a Mobile IP scenario), not just
communicating over a LAN.

If none of these considerations are worth much, then you might
as well go with UDP with a specified retransmission algorithm
(e.g. exponential backoff).

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.
-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.
-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: "Bernard Aboba" <[email-masked]>
Date: Thu, 4 Nov 1999 08:07:26 -0800

Well, it avoids a flamewar, but when the time comes to do
your bakeoffs and interoperability testing, you can have
lots of complications. Some things to think about:

1. Is both UDP and TCP support required on both client
and gateway? Or is one a MUST and the other a SHOULD or MAY?
If the latter, how does a client determine which the
server will support?

2. Should a client choose UDP or TCP and use the same transport
for *all* control channel traffic to the gateway? For all
communication to the gateway with respect to a given
destination?

3. If the client can use UDP for some traffic, and TCP for
other traffic, how should it make the decision?

4. Are there some messages that SHOULD be sent using
TCP? (I'm thinking about route payloads in excess of
the MTU size).

5. Are certain behaviors prohibited, such as:
	a. Getting a lease over UDP and renewing it over TCP?
	b. Having a client send UDP to the gateway and receiving
		a response over TCP?
	c. Sending the same request on both UDP and TCP?

-----Original Message-----
From: Saint-Hilaire, Ylian [mailto:[email-masked]]
Sent: Wednesday, November 03, 1999 12:52 PM
To: 'Mike Borella'
Cc: [email-masked]; [email-masked]
Subject: RE: (NAT) RSIP over TCP stream

Ylian Saint-Hilaire

-