Subject: Re: (NAT) Changes for RSIP protocol -04

From: "Mike Borella" <[email-masked]>
Date: Mon, 22 Nov 1999 14:10:57 -0600

Not necessarily.  Depends on the size of the network.  Theoretically,
RSIP can support 10's of thousands of client all sharing 1 IP address.

Realistically, far fewer, but hundreds of clients per address is still
reasonable.
You're more likely to run into congestion on the router before RSIP itself
is the bottleneck.

-Mike

"Steven M. Bellovin" <[email-masked]> on 11/22/99 12:59:20 PM

Sent by:  "Steven M. Bellovin" <[email-masked]>

To:   Mike Borella/MW/US/3Com
cc:   Pyda Srisuresh <[email-masked]>, Eliot Lear <[email-masked]>,
      [email-masked]
Subject:  Re: (NAT) Changes for RSIP protocol -04

In message <[email-masked]>, "Mike Borella" writes:
>
>
> Not exactly.  The hosts may need public addresses all of the time.
> RSIP allows multiple hosts to share the same address w/o permanent
> assignment.  If addresses weren't a presumed scarcity, we'd just use
> DHCP.

This is exactly my point.  Yes, hosts can share addresses, but that only works
when most don't need outside addresses most of the time.

          --Steve Bellovin

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 23 Nov 1999 23:51:01 -0800

If RSIP leases are set to long times then
connections will remain up but most of the
time they won't be sending very much. This has the
result of adding lots of state to the gateway
but not much in the way of traffic. On the other
hand if the lease times are set lower then many
of those connections will age out. You'll have more
control traffic but less gateway state.

BTW, I am curious about the implications of not
differentiating between allocation of TCP and UDP
ports in RSIP. The case I have in mind is a DNS
server behind an RSIP gateway (strange, I know). It will forward
DNS queries to another server, and so will ask for a source port to
send to dest port UDP 53. If it then attempts to do a zone transfer
from that same dest, and again makes a request for a source
port to send to dest port 53 (TCP this time) what happens? Does
RSIP allocate another port? Does it return an error saying
"sorry, gave you one already?"

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Mike Borella
Sent: Monday, November 22, 1999 12:11 PM
To: Steven M. Bellovin
Cc: Pyda Srisuresh; Eliot Lear; [email-masked]
Subject: Re: (NAT) Changes for RSIP protocol -04

-Mike

In message <[email-masked]>, "Mike Borella"
> assignment.  If addresses weren't a presumed scarcity, we'd just use

This is exactly my point.  Yes, hosts can share addresses, but that only
works
when most don't need outside addresses most of the time.

          --Steve Bellovin

-

-