Subject: (NAT) RSIP and PPTP

From: Oliveira Paul-LPO117 <[email-masked]>
Date: Mon, 22 Nov 1999 09:46:52 -0500

How do we demultiplex PPTP traffic. Specifically PPTP's enhanced GRE header
over IP.  I believe the Call ID field of the Key could be used, but how does
the RSIP server tell the RSIP client what to use for the Call ID?  Do we
need another message pair like we did for IPSec and IKE?

Paul
-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: [email-masked]
Date: Wed, 24 Nov 1999 07:27:28 -0600

Yes, this was brought up 1+ years ago, but never got addressed.
The call ID field was mentioned.  Thanks for volunteering, Bernard. :-)

-Mike

"Bernard Aboba" <[email-masked]> on 11/24/99 01:39:06 AM

Please respond to "Bernard Aboba" <[email-masked]>

Sent by:  "Bernard Aboba" <[email-masked]>

To:   "'Oliveira Paul-LPO117'" <[email-masked]>, "'Nat'"
      <[email-masked]>
cc:    (Mike Borella/MW/US/3Com)
Subject:  RE: (NAT) RSIP and PPTP

Looks like an RSIP extension is needed for PPTP. I'll pull together
some thoughts on how this might work and will post it to the list.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Oliveira Paul-LPO117
Sent: Tuesday, November 23, 1999 6:35 AM
To: 'Nat'
Subject: FW: (NAT) RSIP and PPTP

> in the nar draft i suggested another alternative to demultiplex
> encapsulations based on either gre or IPinIP: use the internal
> addresses for demultiplexing. perhaps both this and the capability
> to use the gre key id field are needed. not hard to define these.
>
> -gabriel
>

Gabriel

This will not work because; a) The internal IP address(es) will be the same
(that is the whole purpose of RSIP) and b) in most cases the payload (which
includes IP Header) will be encrypted anyway.

Paul
-

-

-