Subject: RE: (NAT) SNMP application layer gateway

From: Pyda Srisuresh <[email-masked]>
Date: Tue, 12 Dec 2000 14:48:07 -0800 (PST)

Randy and Rohit,

Please see my comments below.

cheers,
suresh

--- Randy Turner <[email-masked]> wrote:
>  
> Obviously, this cannot be a generic SNMP management station, because
> management stations just don't do this kind of thing.  I haven't been
> following the MIB standardization process very closely, but I'm assuming
> that someone is working on  a "standard" NAT MIB? I would think you would
> need the ALG support anyway. It would cover far more cases than a management
> station approach.

No one is working on a "standard NAT MIB", as far as I know. I.e., we dont
have a draft yet. In the event of a NAT MIB becoming available, I dont
see why that has any dependency on SNMP-ALG support. As far as I can tell,
NAT MIB and SNMP-ALG are orthogonal issues. 

> 
> Randy
> 
> -----Original Message-----
> From: Rohit
> To: [email-masked]
> Cc: [email-masked]
> Sent: 12/11/00 9:04 PM
> Subject: (NAT) SNMP application layer gateway
> 
> Hi, 
> 
>   One of our customer is asking us for the support of 
>   SNMP application layer gateway on CISCO router.
> 
>   RFC2962 covers most of the aspect of the SNMP ALG.
>    
>   As we don't want to use router resources for SNMP ALG 
>   then according to RFC2962  it can be a separate entity, that may
>   reside on a separate node.
> 

Thus far, I understand what you say.

>   But we are planning for an alternate solution where we will
>   define an NAT-MIB which will define the NAT Translation Table.
>   The Management station will query the NAT-MIB and perform the
>   address translation at the management station itself.
> 
That sounds fine as well. Are the address maps static or dynamic?
You may have a problem with dynamic maps.

>   We believe that it should solve the payload translation problem
>   (which ALG would have done otherwise). It would be nice if
>   someone from this alias could comment on the same.

If the managment station is doing the translation of the payload,
then the management station has the ALG funtion within it. You are
suggesting that the managment station obtain the translation table
from the NAT router through a MIB.

SO far, I dont see any contradiction in terms with RFC 2962.

>   Thanks
>   Rohit

cheers,
suresh

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/
-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.

---

From: Rohit <[email-masked]>
Date: Wed, 13 Dec 2000 10:10:22 +0530

Hi, 

  Is it possible that we go ahead with writing a "standard NAT-MIB" and 
  then present our MIB to this alias to be accepted as an draft ?

  Thanks
  Rohit 

-

---

From: Matt Holdrege <[email-masked]>
Date: Wed, 13 Dec 2000 10:25:54 -0800

>   then present our MIB to this alias to be accepted as an draft ?

Such an effort would be very welcome. Understand that once a draft is 
accepted as a working group item it will be subject to the wishes of the 
working group. If you haven't written an IETF MIB before, I recommend 
looking at some of the recent MIB RFC's to understand the style.

-

---

From: rrohit <[email-masked]>
Date: Thu, 14 Dec 2000 12:36:48 +0600

Hi Matt,

 I have written CISCO Specific MIBS in past.
 I will certainly look at some of the recent MIB RFC's to understand the
style.

 Thanks
  Rohit

-