Subject: (NAT) how to implement NAT in Mobile IP?

From: Tao Huang <[email-masked]>
Date: Mon, 28 Feb 2000 12:32:14 +0000

Hi, everybody

I have a question, how does NAT implement in mobile IP?  is there any solution( or product ) available to implement NAT in Mobile IP? Is it possible?

I spent a long time on searching the information about it and found a lot of questions simily like this without any answer. 

Any informations are welcome.

Regards,
Tao Huang
[email-masked]

-
To unsubscribe, email [email-masked]' with
'unsubscribe nat' in the body of the message.
List archive: <URL:http://www.portmasters.com/archives/>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 28 Feb 2001 08:29:15 -0600

Since Mobile IP depends on globally routable addresses, there is
a fundamental problem here. RFC 2993 and 3027 don't mention Mobile IP,
as a case that NAT can't handle, but probably should.

Thomas Narten said to me in private mail long ago:

> [Mobile IP] Registration Request/Reply messages which are sent
> between the mobile host and home agent include IP addresses in the UDP
> payload. In some cases, these messages are covered by an authentication
> header, so even a mobile-IP aware NAT box couldn't twiddle the bits.

   Brian

-

---

From: gabriel montenegro <[email-masked]>
Date: Wed, 28 Feb 2001 17:52:17 +0100

If what you're asking is how to handle private addresses, you might want to read
the appendix in http://www.ietf.org/rfc/rfc3024.txt
The folks at the National Univ of Singapore (http://mip.ee.nus.edu.sg/) also had some work (RATS),
although that link seems to be broken now.

-gabriel

-