Subject: Re: [NAT] TCP checksum adjustment in NAT

From: Pyda Srisuresh <[email-masked]>
Date: Sat, 1 Sep 2001 13:06:15 -0700 (PDT)

Hi Kavleen,

sounds like a vendor specific problem. You should
contact your vendor about this. Thanks.

cheers,
suresh

--- Kavleen Bhatia <[email-masked]> wrote:
> Hi,
> 
> I am currently implementing NAT on VxWorks. I am not able to calculate the
> adjustment to the TCP Checksum. The packet is not received at the destination
> due to bad checksum.
> 
> could anybody provide any pointers to the same.
> 
> Kavleen
> 

=====

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

_______________________________________________
nat mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/nat

---

From: "Kjeld Borch Egevang" <[email-masked]>
Date: Sat, 1 Sep 2001 22:51:19 +0200

Hi Kavleen.

If your TCP checksum is bad, it might be because you forgot to include the
pseudo header in the checksum calcalution.

I can recommend, that you adjust the TCP checksum incrementelly (based on
old address/port and new address/port). This will ensure that if the
checksum was bad due to a transmission error in the path it will still be
bad.

Try to dump that packet, and calculate the TCP checksum by hand before and
after NAT.

/Kjeld

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Kavleen
Bhatia
Sent: 29. august 2001 13:56
To: [email-masked]
Subject: [NAT] TCP checksum adjustment in NAT

Hi,

I am currently implementing NAT on VxWorks. I am not able to calculate the
adjustment to the TCP Checksum. The packet is not received at the
destination due to bad checksum.

Kavleen