Subject: Re: [nat66] Terminology: Definition for "IPv6 Realm"?

From: james woodyatt <[email-masked]>
Date: Mon, 3 May 2010 10:53:24 -0600

On Apr 29, 2010, at 23:30, Keith Moore wrote:
> 
> I agree that the concept of ??? (reachability boundaries?) needs a name.

On May 3, 2010, at 10:37, Fred Baker wrote:
> 
> Maybe. I personally am not sure it needs a name. I agree that it is not a "realm" in the sense that the term is used in IPv4.

For my part, I've found it very confusing-- especially here in the context of the NAT66 list-- when the word "realm" is used to reference the mathematical concept of an address domain in IPv4, and as something else entirely different in IPv6.  I only recently became aware that people were doing this, and I still don't understand why.

I like Keith's proposal to use the word "enclave" to describe a network region, comprising one or more routing domains, where a distinguished subset of network addresses are only reachable between one another and not reachable from addresses outside the region.  I think this concept naturally goes with the RFC 4193 concept of unique local addresses, and I wish it had been introduced there.

--
james woodyatt <[email-masked]>
member of technical staff, communications engineering

---

From: Fred Baker <[email-masked]>
Date: Mon, 3 May 2010 10:36:09 -0700

> I like Keith's proposal to use the word "enclave" to describe a network region, comprising one or more routing domains, where a distinguished subset of network addresses are only reachable between…

wfm

http://www.ipinc.net/IPv4.GIF