Subject: Re: [nat66] Fwd: New Version Notification for draft-mrw-nat66-00

From: Roger Marquis <[email-masked]>
Date: Thu, 21 Oct 2010 08:52:56 -0700 (PDT)

Margaret Wasserman wrote:
> On Oct 19, 2010, at 9:31 AM, <[email-masked]> wrote:
>> Have you considered selection of ULA prefix(es) for internal network
>> in such a manner that it/they can be translated to NAT uplink's /64
>> prefix in checksum neutral fashion?
>>
> This is an interesting idea, however it undermines the purpose of
> NAT66...  If the internal addresses are chosen to allow checksum
> neutral translation to external addresses, then the internal addresses
> will need to be changed whenever the site is renumbered by an ISP, or
> when a site changes ISPs.

Regardless of NAT I'd be interesting in seeing a working example where
internal hosts renumber successfully for any reason, much less in
response to external renumbering.  How would, for example, a persistent
(internal-internal) database connection be renumbered securely?

Used to be the IEFT required a reproducible working implementation before
considering this sort of RFC.  Has that policy been discontinued?

Roger Marquis

---

From: Fred Baker <[email-masked]>
Date: Thu, 21 Oct 2010 17:42:20 -0400

> considering this sort of RFC.  Has that policy been discontinued?

I think you are discussing routing protocols, which require interoperable working implementations to go to proposed standard. 

However, prototypes have been built, multiple, of the original proposal, which was to update the checksum in bits 48..63 of the address. One prototype was built by BUPT students and reported on in terms of the end to end identity issues in an IEEE workshop in spring 2009 IIRC, and a more recent one was done by Sven-Ola Tuecke. I don't believe that we have prototyped the work in the EID that Margaret has in this draft, but we have done mathematical correctness checks.

Begin forwarded message:

> From: "Sven-Ola Tuecke" <[email-masked]>
> Date: October 6, 2010 5:31:58 AM EDT
> To: [email-masked], [email-masked]
> Subject: NAT66 implementation
> 
> Hi,
> 
> FYI: you may be interested in my implementation of NAT66 for Linux netfilter, 
> available under http://map66.sf.net/ It works and I just completed the 
> documentation, see http://map66.svn.sourceforge.net/viewvc/map66/README.txt
> 
> With kind regards,
> // Sven-Ola

---

From: Rémi Després <[email-masked]>
Date: Mon, 25 Oct 2010 10:40:23 +0200

Le 21 oct. 2010 à 23:42, Fred Baker a écrit :
> ...
> I don't believe that we have prototyped the work in the EID that Margaret has in this draft
> ...

I couldn't understand what you mean by EID (sorry if it is obvious).

RD