Subject: [nbs] Fwd:draft-scharf-mptcp-api-03.txt

From: RJ Atkinson <[email-masked]>
Date: Wed, 20 Oct 2010 14:23:43 -0400

This new I-D seems like it might be relevant to this list.

Given the likely near-term deployment of MP/TCP, it would
seem sensible that any API work not preclude interworking
of applications using any new abstracted API with MP/TCP
underneath.

Yours,

Ran

Begin forwarded message:
> From: [email-masked]
> Date: 20 October 2010 13:30:01 EDT
> To: [email-masked]
> Subject: I-D Action:draft-scharf-mptcp-api-03.txt 
> content-type: Multipart/Mixed; Boundary="NextPart"
> mime-version: 1.0
> message-id: <[email-masked]>
> x-beenthere: [email-masked]
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : MPTCP Application Interface Considerations
> 	Author(s)       : M. Scharf, A. Ford
> 	Filename        : draft-scharf-mptcp-api-03.txt
> 	Pages           : 25
> 	Date            : 2010-10-20
> 
> Multipath TCP (MPTCP) adds the capability of using multiple paths to
> a regular TCP session.  Even though it is designed to be totally
> backward compatible to applications, the data transport differs
> compared to regular TCP, and there are several additional degrees of
> freedom that applications may wish to exploit.  This document
> summarizes the impact that MPTCP may have on applications, such as
> changes in performance.  Furthermore, it discusses compatibility
> issues of MPTCP in combination with non-MPTCP-aware applications.
> Finally, the document describes a basic application interface for
> MPTCP-aware applications that provides access to multipath address
> information and a level of control equivalent to regular TCP.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-scharf-mptcp-api-03.txt

---

From: "SCHARF, Michael" <[email-masked]>
Date: Wed, 20 Oct 2010 22:15:47 +0200

Of course, this draft is work in progress.

Please let us know if you have any specific suggestions or comments.

Thanks

Michael

-----Ursprüngliche Nachricht-----
Von: [email-masked] im Auftrag von RJ Atkinson
Gesendet: Mi 20.10.2010 20:23
An: [email-masked]
Betreff: [nbs] Fwd:draft-scharf-mptcp-api-03.txt

Yours,

Ran

> http://www.ietf.org/internet-drafts/draft-scharf-mptcp-api-03.txt

_______________________________________________
nbs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nbs