Subject: [nbs] First draft agenda

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Oct 2010 12:26:30 +0000

Hi all,

Christian Vogt and I (Martin Stiemerling, NEC) have been appointed as chairs for this BoF. 

We are in the process of compiling the final agenda based on the previous proposed agenda. 
However, the below agenda is "reduced" compared to the prior version as we still discuss on how to fit the various presentations in a structure. There is no loss in terms of presentations, we will update the agenda in the next 2 days with more details.

It seems that we have two bigger areas to be handled separately during the BoF:

- API issues
- Stack Change Proposals (below the API doing all the magic)

and this is reflected in the agenda proposal below.

I also would like to compile a reading list to get interested people up to speed. Please send suggestions to Christian and me.

Here is the draft agenda for the NBS BoF at IETF-79 and comments/suggestions are welcome:

Name Based Sockets - BoF
Draft Agenda 

MONDAY, November 8, 2010
0900-1130  Morning Session I
Garden Ballroom 3

Mailing list:
[email-masked]

Chairs:
Martin Stiemerling ([email-masked])
Christian Vogt ([email-masked])

**Proposed Agenda**

* Agenda bashing

* General Overview - Christian Vogt

* API related
 * presentations: tbd.

* Stack Change Proposals
  * presentations: tbd.

* How to continue with NBS: Scope & Where to do the work

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Lars Eggert <[email-masked]>
Date: Wed, 27 Oct 2010 09:32:47 +0300

Hi,

> - Stack Change Proposals (below the API doing all the magic)

I'd like to add a third issue, which to me is as important: where are the OS and application implementors that want the NBS extensions? I have no doubt that we could specify the technical details needed to make NBS work; I wonder who would care if we did.

Lars

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 27 Oct 2010 07:59:04 +0000

Hi Lars,

a valid point. 

Do we have anybody out of the space of OS vendors and application
implementers on the list here that can speak up in that respect? (now or at
the meeting)

Thanks,

  Martin

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London
W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: Lars Eggert [mailto:[email-masked]]
> Sent: Wednesday, October 27, 2010 8:33 AM
> To: Martin Stiemerling
> Cc: [email-masked]
> Subject: Re: [nbs] First draft agenda
> 
> Hi,
> 
> I'd like to add a third issue, which to me is as important: where are
> the OS and application implementors that want the NBS extensions? I
> have no doubt that we could specify the technical details needed to
> make NBS work; I wonder who would care if we did.
> 
> 
> Lars

---

From: Rémi Després <[email-masked]>
Date: Wed, 27 Oct 2010 14:33:50 +0200

Hi, Lars,

Yes, knowing whether some OS or application implementers already are, at this early stage, interested in Name Based Sockets  can be a useful third issue.

But even if there is none today, this IMHO doesn't mean that those that are ready to spend energy to make a sound proposal should be discouraged: 
- We know we need referrals that don't depend on addresses (addresses may be dynamic or subject to renumbering).
- Using names for this is an alternative to other locator/identifier separation approaches.
- It has the distinct advantage leveraging existing Internet specifications such as the DNS and IPv6 address formats, rather than departing from them.

For OS and Application vendors to make their an opinion, clearly explaining first what is meant by named based sockets seems a quite reasonable approach.

Regards,
RD

Le 27 oct. 2010 à 08:32, Lars Eggert a écrit :

> Lars_______________________________________________
> nbs mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nbs

---

From: Lars Eggert <[email-masked]>
Date: Wed, 27 Oct 2010 15:59:16 +0300

HI,

> - It has the distinct advantage leveraging existing Internet specifications such as the DNS and IPv6 address formats, rather than departing from them.

I'm with you until here.

> For OS and Application vendors to make their an opinion, clearly explaining first what is meant by named based sockets seems a quite reasonable approach.

Here I have to disagree. We don't (normally) charter WGs in the IETF to explain technologies. We charter WGs to produce specifications so that interoperable implementations can be built. A specification is not a good way to explain a technology or motivate its adoption, that needs to come *first*.

Lars

---

From: Rémi Després <[email-masked]>
Date: Wed, 27 Oct 2010 15:33:10 +0200

> Here I have to disagree. We don't (normally) charter WGs in the IETF to explain technologies. We charter WGs to produce specifications so that interoperable implementations can be built. A specific…

Eggs or chicken problem!
You obviously know IETF rules much better than I do.
A WG may very well be premature at this stage.
What I hope though, if it is so, is that IETF can continue to be a place where solutions to identified problems can be discussed among specialists.
The lack of referrals that applications can use, and that don't depend on address changes is AFAIK an one of these identified problems. 

Regards,
RD

---

From: Lars Eggert <[email-masked]>
Date: Wed, 27 Oct 2010 17:15:55 +0300

Hi,

> The lack of referrals that applications can use, and that don't depend on address changes is AFAIK an one of these identified problems. 

that I certainly agree with. And I may well have misjudged OS and application developer interest, we will find out at the BOF.

Lars

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Oct 2010 09:47:03 +1300

> that I certainly agree with. And I may well have misjudged OS and application developer interest, we will find out at the BOF.

I notice that you have bumped draft-carpenter-referral-ps-01
from the agenda. But actually the issue of getting OS and apps
interest seems to be exactly the same for the two topics.
By the way, the BOF clashes with the apparea open meeting, where
I also want to present my draft. (I also need to be in softwire
at the same time.)

    Brian

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 28 Oct 2010 07:28:37 +0000

Hi Brian,

Nope, your presentations has not been bumped, as stated in the original email:

> There is no loss in terms of presentations.

There will be an updated agenda by today with presentations on it, as Christian and I are reorganizing the agenda to get it more structured.

 Martin

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, October 27, 2010 10:47 PM
> To: Lars Eggert; Martin Stiemerling
> Cc: [email-masked]
> >> What I hope though, if it is so, is that IETF can continue to be a
> place where solutions to identified problems can be discussed among
> specialists.
> >> The lack of referrals that applications can use, and that don't
> depend on address changes is AFAIK an one of these identified problems.
> >
> > that I certainly agree with. And I may well have misjudged OS and
> application developer interest, we will find out at the BOF.
>