Subject: [nbs] setsockopt() is bad.

From: Javier Ubillos <[email-masked]>
Date: Mon, 08 Nov 2010 16:13:48 +0800

Dave.

You spoke during todays bof (and just now at the MPTCP group) about your
previous experience where setsockopt()s where not a great way to go.

What did you end up doing (other than moving the setsockopt()s to the
appendix).

What was the right way to do it then?

// Javier

---

From: Dave Thaler <[email-masked]>
Date: Mon, 8 Nov 2010 10:05:34 +0000

> -----Original Message-----
> From: Javier Ubillos [mailto:[email-masked]]
> Sent: Monday, November 08, 2010 4:14 PM
> To: Name-based Sockets List nbs; Dave Thaler
> Cc: Javier Ubillos
> Subject: setsockopt() is bad.
> 
> Dave.
> 

See RFC 3678, especially section 2.
Short answer: new functions

-Dave