Subject: Re: [nbs] NBS conflict with MEXT

From: "David Harrington" <[email-masked]>
Date: Tue, 2 Nov 2010 07:58:37 +0800

Hi,

NBS touches a wide variety of protocols and layers.
That is a major reason why the BOF is NOT a WG-forming BOF, but a
technology-exploring BOF.
We are looking to see what technologies might be impacted, and where
such work should be done.

The API bridges between an Application and a transport, and work could
be done in either area.
NBS separates identifier from locator, so could be impacted by HIP
and/or LISP.
NBS will discuss mobility, so there are multiple related mobility WGs
to avoid.
NBS might substitute one transport conection for another, which could
impact security.
All of this will need to be operated and managed, so will likely
impact OPS (where SHIM had problems due to operator pushbock, as I
recall).

As I see it, no matter where you put this BOF, it will conflict with
some other scheduled sessions.
After the BOF discussions, then we can determine what technologies
(and areas) might be impacted.
Then we can either redirect the work to existing WGs, or have one or
more BOFs focused on specific aspects.
I encourage the bulk of the discussion to happen on the NBS MAILING
LIST, not in the BOF.

So my tendency is to say, let's just leave the BOF where it is.

(and I consider the WG-Chairs list the wrong place for this
discussion. Please use the [email-masked] list.
https://www.ietf.org/mailman/listinfo/nbs )

David Harrington
Director, IETF Transport Area
[email-masked] (preferred for ietf)
[email-masked]
+1 603 828 1401 (cell)

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Joe Touch
> Sent: Tuesday, November 02, 2010 6:44 AM
> To: Joe Touch
> Cc: WG Chairs; Laganier, Julien
> Subject: Re: NBS conflict with MEXT
> 
> 
> 
> On Nov 1, 2010, at 3:39 PM, Joe Touch <[email-masked]> wrote:
> 
> > I am hoping none of the issues cited will be in scope, and 
> thus this overlap wouldn't matter.  
> > 
> > NBS can - and IMO should - be limited to effect during initial
conn
> 
> Connection. All other proposals require revision to transport 
> and higher protocols that rely on IP adds as endpoint names, 
> and this revisits HIP and is not described yet enough. 
> 
> Joe 
> 
> 
> > 
> > On Nov 1, 2010, at 2:16 PM, Christian Vogt 
> <[email-masked]> wrote:
> > 
> >> For me, moving the NBS BoF to Wednesday morning would be fine.
> >> 
> >> - Christian
> >> 
> >> 
> >> 
> >> You wrote:
> >> 
> >>> Folks -
> >>> 
> >>> I know it is very late but I just noticed that the NBS 
> BoF conflicts
> >>> With MEXT on Monday morning, which is especially 
> unfortunate since NBS
> >>> has impact on session continuity, mobility and ID/loc 
> split, which are
> >>> also related to MEXT. I am also very interested in NBS 
> but needs to
> >>> co-chair MEXT
> >>> 
> >>> I am not sure something can still be done to resolve the 
> conflict, but
> >>> FWIW, I'd like to know how people would feel about a swap 
> that looks
> >>> relatively benign: swap NBS with another TSV morning 
> session, such as 
> >>> the TSVWG on Wednesday morning.  
> >>> 
> >>> Thanks,
> >>> 
> >>> --julien
> >>

---

From: Pete Resnick <[email-masked]>
Date: Wed, 3 Nov 2010 22:21:30 +0800

> NBS touches a wide variety of protocols and layers.
Touching a variety of protocols is a justification to not worry about a 
particular WG it is conflicting with. But layers is a different matter. 
You currently have NBS, ostensibly a protocol which at the very least 
will be serving the Apps layer, conflicting with the Apps *AREA* 
meeting. If most Apps people (and BOTH Apps ADs) cannot be there to 
comment on this BOF, I simply don't see the point in having it.
> The API bridges between an Application and a transport, and work could be done in either area.
>    
You bet. Which is why the almost complete absence of people in one of 
those two areas seems pretty darn goofy.
> some other scheduled sessions.
Again, one thing to conflict with a WG, another to conflict with an 
entire interested area.
> So my tendency is to say, let's just leave the BOF where it is.
I think this is phenomenally short sighted.
> discussion. Please use [email-masked]  list.

This is a BOF. Chairs who might not be aware of the BOF or have 
particular interest in the work area still might be significant input on 
this kind of conflict.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102