Subject: [ncrg] Recording of last NCRG meeting

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Thu, 5 Sep 2013 13:11:40 +0000

On Tuesday, Russ White presented his and Alvaro's draft, and we had some interesting discussion throughout the call. 
http://www.ietf.org/internet-drafts/draft-irtf-ncrg-network-design-complexity-00.txt

The recording is available here: 
https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=71094517&rKey=67cfc3967052661f

Thanks Russ for the presentation. 
Michael

---

From: Rana Sircar <[email-masked]>
Date: Thu, 5 Sep 2013 19:55:46 +0530

Hi Michael and Russ,

In continuation to our discussion in the call the other day, I thought of
jotting down my thoughts and proposal to define the problem space. We have
already seen examples of Metrics as outlined by you earlier e.g., Cost,
Bandwidth / delay / jitter, Configuration complexity, Susceptibility to
Denial-of-Service, Security (confidentiality / integrity), Scalability etc.
Russ highlighted multiple examples of pairs of Variables. Two aspects were
ongoing in my thoughts as I heard you all - how do you define this
Complexity and is there some standard term that we can borrow from Nature
and other Complexity analysis as pointed out by David.

One Term that seems to be used across Natural world for measure of
Information and disorder is Entropy. Thermodynamic Entropy is used to
measure Disorder. Similarly Shannon entropy quantifies the expected value
of the information contained in a message. Some authors have used
multiscale entropy analysis to measure complexity of network traffic (see
attached papers). As I explained the other day, I was looking at Entropy to
measure the Complexity of networks. Ofcourse, we still need to define that.

Now, let us assume that Complexity of the Network is defined by a Function
of many variables called "Network Entropy", such that the goal of every
network designer would be to minimise this Function. Then, the goal of the
Network complexity framework is:

Minimize [ Network Entropy (variable 1, variable 2, ....variable n)] ----
our  Objective Function

Now, we need to now formulate 'n' constrain equations for these variables:
1. Constraints of Cost (c1.....cn)
2. Constraints of Control Plane State
3. Constraints of Optimal Forwarding State / Paths
4. Constraints of Configuration State
5. Constraints of Failure Domain Separation
6. Constraints of Policy Architecture
7. Constraints of Configuration State etc...etc...

One aspect of draft-irtf-ncrg-network-design-complexity-00 that Russ
presented is very interesting - we can have an initial state that is at a
lower complexity level e.g., simple routing with simplest configuration and
minimum number of subscribers and simple traffic floows due to basic level
of services and Applications. Now as time grows, each of these become
complex since more subscriber / Routers / Apps / Services etc. come in.
Thus, clearly, we have an initial simple state of "Network Entropy" and
future more complex state of this variable.

There are different deployment of Networks serving different purposes and
goals. The Framework Document should provide Guidance for defining this
overall approach to simulate and optimize / minimize the Network Entropy.
Thus, based on the Usage, the Objective Function can be defined as well as
the the constraints.

Hope that I was able to put across my thoughts...

Best Regards,
Rana

Best Regards,
Rana Sircar
GSM+919899003705|

On 5 September 2013 18:41, Michael Behringer (mbehring)
<[email-masked]>wrote:

> On Tuesday, Russ White presented his and Alvaro's draft, and we had some
> interesting discussion throughout the call.
>
> _______________________________________________
> ncrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/ncrg
>

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Tue, 17 Sep 2013 08:32:25 +0000

Rana,

Apologies for the late response, I'm very much under water at the moment. If you are on today's NCRG call, I suggest we take the discussion there. I think you have very interesting ideas!

Thanks,
Michael

From: Rana Sircar [mailto:[email-masked]]
Sent: 05 September 2013 16:26
To: Michael Behringer (mbehring)
Cc: [email-masked]
Subject: Re: [ncrg] Recording of last NCRG meeting

Hi Michael and Russ,

In continuation to our discussion in the call the other day, I thought of jotting down my thoughts and proposal to define the problem space. We have already seen examples of Metrics as outlined by you earlier e.g., Cost, Bandwidth / delay / jitter, Configuration complexity, Susceptibility to Denial-of-Service, Security (confidentiality / integrity), Scalability etc. Russ highlighted multiple examples of pairs of Variables. Two aspects were ongoing in my thoughts as I heard you all - how do you define this Complexity and is there some standard term that we can borrow from Nature and other Complexity analysis as pointed out by David.

One Term that seems to be used across Natural world for measure of Information and disorder is Entropy. Thermodynamic Entropy is used to measure Disorder. Similarly Shannon entropy quantifies the expected value of the information contained in a message. Some authors have used multiscale entropy analysis to measure complexity of network traffic (see attached papers). As I explained the other day, I was looking at Entropy to measure the Complexity of networks. Ofcourse, we still need to define that.

Now, let us assume that Complexity of the Network is defined by a Function of many variables called "Network Entropy", such that the goal of every network designer would be to minimise this Function. Then, the goal of the Network complexity framework is:

Minimize [ Network Entropy (variable 1, variable 2, ....variable n)] ---- our  Objective Function

One aspect of draft-irtf-ncrg-network-design-complexity-00 that Russ presented is very interesting - we can have an initial state that is at a lower complexity level e.g., simple routing with simplest configuration and minimum number of subscribers and simple traffic floows due to basic level of services and Applications. Now as time grows, each of these become complex since more subscriber / Routers / Apps / Services etc. come in. Thus, clearly, we have an initial simple state of "Network Entropy" and future more complex state of this variable.

There are different deployment of Networks serving different purposes and goals. The Framework Document should provide Guidance for defining this overall approach to simulate and optimize / minimize the Network Entropy. Thus, based on the Usage, the Objective Function can be defined as well as the the constraints.

Best Regards,
Rana

Best Regards,
Rana Sircar
GSM+919899003705|

On 5 September 2013 18:41, Michael Behringer (mbehring) <[email-masked]<mailto:[email-masked]>> wrote:
On Tuesday, Russ White presented his and Alvaro's draft, and we had some interesting discussion throughout the call.
http://www.ietf.org/internet-drafts/draft-irtf-ncrg-network-design-complexity-00.txt

Thanks Russ for the presentation.
Michael
_______________________________________________
ncrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/ncrg

---

From: Rana Sircar <[email-masked]>
Date: Tue, 17 Sep 2013 14:24:04 +0530

Hi Michael,

Thanks a lot. I would try to be there.

Meanwhile, to upload the papers, I tried creating a Login in Wiki. But
getting an error - "out of captcha images; this shouldn't happen"

Best Regards,
Rana Sircar
GSM+919899003705|

On 17 September 2013 14:02, Michael Behringer (mbehring) <[email-masked]
> wrote:

>  Rana, ****
>
> ** **
>
> Apologies for the late response, I’m very much under water at the moment.
> If you are on today’s NCRG call, I suggest we take the discussion there. I
> think you have very interesting ideas! ****
>
> ** **
>
> Thanks,****
>
> Michael****
>
> ** **
>
> ** **
>
> *From:* Rana Sircar [mailto:[email-masked]]
> *Sent:* 05 September 2013 16:26
> *To:* Michael Behringer (mbehring)
> *Cc:* [email-masked]
> *Subject:* Re: [ncrg] Recording of last NCRG meeting****
>
> ** **
>
> Hi Michael and Russ,****
>
> ** **
>
> and other Complexity analysis as pointed out by David. ****
>
> ** **
>
> ****
> ** **
> Network complexity framework is: ****
>
> ** **
>
> our  Objective Function****
>
> ** **
>
> ****
> 1. Constraints of Cost (c1.....cn)****
>
> 2. Constraints of Control Plane State ****
>
> 3. Constraints of Optimal Forwarding State / Paths****
>
> 4. Constraints of Configuration State****
>
> 5. Constraints of Failure Domain Separation****
>
> 6. Constraints of Policy Architecture****
>
> 7. Constraints of Configuration State etc...etc...****
>
> ** **
>
> future more complex state of this variable. ****
>
> ** **
>
> the the constraints. ****
>
> ** **
>
> Hope that I was able to put across my thoughts...****
>
> ** **
>
> Best Regards,****
>
> Rana****
>
>
> ****
>
> Best Regards,
> Rana Sircar
> GSM+919899003705|****
>
> ** **
>
> On 5 September 2013 18:41, Michael Behringer (mbehring) <
> [email-masked]> wrote:****
>
> https://www.irtf.org/mailman/listinfo/ncrg****
>
> ** **
>

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Tue, 17 Sep 2013 08:58:43 +0000

Thanks. Looking forward to later on today!

Need to fix the captcha generator. In the meantime, I'll create a login for you directly, will mail it to you.

Michael

From: Rana Sircar [mailto:[email-masked]]
Sent: 17 September 2013 10:54
To: Michael Behringer (mbehring)
Cc: [email-masked]
Subject: Re: [ncrg] Recording of last NCRG meeting

Hi Michael,

Meanwhile, to upload the papers, I tried creating a Login in Wiki. But getting an error - "out of captcha images; this shouldn't happen"

Best Regards,
Rana Sircar
GSM+919899003705|

On 17 September 2013 14:02, Michael Behringer (mbehring) <[email-masked]<mailto:[email-masked]>> wrote:
Rana,

Thanks,
Michael

From: Rana Sircar [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 05 September 2013 16:26
To: Michael Behringer (mbehring)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [ncrg] Recording of last NCRG meeting

Hi Michael and Russ,

Best Regards,
Rana

Best Regards,
Rana Sircar
GSM+919899003705|