Subject: RE: [Nea] LAST CALL on NEA action plan

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Thu, 13 Apr 2006 15:36:57 -0700

Hi Steve, Susan

Apologies for not replying earlier to this action plan.

This looks like a pretty reasonable action plan to me for moving
forward. The prioritization looks good, reflects the feedback that was
received during the BoF.

Lets get started on the work items now :)

Regards
Hormuzd

-----Original Message-----
From: Steve Hanna [mailto:[email-masked]] 
Sent: Thursday, April 13, 2006 2:49 PM
To: [email-masked]
Subject: [Nea] LAST CALL on NEA action plan

I have revised the proposed NEA action plan in
response to feedback received on the NEA list
(changing item 2.D say clearly that the security
analysis will cover the entire NEA system).

If you have anything else to say about the plan,
please send email to [email-masked] by Monday.

I'd like to see a bunch of emails indicating
support for the plan or suggesting changes.
Short emails are OK. You needn't write an essay.

Thanks,

Steve

------

Proposed NEA Action Plan

1) Discuss, revise, and agree on this action plan.

2) Work on these items in parallel:

 A) Draft requirements for PA, PB, and PTT

 B) Revise proposed NEA charter to focus on
    transport-independent PA and PB and
    requirements for PTT

 C) Revise NEA problem statement to focus on
    transport-independent PA and PB and
    requirements for PTT

 D) Draft security analysis of entire NEA system

3) When we have all or most of those items in
   good shape, schedule another NEA BOF or ask
   for a WG to be created

_______________________________________________
Nea mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nea

_______________________________________________
Nea mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nea

---

From: "Blumenthal, Uri" <[email-masked]>
Date: Sun, 16 Apr 2006 10:32:53 -0400

Likewise. 

-----Original Message-----
From: Joseph Tardo [mailto:[email-masked]] 
Sent: Sunday, April 16, 2006 1:17 AM
To: Steve Hanna; [email-masked]
Subject: RE: [Nea] LAST CALL on NEA action plan

Steve,

You have my full support on this.

I am also planning to work on it.

Thanks,
--Joe

-----Original Message-----
From: Steve Hanna [mailto:[email-masked]] 
Sent: Thursday, April 13, 2006 2:49 PM
To: [email-masked]
Subject: [Nea] LAST CALL on NEA action plan

Thanks,

Steve

------

Proposed NEA Action Plan

---

From: "Sahita, Ravi" <[email-masked]>
Date: Sun, 16 Apr 2006 17:37:39 -0700

Steve,
I support the plan below, and as I mentioned earlier, would like to
volunteer to help with the PA, PB requirements.

Cheers,
Ravi

-----Original Message-----
From: Steve Hanna [mailto:[email-masked]] 
Sent: Thursday, April 13, 2006 2:49 PM
To: [email-masked]
Subject: [Nea] LAST CALL on NEA action plan

I have revised the proposed NEA action plan in response to feedback
received on the NEA list (changing item 2.D say clearly that the
security analysis will cover the entire NEA system).

If you have anything else to say about the plan, please send email to
[email-masked] by Monday.

I'd like to see a bunch of emails indicating support for the plan or
suggesting changes.
Short emails are OK. You needn't write an essay.

Thanks,

Steve

------

Proposed NEA Action Plan

---

From: "Hao Zhou \(hzhou\)" <[email-masked]>
Date: Mon, 17 Apr 2006 13:32:17 -0400

Steve:

I agree on most part of this plan and am willing to put some cycle to
it. However, I have a different take on the priorities of the items:

1. B, C, D. I think they are reasonable to be done first.

2. We may need to document the transport-independent generic
architecture and various instances of it, e.g., EAP/AAA, TLS, IPSec,
etc. I don't know whether that's already planned as part of the problem
statement or in a separate architecture draft. I think it should be done
before D.

3. A should be put to last, after we have dome some security analysis. I
don't think it is critical to have that ready before we propose for WG
or another BOF. It could be part of workgroup charter and items to be
worked on. 

> Sent: Thursday, April 13, 2006 5:49 PM
> To: [email-masked]
> I have revised the proposed NEA action plan in response to 
> feedback received on the NEA list (changing item 2.D say 
> clearly that the security analysis will cover the entire NEA system).
> 
> If you have anything else to say about the plan, please send 
> email to [email-masked] by Monday.
> 
> I'd like to see a bunch of emails indicating support for the 
> plan or suggesting changes.

---

From: "Paul Sangster" <[email-masked]>
Date: Mon, 17 Apr 2006 11:00:48 -0700

> Short emails are OK. You needn't write an essay.

I'm happy to help with the documents and believe the plan reflects the
feedback we heard at the BOF to focus on the more transport independent
aspects of the architecture (EAP vs. IPsec and others.)

---

From: "Brian Ford \(brford\)" <[email-masked]>
Date: Tue, 18 Apr 2006 11:44:15 -0400

Steve,

Thanks for your great work here.  I'd certainly like to contribute to
the effort to further the action plan.  I'd like to volunteer as a
contributor and / or reviewer.

I think we all need to keep a eye on the problem that NEA is being
formed and developed to address.  From the problem statement "...to
assess the software or hardware configuration of endpoint devices for
the purposes of monitoring or enforcing compliance of endpoints to an
organization's policy on access to the network.".  Interoperability and
standards are great as long as they go towards solving the original
problem.

"The computer is the first metamedium, and as such it has degrees of
freedom for representation and expression never before encountered and
as yet barely investigated." Alan Kay

Liberty for All,

Brian 

QUOTE
 Message: 3
Date: Fri, 7 Apr 2006 10:16:54 -0400
From: Steve Hanna <[email-masked]>
Subject: [Nea] Next steps for NEA
To: [email-masked]
Message-ID: <EB077C45A588684091E61B40C4BB6EC9205316@concordmail>
Content-Type: text/plain

Although the NEA BOF did not end with consensus on a charter, there were
several clear messages:

1) This is important work. Many people spoke about this.

2) We need clear interoperability goals.

3) We should standardize at least a minimal set of
   posture attributes to allow any client and server
   to have some interoperability.

4) PA and PB should be transport independent.

5) We should not spend too much time on requirements.

Based on these messages, I would like to suggest the action plan below.
Comments are welcome on the messages and action plan.

Thanks,

Steve

------

Proposed NEA Action Plan

 D) Draft NEA security analysis

UNQUOTE

------------------------------
 
Brian Ford 
Consulting Engineer
Cisco Systems, Inc.
http://www.cisco.com <http://www.cisco.com/>